Wyse Thin Client Home Assistant OS installation instructions

I had been running Home Assistant on a laptop in a Virtual Box and decided it was a waste of energy and tied up the use of the laptop. Looking at alternatives the NUC seemed an overkill for my application since I wanted a reliable server dedicated to Home Assistant that would work with my Husbzb-1. I then stumbled on Thin Clients which can be bought for $50 off eBay and are manufactured by reliable manufacturers like Dell and HP. I bought a new (2016 model) Dell Wyse 5020 with 4GB memory and 32GB Flash Drive for $50 plus shipping costs. After searching around looking for step by step instructions, I couldn’t find any. Using the help of others, I got it up and running and it has worked great. Fast boot, fast response, nice package, and low energy. For those considering this path, I created instructions (to the best of my memory) Dropbox - Thin Client setup.pdf - Simplify your life

Edit: 03-11-2021 The installation guide has been updated for the xz image format. I have tested this on both a Wyse 5020 and 7010.

Edit: 01-22-2022 unrly provides some excellent instructions for the 3040 and I would suggest anyone having trouble with my procedure to give his procedure a try. Wyse Thin Client Home Assistant OS installation instructions - #15 by unrly

Edit: 05-02-2022 This is an excellent video to a very simple way to intall HA on a Thin Client. It only requires one Flash Drive. Wyse Thin Client Home Assistant OS installation instructions - #73 by Richdem

7 Likes

Did you try just writing the NUC image to your USB with Balena Etcher as noted in the HA docs? Not familiar with working with this hardware, but have always been able to just boot straight from this method.

Id be interested in your thoughts on performance (config check, restart) compared to the laptop.

I am probably missing something, but didn’t see how to transfer from NUC image on USB to Flash Drive? The Dell 5020 Thin Client I have has a 32GB Flash Drive connected to the main board with Sata 22 pin connector. So to image it to the 32GB using Balena Etcher, I think I would have had to remove it and connect it to my PC with special cable which I don’t have. I guess the other option would have been to install an OS, then Docker, and then Home Assistant. For me, I just wanted a fully supported, dedicated Home Assistant server.
The performance has been great and built like a tank. As fast, maybe faster, than laptop. My restart fully loads in about 40 seconds which includes my Z Wave and Zigbee devices. As with all Z Wave they are not very responsive for the first few seconds after becoming available. I do miss the battery backup the laptop provided, but the Thin Client is set to Power On after Power Loss and I don’t have to mess with the Husbzb-1 after a full reboot. In Virtual Box, I would always have to unplug the Husbzb-1 and plug it back in anytime the laptop did a reboot. I switched to VMWare Workstation Player and I no longer had to unplug the Husbzb-1 but I would have to clear a Pop Up error. At least I could remote in and fix that. With the Thin Client that issue is gone. Husbzb-1 works great as it should.

You are correct, I forgot the HassOS install doesn’t let you specify a target drive. I wonder if one could write directly to the flash drive and then boot?

Wow. This is awesome. I was considering buying that very unit and having your feedback has pretty much cemented it for me. I’ve been running on a RPi 3b for over three years now, and I want something more powerful that doesn’t use SD cards.

Thanks for posting your setup document. It should make bringing it up much easier.

1 Like

Thanks for this info, I went for it, it’s been about a week since I migrated to this WYSE 7020 (probably 7010, not easy to differentiate), 4 Gigs ram, 60 Gigs SSD, $50 + SH, performance is great! (my old RPI was hung every two days) really happy with the change, again thank you very much for the idea.

Just some additional info on my setup: I had to leave the old RPI running because I have connected to it all my house doors and windows status through the GPIO and some custom circuitry with optical isolators which I cannot migrate tot he WYSE. I have connected both of them using this component:

…to replicate in the WYSE only the binary inputs indicating the status of the doors and windows. So the WYSE is doing the heavy lifting with all my home sensors (33 sonoff + a few other devices) and automations (+100) and the RPI is just for the doors and windows (very little load, no history, no log, just sensing the GPIO and replicating to the WYSE), I’ll reply back in few months from now to confirm the setup continues to work reliably.

Glad it is working for you and thanks for the additional information to help other with similar configurations.

I don’t suppose anyone has done this with the new image in xz format? Trying to figure out how I would do that.

I have verified this on both a 5020 and 7010

sudo xz -dc /path/to/image.xz | sudo dd of=/path/to/your/ssd bs=4M conv=fsync (After the -dc replace your path where I show mine and then the path to your destination drive)

In my case it was sudo xz -dc /media/ubuntu/NUC/hassos_intel-nuc-5.12.img.xz | sudo dd of=/dev/sda bs=4M conv=fsync

I’ve just realised that the flash drive on my Wyse is only 4GB. Not nearly big enough. Going to see if I can install it on a USB flash drive and boot from that.

My first one had 32G Flash Drive and works great. The one I bought for future backup only has 16GB so I am going to replace it with a 128GB SSD internal drive. I have seen several people comment that what they do. An SSD connected with a 22 pin SATA extension cable will fit inside the case and can be done for less than $30.

I installed a 120GB SSD inside my 7010 using a short 22 pin SATA cable connected to the Flash Drive 22 pin SATA connector. It worked great.

1 Like

I used your instructions to install Hass on a HP T620 and it is working fine.

Glad to know. Thanks for the feedback.

1 Like

I know discussions here are around the 5020 and 7010, but I just finished up moving my VM to a Wyse 3040. These are really cool little devices, but I had a hell of a time getting things up and running as the UEFI/BIOS on the 3040 is particularly strange. Not to mention I bought it to install a Linux OS and Docker for Frigate, but I successfully got Debian installed once out of 20 tries and no Ubuntu flavor ever would let me install.

I also moved all of the data to a USB SSD with these instructions to make the eMMC my boot drive and the SSD for everything else. So far works pretty good, though I think my VM was faster - this just gives me a lot more flexibility with all of the USB ports.

EDIT: I had issues with this particular device and Frigate, which is pretty resource-intensive. I ended up buying an HP T430 thin client which has better specs, making me think it would work better. I did the same steps as above on that and had the same issues. I ended up adjusting the swap file and so far everything has been running beyond expectations for the last week. If you’re doing all of this with the Wyse, I would also recommend the same thing: How to increase the swap file size on Home Assistant OS

I ended up giving up and deciding I’d give the img.xz a shot and move all of HA to this little device that could run on it’s own, while my server that had the VM could serve other purposes.

I found the winning formula to get it to work as dd commands didn’t work for me on the 3040:

  1. Booted up a Linux live cd (Ubuntu 16.04)
  2. Opened Disks
  3. Wiped the partition
  4. Restore image (hamburger menu)
  5. Select the img.xz, let it restore
  6. Shutdown
  7. Take out usb
  8. Let emmc boot to HAOS
  9. HASS.IO -> transfer from SD card to SSD or USB - #270 by benmarshall
  10. How to increase the swap file size on Home Assistant OS (found this after doing it on the T430 which made it much more stable and faster. Have not tested on the 3040)
5 Likes

@unrly, I know it is a fairly old post, but by any chance have you tried the IntelNUC version of HA to install directly on the Wyse 3040?

I am playing with the idea to use it as a satellite device. The power consumption and the number of USB ports makes it a good candidate, but the 16GB storage and the option not be able to expand it makes me think more about it. (The cost of the device like 60 Euro is nice as well.)

@GSzabados I edited my post to show the entire instructions. I honestly didn’t end up using it too long because it would lock up. However, I had the same issue when I bought an HP T430 shortly after and followed the exact same instructions which has twice the ram and a much better Celeron. I found the swap increase and it hasn’t shown any issues in over a week, very stable.

If I ever get time I’d like to try again on the Wyse just to play with, but I’m happy with the HP due to knowing that the m.2 works with the Coral.

2 Likes

@unrly - Thanks for that. I’ve thought that you did install a supervised setup with Ubuntu back then. It is all clear now.
I use a HP T630 with Debian supervised. The physical M2 SSD makes everything really easy. That’s the reason why I have more thoughts of the Wyse 3040.

I’ve looked at recently the HP Elite Slice, that is a really small fine device, but the active cooling stopped me from upgrading the T630.

Yeah, I didn’t try to use an m.2 ssd with the 3040 as the slot may or may not support anything other than a wifi card. I didn’t have anything to test (until now with the Coral) so I went the route above to install directly to the internal drive. I’d imagine it would be fine to run HAOS - though there seem to be differing opinions on whether the Atom processor is better than a Pi 4 or not. That Slice looks like a very sweet little device too though pretty pricey. Honestly these thin clients are great little devices and I’m looking forward to coming up with a project to put the 3040 to use! In the end it was cheaper than a Pi 4+case+power adapter.

Oh yeah, that’s for sure.

I have found a topic on Reddit where a user mentions that he researched it. And the connectors is actually not connected to the PCI-E line. It is an SDIO port, with the form factor of the M2 slot. The user mentioned that this SDIO is a remnant from the past. It was designed for PDAs with an physical SD card slot where you can put a device with and SD card connector. So it is a lost cause.

In another topic a user mentions that he has replaced eMMC on the board to a bigger one. Just search “wyse 3040” on reddit and for sure you will find the same topics.

There were some ideas to benchmark RPis and normal computers with Pixel, as it was released to x64 and i386 config as well. So it would be comparing like apples to apples, but I don’t know what was the end result. I have only Rpi 3 and 3B so I don’t have any experience with the 4’s uplift.