Home Assistant ios app not updating location

Same issue with my iPhone Xs MAX IoS 13. A few days back it was working but after HA instance was recovered it stopped reporting.

Same here with two phones. They are updating iphone_connection_type and stuff like that but not location. Location sharing is set to “always” HA version is 0.107.6

since today tried the app as well on iOS and my HA 0.107.7 and iOS 13.4
Everything is updating except my location.

  • access location always
  • Background updates
  • use mobile data

Are all on and checked.

When I open the iOS app and refresh I see the change in HA and its updating correct.

Would be so nice to never open the iOS app and will send all the info in background…

I removed the integration. Removed the mobile.app file in .storage
and removed the IOS app.

Restart HA, after that installed iOS App again. Login in the app.
Now everything seems work… but for how long…

I have issues with all the other sensors too. Battery level and state not updating for example.

I followed the same approach, and reinstalled the app after removing the integration. With all the pains that it comes with, like redefining every action in the app or the watch integration.

The sensor update worked only the first time. After first reset of HA, they stopped working again. As I also have the android mobile app I am steered towards an issue in the companion app and the mobile_app implementation on iOS side, more than a bug in HA. Maybe something changed in latest iOS?
Honestly, don’t know. But I rely on the integration quite a lot, and in this state is not very useful.

1 Like

Should we create an issue on this in the companion app’s source to get attention from the devs?

I try the companion app every now and then, but never seems stable enough to depend on. I am running into similar issues, reset everything, check iOS permissions, log back in, integration is created and entries show up, but never seem to update. Is there something in the App event log that I should look for to see updates sent back to hass?

Having the same issue here. All my settings are correct and I have no previous version of the app, but it never sends updates passed the initial setup.

I was searching hoping to find a fix for this, but same issue here.
When the app is open, it will send an update, but once it is sent to the background, the updates stop.
I also noted that when the app is reopened, it will sometimes send old states back to Home Assistant.
I have an input select that allows manual switching between Day, Evening, Night, Away modes.
I re-opened the app when the night mode was selected and the reset the input select to the last one it knew of, which was evening.

Have the same thing, Reconfigured the iPhone app serveral times, sensors get made and initial update of all the sensor are done. But after that the never update again. My iPad at the other hand does update frequently…

check https://github.com/home-assistant/iOS/issues/547, https://github.com/home-assistant/iOS/issues/563 there are a few more.

not sure what the status of a possible fix is, not much communication from the dev’s coming back to the posters unfortunately.

On the sensor issue, this is known and there is a fix in the pipeline however the developer has started a new job recently and free time is very limited. If you need the battery sensor specifically you can pick this out from the attributes of the device_tracker.* entity which is still updating


thanks for joining in. great to hear. hope some free time can be found.
To manage our expectations…:
does the above mean a fix has been offered to the Apple store and we’re waiting for Apple to approve, or that the issue has ben recognized, and we are waiting for the dev;s to start working on it…

It would ease many configs by just temporarily disabling mobile_app awaiting the latter.

Speaking of which: can we do so per device? I have only 2 devices act up, so would only need to exclude these from the mobile_app config. (one need the app to see my HA instance, don’t need all of the sensors)(this only mentions disabling the device_tracker)

My understanding is that it hasn’t gone to Apple yet however a fix has been merged in GitHub

ok thanks, not sure where the leaves us then. Seems not to be very close to a release to Apple.

Since that PR merged only fixes the carrier name: Wonder if fixing the carrier name would make all other sensors update upon change or web refresh?

I believe all sensors are sent in a single webhook call and it is the change Apple bought in with the carrier name returned on a disabled or empty interface (eSIM) that is breaking the sensor update

1 Like

ok, thanks for the info.
couldn’t we try this with the extended line 145, as a CC for the time being? Would be interested to see if that indeed solved the issue, because my affected devices don’t have a disabled sim at all.

Thx for bringing some light into the darkness. I am struggling with this bug for some amount of time. Now I can stop searching the fault on my side of the screen :wink:

I’m struggling with this as well. My android works great but my wife has an iphone and it seems to rarely update its location. Today we drove 40 minutes away from our house and back again and the phone said it never left home. Naturally this throws a big wrench in my ability to detect presence.

When I noticed this I went to her app to see what was wrong and noticed when I clicked on it that there was a loading icon before it could open. I asked what it was and she said Apple now automatically removes apps that aren’t opened by the user in a while to save space. It leaves all the settings/preferences but the app binary itself is gone so the app can’t run until manually opened again. Since she never opens the app and just wants it to report in the background apple apparently decided to optimize it out of her phone.

The setting is called “Offload unused apps”, we found this article showing how to turn it off. I don’t know if this will completely fix the issue yet since we just did it today but something else to check into for anyone having issues.

I have been searching for three days. It’s nice to know it’s not just me.