Home assistant Operating System update 4.8 to 3.13

I’m havin a strange update notice in Supervisor

Update Available :tada:

Operating System 3.13
You are currently running version 4.8

It’s clearly a mistake (my version is 4.8 and wants to upgrade to a lower version), but I do not dare to click Update, because I don’t want to crash my HASS at home. does anyone have a suggestion how to fix this?

Using HASS on Raspberry Pi 4.

Kind regards,

System Health (from developer tools -> Info

arch	armv7l	
chassis	embedded	
dev	false	
docker	true	
hassio	true	
host_os	HassOS 4.8	
installation_type	Home Assistant	
os_name	Linux	
os_version	5.4.42-v7	
python_version	3.7.7	
supervisor	227	
timezone	Europe/Ljubljana	
version	0.110.4	
virtualenv	false

This is a post by @makai that shed some light on why this the UI asks you to upgrade from version 4.8 to 3.13.
In short, this is because versions 4.8 and 4.9 have issues and are no longer considered Stable releases. So you can either downgrade to 3.13 or wait a few more days to the 4.10 release.

I’m not trying to sound negative, but if releases 4.0 through 4.8 were beta tested without anyone noticing that they massively failed on a RPi 2 or 3, then my confidence level in the beta testing process isn’t all that high. I’d give 4.10 a good long time to “soak” (let other people be the guinea pigs) before I’d go there. Obviously everyone’s tolerance for failures is different, so I can only speak for myself.

Problem is there are not enough volunteers to do ‘beta testing’. It still is a open source project depending (mostly) on volunteers.

So I read through the update notice a bit absent-minded, clicked “update” and only the realised that something seems off. Too late. Now my complete hassio-install seems to be f**ked, my router cant even see the Pi’s IP-address anymore! What a disaster! My last Backup is from 4 month ago and I put in so much time and effort learning to code and using node red since then!

Any advice on how i could save my install anyone? Pleeeease!

Cutting the power and letting it reboot three times will apparently activate a recovery mechanism that gets you back to the working version.

Thanks for the suggestion - however i tried that now but still nothing…

First, let me get out of the way that I think HA is a great project and I really appreciate all the hard work that’s being done on it.

But looking at it from a user’s perspective, it would appear there are plenty of volunteers willing to make changes. We went from 3.13 to 4.8 pretty quickly. That represents a lot of volunteer hours of coding.

I get that testing is nowhere near as much fun as coding. But doing only the fun half of a job, then complaining when no-one wants to do the other, boring half seems sort of selfish.

Put another way, “we don’t have time to test” is not the sort of approach which results in a good product.

I understand completely that no-one has any obligation to listen to me. Those managing and supporting the project are free to choose their own processes and goals. I only offer the perspective of someone who wants to see the project succeed. I’ve found in life that seeing things from another perspective can have great value.

I got lucky, because I was busy and could only deal with HA intermittently. I think the critical piece which worked for me was allowing time for the update to happen, instead of giving up and powering off and on too soon.

I feel the frustration, losing all that work would be disheartening! I hope it’ll come back for you.

I had it sitting for well over an hour before i power-cycled. Seems like it is all gone and i have to say: after all the hassle I have been having with HA since day one I dont see myself reinstalling it. Over the last months i migrated all automations to NodeRed and HA has just become an annoyingly complicated and unstable framework. I’ll maybe revisit HA in a couple of years to see if it has become more user friendly - at the moment it is not for me. I love tinkering around but i also want to live in my flat without having to troubleshoot some software every other time i want to make a coffee or turn on a lamp…

If you do want to continue with Home Assistant, I am sure your configuration can be salvaged somehow. It is a Linux filesystem that you should be able to read from a different computer and copy onto a fresh install.

Well - yeah maybe that is possible. But the extFS filesystem somehow cant be read by OSX (or actually one needs a 40.- software to do so and i only have a macbook at hand) and i already see myself spending hours and hours once again reading through forums and watching youtube tutorials to somehow figure out how to piece it back together. I am not a coder and am quite frankly not interested in learning to code - and as it stands now you cannot use or even set up HA without messing around with this YAML-language, so i am unsure if HA is the right thing for me. I am now setting up a Raspbian/Deconz/NodeRed install on another SD card - depending on how that goes i might be back here or not…

I just noticed this too today. I’ve checked the repository and it’s showing 4.10 as the latest release. However, the HA UI is still showing the “upgrade” to 3.13. Should we just wait longer before it shows up?
Or should I upgrade to Core 0.110.5 (currently on 0.110.4) and then it’ll show up?

actualizado. ya salio 4.10

Hi guys,

This is my story: On a RPI3B+, ver 4.8 have been running without any problems, only several errors in log… So when I see that Supervisor ask me to downgrade to 3.13, I check different forums and saw that errors disepear, so I decide to downgrade.

After few days, Supervisor ask me to upgrade to 4.10 … OK, 4.10 is better than 3.13 isn’t it ? GO

My Pi won’t respond anymore, ping working but nothing else.

I check the different logs and I saw that hassio_supervisor failed to start … OK But for it’s hassos_supervisor now ??

On terminal, I launch this command line:
docker restart hassos_supervisor

And aleluia !! All is working fine


I can’t reboot my Pi, after that I’ve to lauch the command line to start supervisor.

I hope that help to find what is blocking supervisor from launching.

Similar experience to @BuXTeR above, although I stayed on 4.8 even when 3.13 was presented as an update. But this morning 4.10 showed as the latest update. I clicked the update button, but now I’m faced with HassOS not showing a web interface at all, although my Octoprint Hass.io Add-On still works, so some bits are clearly running… Going to try a reboot later

And a reboot did not make any difference, except for losing access to Octoprint now too.

In my vase i foundation that, after goding from 4.8 to 3.13, the ip-adress has been changed to the pi. So i just changed to the new pi adress in the brewser, and the it was up rundning again.

I’ve now restored a snapshot from yesterday to a fresh installation of HassOS 4.8 and am back online…