Home Assistant Operating System Update 9.4 stuck


I was just trying to update the home assistant OS from 9.3 to 9.4
However after just over half an hour it hasn’t finished.
I decided to reboot.
Home assistant comes up perfectly fine.
When I try clicking the INSTALL button again I get.

Error updating Home Assistant Operating System: Another job is running

I tried to update it via terminal:

ha os update

It returns:

Another job is running.

So it looks like the install is stuck somehow.
Any ideas how I can either stop the job running, and try again, or diagnose what is happening generally?

1 Like

I was away from home and when I vpn’ed in to my home network, I saw that there was an update to the Home Assistant OS to 9.4. I cliicked and installed it. Now, my Home Assistant is dead. I have a smart plug to remotely turn the RPi power supply off/on, but no respond from my RPi which hosts the Home Assistant OS. It’s dead. I will see what happened to it when I get home on Friday night, December 16, 2022!
To those of you have not updated yet - DO NOT update to 9.4! Something bad will happen to your host machine after/during the update.

Update: 2022-Dec-14 15:50 Central USA time —
With the smart switch controlling the power supply to the RPi, I switched it off/on every 2 hours hoping that I can eventually ping it. It did and I was able to connect to it. I looked at the “About” and it did update the OS to 9.4! I didn’t bother to look at the logs. I will check it when I get home this Friday. From now on, I will refrain from doing updates from remote!

Hello after updating to the latest release and core update I receive the following:

Logger: homeassistant.components.websocket_api.http.connection
Source: components/hassio/update.py:305
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 15:32:58 (2 occurrences)
Last logged: 17:09:33

[547863163376] Error updating Home Assistant Core 'HomeAssistantCore.update' blocked from execution, system is not healthy - setup
[547178247648] Error updating Home Assistant Core 'HomeAssistantCore.update' blocked from execution, system is not healthy - setup
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/hassio/update.py", line 303, in async_install
    await async_update_core(self.hass, version=version, backup=backup)
  File "/usr/src/homeassistant/homeassistant/components/hassio/handler.py", line 51, in _wrapper
    raise HassioAPIError(data["message"])
homeassistant.components.hassio.handler.HassioAPIError: 'HomeAssistantCore.update' blocked from execution, system is not healthy - setup

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 200, in handle_call_service
    await hass.services.async_call(
  File "/usr/src/homeassistant/homeassistant/core.py", line 1745, in async_call
  File "/usr/src/homeassistant/homeassistant/core.py", line 1782, in _execute_service
    await cast(Callable[[ServiceCall], Awaitable[None]], handler.job.target)(
  File "/usr/src/homeassistant/homeassistant/helpers/entity_component.py", line 213, in handle_service
    await service.entity_service_call(
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 678, in entity_service_call
    future.result()  # pop exception if have
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 943, in async_request_call
    await coro
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 715, in _handle_entity_call
    await result
  File "/usr/src/homeassistant/homeassistant/components/update/__init__.py", line 154, in async_install
    await entity.async_install_with_progress(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/update/__init__.py", line 413, in async_install_with_progress
    await self.async_install(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/hassio/update.py", line 305, in async_install
    raise HomeAssistantError(
homeassistant.exceptions.HomeAssistantError: Error updating Home Assistant Core 'HomeAssistantCore.update' blocked from execution, system is not healthy - setup

Any suggestions on how to resolve this?

I also experienced issues with 9.4
System became very unstable, frontend sluggish as well as zigbee.
Didn’t find any clear clue’s in the logs either.
Decided to roll back last month’s snapshot (vm) after downloading last nights backup.
Restored the backup, updated all updates, except haos 9.4; took another snapshot before trying 9.4 again.
Surprisingly, this time system was fast and stable. :grin:

Not sure where and what went wrong with the first 9.4 update :thinking:

Same problem, but I cannot even restore the previous backup.
It boots, but gets really really slow on startup…

Hi guys, thanks for the input.

Sorry to hear that you are having problems, guess it’s nice to know I’m not alone.
I think many of your issues are more serious than what I’m experiencing.

Since the UI was still up and available, I made the decision to try restoring from backup.
This worked. I then tried to reinstall the updates and this time no issues.
The only difference between this time and last, is that I tried installing Home Assistant OS 9.4 first, and then the core update. That seemed to work fine this time, and so far I can’t see any issues.
I doubt this will help for those of you with more serious issues, but it might help some who are seeing the same problem as me.

Mine completely locked/crashed. After enough reboots I was finally able to get it back, seems to have auto-rolled-back to 9.3. I’ve clicked the “skip” button for OS 9.4!

Stuck here too. Won’t boot anymore.
Warning for other uses… don’t upgrade to 9.4.

RPI4 on a usb-ssd here.

Yes, 9.4 seems to be buged from the start. First updated from 9.3 to 9.4, got system unhealthy error. Couldn’t update anything anymore. After complete reboot of my rpi4, it wasn’t booting anymore.

So i reinstalled 9.4 on clean SD card, directly after installing, without any setup done, the system reports unhealthy setup again…

Hello all,

I just installed the new Supervisor update and it’s working again! Today I saw that a new Supervisor update became available. Luckily it did not give me the "System Not Healthy"message and was able to install it. Now I am also able to update other items again.