Home Assistant OS on Intel NUC -> no USB devices

I installed Home Assistant OS on my Intel NUC device. On a previous HA installation on the same device (based on Ubuntu Server with Docker) I had a working integration with my smart power meter via ‘DSMR slimme meter’ with a P1 USB cable. Since I migrated to HA OS, I can no longer get this integration working.

No matter what path I specify as USB device path on the DSMR integration dialog, nothing is accepted. Since the hardware is not changed, this has to have something to do with the OS change. Any steps I’m missing to get USB devices to work on HA OS?

How did you install HAOS? Depending on type of install you might have to assign the port from a VM for example.
Also in HA: Supervisor → System → Below Host select Hardware and scroll down to tty
Do the USB devices show up there?

I installed HA OS by writing the HA OS generic image from the mentioned url in the documentation:


The Host > Hardware option only shows event and tty serial devices. No USB devices whatsoever.

Seems to be the same issue as in Conbee II problem, I don't see tty/ACM0, although no solution so far. :frowning:

The fact they dont show up in the Hardware list is a problem. Since then you will never get it to work.
I have a nuc and an USB P1 reader and on this machine it shows under:


Did you try all USB ports?

There’s limited USB device support in HA OS. From what I can tell, if a USB device isn’t automatically discovered, the device needs to be accommodated in an update.


Perhaps @agners can comment. He’s a principal developer of HA OS. He recently merged a Realtek serial driver into OS release 7, but it’s not released yet (not sure if it’d be in an Intel NUC). There’s a dev release you can try if you think it might apply.


Of course, there’s always a Supervised installation with Debian.

The Home Assistant Core USB integration you are linking is not related with USB detection on OS level. A device such as Conbee II is detected by the OS (the Linux kernel itself) as a serial device, and the serial device /dev/ttyACM0 or similar is created. The Supervisor makes sure to automatically have them available in Core and Add-ons if necessary.

The device should appear automatically in the hardware list, like so:


Not sure what the problem is in this case, maybe that hardware you are using is not properly supported (what is it?) or something wrong with the USB port.

1 Like

Thanks for the reply.

Is the USB interface detected at boot time? That is, should the cable be connected during boot for the OS to recognize it and create a 'dev/ttyXXXX instance? What log in an HA OS installation would show the port and driver being assigned for the interface?

FYI, I assume the OP is using something like this:


I see these use FTDI or similar serial chips.

The NUC is an DC3217YE device. USB devies should be good since this worked fine exactly till my move from Ubuntu server (unsupported) to HA OS.

I’ve tried all ports, no success so far.

I’ve just reinserted the two USB devices I have on the NUC. One of them suddenly appears in the hardware list (cc2531 Zigbee device). The P1 cable is not showing up.


Maybe I have to find another P1 cable that is actually supported.

Try shutting down the computer first, then plug in the cable and reboot. See if it appears afterwards.

Just tested, makes no difference unfortunately. I guess HA OS does not recognise this USB device.

It was worth trying, but I’m out of ideas.

Let’s see if @agners has the time to respond. In the meantime, look through your logs (under Supervisor>>System on my installation) to see if there are any clues to the issue. Look for any errors or instances with ‘tty’ in the device. Also, in the ‘hardware’ drop-down menu, check to see if you see the P1 cable info on any of the USB devices.

Checked both, no noteworthy things in the log, also no tty related USB devices. Hope this can be fixed. :crossed_fingers:

I suppose the next step might be to try another cable. Is there any way to see what chip is in the USB end of the cable if you connect it to a desktop machine (look for the driver associated with the port)? That might be useful to know if only to avoid ordering something with the same device.

Not sure what happend, but I had the USB P1 cable removed for a day or so, and just re-inserted it and it is now suddenly recognised. This was definitely not the case of the cable not being inserted fully into the NUC case or something.

1 Like

Well, that makes two of us.

It’s possible you might have inadvertently triggered a latch-up condition before it was unplugged. It’s relatively common with CMOS logic devices; however, it’s a pretty arcane topic unless you’re a designer of electronic hardware.


We should recognize @agners for being spot on.