Home Assistant OS Release 8

Home Assistant OS 8.0 stable is available now!

Highlights:

  • Use of GRUB2 for UEFI based systems
  • Support for additional Wi-Fi and Bluetooth devices
  • New image: Generic AArch64 for UEFI based AArch64 VMs and boards
  • New image: Home Assistant Yellow

For existing installations, no manual intervention is needed! You can safely update without reading these rather technical release notes.

Table of contents

Operating System Changes

GRUB2 for UEFI based systems

For Generic x86-64, OVA and the new Generic AArch64 Home Assistant uses GRUB2 as boot loader now. GRUB2 (GRand Unified Bootloader) is the de-facto standard boot loader used by most Linux distributions. The main reason for switching from Barebox to GRUB2 was the missing AArch64 UEFI boot support in Barebox. We also expect GRUB2 to be more stable especially on Desktop style x86-64 systems as it gets used by much more users since generic Linux distributions use GRUB2. Although, we actually hit a bug in GRUB2 during the RC phase, let’s hope this was a one-off. 🤞

The boot menu shows the two boot slots. Typically you don’t have to change selection here, unless you intentionally want to boot the previously installed Home Assistant OS version.

Note: Upgrading from any version 7.x is safe, but we recommend upgrading from the last version of the previous major release. This is also the best tested upgrade path. From any release with GRUB2 it is only safe to downgrade to 7.6! Downgrading to releases before 7.6 can be done by downgrading to 7.6 first.

Under the Hood

Under the hood, the OS was updated to the latest upstream Linux 5.15 kernel as well as Buildroot 2022.02.1. The latest Buildroot release brings new versions of various core components like systemd 250, NetworkManager 1.34.0 and Docker 20.10.14.

Additional networking drivers and settings prepare Home Assistant OS to host the OpenThread Border Router add-on.

Other Changes

  • IP set support for advanced firewalling (also used by the OTBR add-on).
  • Support for NTP configuration via DHCP.
  • Google Coral support is now using Google’s latest driver. This enables additional Coral device support such as PCI Dual Edge TPU.
  • Legacy wext backend for wpa_suppilcant is now enabled to support more Wi-Fi devices.

Device Support

Raspberry Pi

All Raspberry Pi versions use the latest LTS Linux Kernel 5.15 and firmware (tag 1.20220331) from the Raspberry Pi team. These are the same versions as the Raspberry Pi OS is using currently.

Home Assistant Yellow

This is the first release that supports Home Assistant Yellow. Since Home Assistant Yellow uses the Raspberry Pi Compute Module 4, the support is based on the regular Raspberry Pi support currently. The Yellow image is using the same kernel and firmware version. The Yellow board also supports booting directly off of an NVMe device for those using a CM4 Lite (without eMMC storage).

Generic x86-64

Besides the move to GRUB2 Generic x86-64 received quite some additional device support. The Wi-Fi devices 3945ABG/BG/4965AGN and 22000 series are now supported.

Other Changes:

  • Support 32-bit UEFI boot. This is required by older Intel Atom systems. Note that only the boot loader is 32-bit, everything else uses the same 64-bit binaries as 64-bit UEFI boot.
  • Driver and firmware for Broadcom BNX2/BNX2X network interfaces are included.

Generic AArch64 support

@Doridian contributed support for generic AArch64 systems which use the UEFI boot flow. It should support real boards as well as virtual machines. So far it has been successfully tested on KVM Virtual Machines.


This is a companion discussion topic for the original entry at https://www.home-assistant.io/blog/2022/05/16/home-assistant-os-release-8/
6 Likes

I have an Intel BOXNUC7I3BNH
And it wont start after the update. I am stuck on the boot menu all i get when i pick one of the options it says:
Booting a comand list
Error: incorrect compressed chunk
Normal Home assistant installation no custom, all latest updates.
Open the images in new tab to see text… amature way to screshot but it is only one i have…


1 Like

Same here. On my HP t620. Won’t boot after upgrade to v8. Help!

Same here. On my HP Elitedesk. Won’t boot after upgrade to v8

I get this message

Might be unrelated to previous replies, but I’m also unable to boot after upgrade using VitrualBox VM. I’m able to reach BIOS but can’t proceed past that.

was just about to do this…think ill give it a miss for now as also running on an Intel NUC

After upgrading my RaspberryPi 4: I now have problems with my ZHA (Zigbee Home Automation): it does not startup anymore, because it can’t start the “deCONZ RaspBee I/II coordinator”. Also my HACS ble_monitor has no connection to bluetooth anymore - so my house is dark now :sunglasses:

1 Like

@Sangoku @mrbasque this issue has been reported here as well: HA 8.0 fails to boot (incorrect compressed chunk) · Issue #1912 · home-assistant/operating-system · GitHub. It seems that GRUB2 has problems on some x86-64 systems reading from the compressed, squashfs bsaed kernel partition. Please share the details of your system in that issue report, it would help narrow down affected systems.

@Boklak we had similar reports during the RC, but it got resolved in 8.0 for most people, see Error updating versions higher than Home Assistant OS 8.0.dev20220321 · Issue #1830 · home-assistant/operating-system · GitHub. Did you upgrade to the final 8.0 release?

@LeoSko haven’t seen that issue so far, can you open an issue in the Home Assistant OS repository? Sign in to GitHub · GitHub

Homeassistant OS 8, in VMWare updated successfully, VMware, reports "Version Other Linux 5.x kernel 64-bit.
Ha reports Kernel version 5.15.38
Upgraded from latest OS, Supervisor, Core Versions

Windows 10 P(latest update), i7-4700MQ(MSI GE60), VMware VMCI Host Device - Driver Version 9.8.16.0 (Vmware Workstation 16)

PS: VMware installed on separate exFat Disk
Edit: All disks are GPT

NOTE: After reading below posts, i checked my HOST-File , and did found it “peculiar” thou i’ve never paid any special attention to the HOST-Log , But in regards to i’e network interfaces ect. Only USB shows a “strange behavior” ( New Device Found )

[    1.367219] ACPI: bus type USB registered
[    1.367534] usbcore: registered new interface driver usbfs
[    1.368505] usbcore: registered new interface driver hub
[    1.369544] usbcore: registered new device driver usb
[    3.230689] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.236283] ehci-pci 0000:02:03.0: new USB bus registered, assigned bus number 1
[    3.247889] ehci-pci 0000:02:03.0: USB 2.0 started, EHCI 1.00
[    3.249986] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.15
[    3.252399] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.254494] usb usb1: Product: EHCI Host Controller
[    3.255930] usb usb1: Manufacturer: Linux 5.15.38 ehci_hcd
[    3.257543] usb usb1: SerialNumber: 0000:02:03.0
[    3.259058] hub 1-0:1.0: USB hub found
[    3.261589] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    3.264722] uhci_hcd: USB Universal Host Controller Interface driver
[    3.268634] uhci_hcd 0000:02:00.0: new USB bus registered, assigned bus number 2
[    3.272893] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.15
[    3.275313] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.277422] usb usb2: Product: UHCI Host Controller
[    3.278850] usb usb2: Manufacturer: Linux 5.15.38 uhci_hcd
[    3.280441] usb usb2: SerialNumber: 0000:02:00.0
[    3.282287] hub 2-0:1.0: USB hub found
[    3.287042] xhci_hcd 0000:03:00.0: new USB bus registered, assigned bus number 3
[    3.293476] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.15
[    3.295925] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.298027] usb usb3: Product: xHCI Host Controller
[    3.299455] usb usb3: Manufacturer: Linux 5.15.38 xhci-hcd
[    3.301075] usb usb3: SerialNumber: 0000:03:00.0
[    3.302654] hub 3-0:1.0: USB hub found
[    3.307411] xhci_hcd 0000:03:00.0: new USB bus registered, assigned bus number 4
[    3.309596] xhci_hcd 0000:03:00.0: Host supports USB 3.1 Enhanced SuperSpeed
[    3.311800] usb usb4: We don't know the algorithms for LPM for this host, disabling LPM.
[    3.314125] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.15
[    3.316581] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.318687] usb usb4: Product: xHCI Host Controller
[    3.320106] usb usb4: Manufacturer: Linux 5.15.38 xhci-hcd
[    3.321768] usb usb4: SerialNumber: 0000:03:00.0
[    3.323313] hub 4-0:1.0: USB hub found
[    3.326657] usbcore: registered new interface driver usblp
[    3.328465] usbcore: registered new interface driver usb-storage
[    3.330281] usbcore: registered new interface driver usbserial_generic
[    3.332171] usbserial: USB Serial support registered for generic
[    3.388043] usbcore: registered new interface driver usbhid
[    3.389908] usbhid: USB HID core driver
[    3.505863] usb 2-1: new full-speed USB device number 2 using uhci_hcd
[    3.551880] usb 3-1: new full-speed USB device number 2 using xhci_hcd
[    3.781697] usb 2-1: New USB device found, idVendor=0e0f, idProduct=0008, bcdDevice= 1.00
[    3.794160] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.805080] usb 2-1: Product: Virtual Bluetooth Adapter
[    3.813894] usb 2-1: Manufacturer: VMware
[    3.820846] usb 2-1: SerialNumber: 000650268328
[    3.840706] usb 3-1: New USB device found, idVendor=0e0f, idProduct=0003, bcdDevice= 1.03
[    3.845331] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.849485] usb 3-1: Product: VMware Virtual USB Mouse
[    3.852648] usb 3-1: Manufacturer: VMware
[    3.860961] input: VMware VMware Virtual USB Mouse as /devices/pci0000:00/0000:00:15.0/0000:03:00.0/usb3/3-1/3-1:1.0/0003:0E0F:0003.0001/input/input4
[    3.869305] hid-generic 0003:0E0F:0003.0001: input,hidraw0: USB HID v1.10 Mouse [VMware VMware Virtual USB Mouse] on usb-0000:03:00.0-1/input0
[    3.947009] usb 2-2: new full-speed USB device number 3 using uhci_hcd
[    4.089167] usb 2-2: New USB device found, idVendor=0e0f, idProduct=0002, bcdDevice= 1.00
[    4.092521] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    4.095298] usb 2-2: Product: VMware Virtual USB Hub
[    4.097401] usb 2-2: Manufacturer: VMware, Inc.
[    4.107190] hub 2-2:1.0: USB hub found
[    5.061323] usbcore: registered new interface driver btusb

Could be the cause of “lost” USB-Devices, turning up as “New”, For some Users
EDIT: Maybe because i only have a wired mouse attached , everything was “seamless”

Since upgrading to OS 8.0, my Z-Wave is broken, with the error “Driver: Failed to open the serial port: Error: No such file or directory, cannot open /dev/serial/by-id/usb-0658_0200-if00”.

Running 2022.5.4 in a Proxmox VM.

RPi4 over here. Upgraded to HA OS 8.0 and the Deconz firmware which strangely shows “Not connected” in Phoscon…
I am using Deconz add-on 6.13.0

After restarting, Deconz is no longer booting up.
On https://xxx.duckdns.org:8123/hassio/addon/core_deconz/config , line
/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2254892-if00
seems to be playing hide and seek.
After selecting it eventually and clicking Save, error ?!
Failed to save add-on configuration

It’s a total mess :crying_cat_face:

I had a canable USB stick too , not connected anymore… In my case I had to turn off, not restart… After boot it was up again, maybe that helps with deconz too… running on esxi here

For intel NUC the uefy boot menu was the solution.
I enabled legacy boot. Rebooted. enabled Uefy boot manager and it worked like a charm.

1 Like

Fixed via totally shutting down (power off) the host then restarting. Thanks for the suggestion pergola.fabio!

Same here, cant turn off my lights in the middle of the night wanting to go to bed :rofl: any fix yet on your side?

I switched off my RPi, unplugged the Conbee 2 stick, restarted HA and the host, all this no to avail.
I’ve just noticed that, in the Phoscon interface, my Conbee II name and logo had been replaced by Raspbee with a new icon :expressionless:

So I’m wondering if the firmware update I made within the Phoscon interface has not broken something…

BEFORE

AFTER

raspbee

I’m afraid of restoring the previous Phoscon backup and having to pair my switches again…

So FWIW updated to 8.0 and after restarting nothing. Pulled the power a couple of times, still nothing. My 'pi is normally running headless so I hooked up a monitor and could see nothing - so another cold boot - and this time it started up ok albeit running 7.6 so it had reverted to the fallback. I might hold off trying the update for a few days… :wink:

1 Like

Had some issues after upgrading to 8.0. Very long shutdown and boot-up times. It failed boot once; got hung up on the docker container initialization, and went into emergency shell. Another forced reboot and i saw it flash up quickly and select “slot 2”, and it booted ok, but still took forever.

Noticed it was using almost all the allocated 8GB of ram before reboot, but only 3 GB after reboot.

running HASS OS under Proxmox 7.1 in OVMF, 4 cores, 128GB partition, 8 GB RAM, 2x USB 2.0 devices passed through by ID (Conbee II and zWave stick),
AddOns: Deconz, zWave JS, SSH, Studio Code Server, HACS, ESPHome

I noticed in the deconz config the device address had changed to the wrong one suddenly, changing this back fixed it for me. In my case it was set to /dev/ttyS0 while it had to be the /dev/ttyAMA0

Screenshot_1

Hmm, interesting.
Even when I choose /dev/ttyAMA0 , Save and restart the add-on, the stick is still not picked up.
Yesterday I upgraded HA OS to 8.0 AND upgraded the Deconz firmware (within the Phoscon interface)
Not sure which one broke something, if not both…

I could restore a previous version of Hassio (downgrading to OS 7.x) but I’m not sure it’ll be sufficient since I also updated the firmware in Phoscon (which I don’t know how to downgrade)

Anyway, in the Phoscon web interface, what version of firmware do you have (*) and does it say RaspBee or ConBee II like it should ?
I’m afraid if I “Reset gateway” (in Phoscon) I will have to pair all my devices again :weary:

(*) mine is currently 2.15.3 / 21/04/2022

[Edit] I will try upgrade the FW manually following the instructions within that issue.