Home Assistant OS very unstable


In the last few months my Pi with Home Assistant OS is very unstable.
It crashed one time a day, sometimes it crashed after a day or two.
Tried different things, but i’m out of options now, maybe someone had some tips?

This is how it’s now running.

  • Raspberry PI4
  • Home assistant OS
  • Using an SSD, don’t use micro sd any more. (brand new SSD)
  • Original PI power supply (already tried another power cable)

What i tried without succes:

  • Update fireware of my Conbee II stick
  • Disconnect Conbee stick and remove ZHA integration
  • A clean install, just a couple of devices connected, nothing special.

What can it be?
Can the PI just be broken?
Is there a way how to see what caused the crash?
Can’t find anything in the logs.

I hope someone can help me.
My WAF was 85% and it’s now 10%, not a good thing! :sweat_smile:
I totaly understand her, we can’t count on our assitant any more with all the crashes.

Thanks in advance!!
And happy holiday’s offcourse :slight_smile:

Check home-assistant.log.1 in the /config directory to see if there is anything mentioned in there before it crashed.

That’s odd. I have about 99% (if not 100%) the same config and it is rock solid.
Do you have the integration ‘Raspberry Pi Power Supply Checker’ running?
That way you at least know if the power is sufficient.

I assume you are running the latest versions of everything (core-2021.12.2, supervisor-2021.12.2, Operating System Home Assistant OS 7.0). Does the crash result in a full crash or “just” not responding HA?
If not responding:

  • Is the SSD connected to USB3?
  • If yes, do you use an extension cable for your conbee?
    USB3 interferes with the 2.4Ghz signal of WiFi and Zigbee. This could result in odd behaviour.

There are multiple logs, but I am not sure if these are of any help.
One log is at Configuration → System
The other logs are at Configuration → Add-ons, Backup, Supervisor → tab: System

1 Like

Got file with 1610 rows, multiple errors because of integrations that’s not working.
I’m going to monitor when HA exactly crashed and then search the file.
The result i’m posting.

Result of the “Raspberry Pi Power Supply Checker”.

Could this be responsible for the crashes?
I seet a lot of problems…

Everything up to date.
It’s really crashing, can’t reach it any more and my automations stop working, so i think we can call that a full crash?’

The SSD is connected to the USB3 port.
When i had the Conbee connected i used an extension cable.
Only connect the Conbee to the USB2 port?

I get a lot off errors and warning at “configurations > logs”, going to check when it crashed again what happend just before.


Just a slight drop can cause a crash and the fun part is that the drop is short, then the Pi will not shutdown, but just get wierd reading from the hardware that did not get enough power, which makes it hang.
If the drop was longer, then it would actually reset the Pi and have it start up normally again.

Is your USB SSD powered through the USB port or through an external power plug.

Are you using a separate power supply for the SSD? If not, this could be the cause of your problem.

1 Like

Here RPi4 with SSD , power from a adapter that support multiple USB connections.
SSD is not extra powered…

HA OS is running rock solid for months…

Is your RPi4 board ok?

Trying another power supply, lets see if we get an only green bar :).

Ssd is powered bij usb, one cable, power and connected via 1 usb cable.

No, one cable attached to the ssd, power via usb…

Never crashed once in months?

That still doesn’t tell us enough. When it crashes, can you ping it? If you have the Samba add-on can you still access the samba share? Can you access the Supervisor? ( http://ip-address-of-home-assistant:4357 )

If the answer is no to ALL of the above, then we know that yes we can consider this a full crash (though it is possible that it’s actually only the network that has died, you’d need to plug in a keyboard and monitor to verify if that is the case).

If the answer is yes, everything else is reachable, and it is only home assistant that is not - then home assistant (the core) has crashed and for some reason the Supervisor (or the observer I’m not sure which is responsible) has for some reason not restarted it.

No. Not a single crash…

I think we found the bottleneck.
Look at this:
pri power good

Looking mutch better than with my original pi adapter!
Not crashed today, let’s wait one more day to be sure!

1 Like

Thanks for posting about the power supply checker. I had never heard of that!

From the beginning, my Pi 3 B+ has reported low voltage, even though I tried multiple different power supplies and cables. It never crashed though. I finally bought a MakerFocus RPi 4 Battery Pack UPS and a RPi 4 power supply for it, and powered my Pi 3 from that (using the same cable as before, BTW.)

The low voltage warnings have disappeared, and hopefully HA will survive a fairly long power outage. At least, long enough for me to go fire up the generator. I’m going to try the power supply checker anyway, just to confirm I’m good now. Thanks again!

Good to see it looks like you sorted it out.
About the USB3. Good that you use an extension cable, I’d strongly advice everyone to do so for the Conbee or any other Zigbee dongle when you use USB3. Creating some distance from the USB3 interference will make the Zigbee signal more reliable and enables you to easily pick a good spot for the antenna as a bonus.

Also see this post:

All is stable now, for god sake. :slight_smile:

The blue usb port is USB3 right? The other 2 ports are USB2?
If i connect the conbee to the other (not blue) ports, do i still have to use an extension cable?


The blue ones are USB3 and the black ones are USB2
It does not matter which port you use, since the interference comes from the chips, so you will need the extension cable with both setups.