Home Assistant & Razberry

Has anyone been able to use Razberry (http://razberry.z-wave.me/) with HA? This looks like it could be a pretty good setup and clean too in that you would not have any ZWave sticks hanging off the USB ports. But before I tried one I thought I would see if it would integrate with HA.

1 Like

I’ve used the razberry in HA daily for around 3months now and it works really good once it’s installed :slight_smile:

I assume, then, there are some tips and tricks, ins and outs to the install process? Looking at the website it seemed rather straight forward but I thought that too of the bridge to try and get HA to work with my SmartThings HUB.

I have a few (4 or 5 ) zigbee devices, mainly door sensors that I will swap out zwave based ones if Razberry will work well enough.

I’ve also been using the Razberry for a long time with HA. At first on a raspberry pi 2, now with a raspberry pi 3. I did have to run the z-wave.me installer before it would work, but I disabled all of the extra services it enables by default.

I think I only have around 5 or so devices hooked up using z-wave, but I haven’t really had any issues with the razberry card. It’s really nice to not have to have a big zwave usb stick hanging out of the pi though.

Post here if you have any issues getting it set up =D

@justyns thank you for that. So, do I understand correctly, you don’t have to use the Z-Wave.me software to use the Razberry? The Razberry will detect your ZWave devices and allow you to automate them with HA? I just want to be sure before I purchase one.

The thought of this is getting me pumped up that I can finally move my home automation in-house (well, I assume all but the garage door opener from what I understand) and be able to set things up exactly how I want them rather than what some vendor ‘thinks’ I will want or need. I’m ready to buy the Razberry, just got to make sure it will all integrate and work well as I have nearly 30 ZWave devices in my house.

That’s correct you don’t have to use the z-wave.me, I’m running one on my rpi3. However, there is an issue - if you wish to use bluetooth on the rpi3 I would suggest getting a z-wave usb dongle instead. See Raspberry pi 3 + Razberry z-wave-me GPIO daughter card

@justyns the z-wave.me installer just sets pi3-disable-bt else it conflicts

Alrighty then. Thank you @samriley. I had ordered the Aeon Labs USB stick but I don’t mind ordering the Razberry as well. Could be a good opportunity to experiment with both. Perhaps buy another RPi and use one for development and the other for production sort of thing. Or just learn both so that perhaps I can help others set thiers up.

samriley: what exactly did you do to get it to work? (explained so that a complete beginner can understand :wink: )

I’ve got a rpi3 and a razberry. I installed everything with the “Raspberry Pi All-In-One Installer”. I’ve been fiddling with different usb paths in the yaml and turning off bluetooth and setting “Core_freq=250” in the config.txt as suggested in different threads.

When all is upp and running, how do you confirm that it is working?

Edit: I’ve got the razberry software up and running. I will also specify my questions.

  1. What should I add in the yaml file?
  2. What should I add in the config.txt file?
    3a) Can it be different configurations in the yaml and config files on two separate RPi3?
    3b) If yes in 3a, why?
  3. How do you confirm that the configurations is working?
1 Like


  1. Here’s the “zwave” part of my configuration.yaml (you might not need polling_interval, but it was required for some of my sensors to update):
  config_path: /srv/hass/src/python-openzwave/openzwave/config
  usb_path: /dev/ttyAMA0
  polling_interval: 30000
  1. This is my config.txt file, but note that I do not have bluetooth working and I do not remember what was default vs what wasn’t default. I didn’t need to change config.txt at all originally, but started messing with it to try and get bluetooth working (@samriley mentioned that earlier)
  1. The openzwave and usb path could both be different depending on how everything was installed. It’s also possible to configure udev to give your razberry (or aeon stick) a different device name.
  2. Depending on the z-wave devices you’re using, you should see them added to home-assistant on the default page. You can check the log as well to see if there are any errors.

Also, keep in mind that you’ll need to add devices to your zwave network. I don’t think you can add one device to both your razberry and aeon stick at the same time, but someone could correct me if I’m wrong.

Thank you, now it is up an running! After a myriad of reboots and adding and removing devices :wink:

These are the steps (for me)

  1. Installed HA with the All-in-one installer. Followed all steps in this video: https://youtu.be/VGl3KTrYo6s

  2. Added this to the yaml file:

    usb_path: /dev/ttyAMA0
    config_path: /srv/hass/hass_venv/lib/python3.4/site-packages/libopenzwave-0.3.1-py3.4-linux-armv7l.egg/config

    (USB path from @justyns example)
    (Config path from this video: https://www.youtube.com/watch?v=ajklDCaOGwY)

  3. Added this to the config.txt


  4. Installed RaZberry


  5. Added devices in the RaZberry page, YourIP:8083 and they showed up in HA!

I guess you can add devices from HA with the zwave/add_node service?

I think I’m starting to understand how it all works now! Thanks again

1 Like

For some reason not all my node’s are pulling into home assistant? Anyone know why?

Also when running home assistant my razberry pages shows no devices and gives me an error saying it is unable to initialise the z-wave controller data.

17-02-13 20:09:44 ERROR (Dummy-21) [openzwave] Error in manager callback
Traceback (most recent call last):
File “/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/openzwave-0.3.2-py3.4.egg/openzwave/network.py”, line 974, in zwcallback
File “/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/openzwave-0.3.2-py3.4.egg/openzwave/network.py”, line 1266, in _handle_essential_node_queries_complete
**{‘network’: self, ‘node’: self.nodes[args[‘nodeId’]]})
KeyError: 18
17-02-13 20:14:41 ERROR (Dummy-21) [openzwave] Error in manager callback
Traceback (most recent call last):
File “/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/openzwave-0.3.2-py3.4.egg/openzwave/network.py”, line 948, in zwcallback
File “/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/openzwave-0.3.2-py3.4.egg/openzwave/network.py”, line 1474, in _handle_value_added
KeyError: 11

I have the same problem, did you find any solution?


I also have the same problem with not being able to run homeassistant parallel to the razberry UI. Did you find any solution?

You can not run two different zwave applications at the same time. In order to have HA handle your Zwave you need to disable the razberry service (z-way).

After you have install the razberry device. Run this:

sudo update-rc.d disable z-way-server

Edit /boot/config.txt. Add this:


I added this to my HA configuration.yaml:

usb_path: /dev/ttyAMA0
config_path: /srv/homeassistant/lib/python3.4/site-packages/libopenzwave-0.3.2-py3.4-linux-armv7l.egg/config
polling_interval: 30000
device_config: !include zwave_device_config.yaml

This will get you into the open zway control panel:

Make sure Home Assistant is not running! So stop that first
Login to Raspberry Pi ssh pi@your_raspberry_pi_ip
Change to the ozwcp directory cd /srv/homeassistant/src/open-zwave-control-panel/
Launch the control panel sudo ./ozwcp -p 8888
Open a web browser to http://your_pi_ip:8888
Specify your zwave controller, for example /dev/ttyACM0 (this should be /dev/ttyAMA0) and hit initialize

Your zwave config_path may be different and your usb_path may also be different. Hope this helps out.

Check out https://community.home-assistant.io/t/unable-to-configure-razberry-board-with-openzwave/4686/5 for more information

Lastly HA 0.43.0 killed my zwave so I had to roll it back for now.

1 Like

Thank you very much!
It looks like everything is working but I will have to verify when I get home.

Note, the command to disable was:

sudo update-rc.d z-way-server disable
1 Like

where can I find zwave_device_config.yaml ?

Just make an empty file with that name.

what step will fill the write config to this file?
my question is how the configuration we do on http://your_pi_ip:8888/ gets to the yams file?


There is literally nothing in my zwave_device_config.yaml file. I only have it because HA requires it. That file you are talking about is completely different to this yaml file.

Thanks, @jordanb05 . This almost got me there…

I have installed the SD card via Hassbian, and the paths seem similar to yours. However, mine seem to be version 0.4.0 and I presume some filename changes have occurred.

None of the folders (see below) have a config subfolder, but there is ozw_config in one. I’m going to try that. In case you already know what works with 0.4.0, I’d be happy to hear.

$ ls /srv/homeassistant/lib/python3.4/site-packages/*openz*

dependency_links.txt  not-zip-safe  PKG-INFO  requires.txt  SOURCES.txt  top_level.txt

EGG-INFO  openzwave


EGG-INFO  libopenzwave.cpython-34m.so  libopenzwave.py  openzwave  __pycache__  pyozwman  python_openzwave

In case others share my situation (Hassbian + RaZberry, with 0.4.0 Openzwave), please answer here what worked for you. :slight_smile:


config_path: /srv/homeassistant/lib/python3.4/site-packages/python_openzwave/ozw_config

…did indeed make HA start without warnings, for me. I’m still not sure if that’s the intended folder, though.