Home assistant suddenly wont load

i am getting the attached error when booting ha on an old PC.

sorry its a photo.

I have tried different ethernet cables, but no change.

I cannot access ha through the web client.

any ideas of the problem please?

thank in advance for any help

by old PC you mean ? , and “Suddenly wont load” also sounds alittle weak description :slight_smile: … anyway try to update NIC driver to r8168

sorry - it is a Distec ESI604-DC

and the screen photo is all i can access, no cli, nor webpage access or SSH - i cant really get much more info as to why it wont load.

so not even a linux console ? connect a monitor/keyboard direct to your ha instance, you wont get anywhere over the network , so somehow you have to get “into” linux, to either update driver , or try

sudo pacman -S r8168
sudo rmmod r8169
sudo modprobe r8168
sudo netctl restart wired

ok thank you - i will give it a try

i can access the pc with keyboard and monitor, i have tried the command sudo pacman -S r8168 but get the error sudo: pacman: command not found

ok, which “console” are you seeing/typing in ? , any indications that it’s actually maybe ha-console, and that infact ur ha-instance is up and running ?

ok, maybe i was to fast aswering, im sure your not in ha-console :), you would have noticed

but basically the error you showed from “some screen” before, indicates that the mentioned nic, doesn’t get an Ip-number from DHCP

it could well be - i can log into HA on the local machine, but cannot access remotely - still with the error r8169 000:02:00.0 ens1: rtl_txcfg_empty_cond == 0 (loop 666, delay: 100).

ok, so youi have ( ha > ) command promt blinking in front of you ?

i have:


If you actually now locally have access to HA, then in the ha-cli type

ha network


ha net info

oh ok, seems like your inside ha … anyway good sign
try to type

ha net info

EDIT: and see there whether you have gotten a local ipv4 number ( i.e 192.168.x.y )

i do have an ip4 address, but cannot use that either to shh or webpage access - i should have address reservation too on the router which is a different address to that shown

Fix that, either ditch the fix number, as the one number you see in your console, IS the one that HA have nove, regardsless of what your router/dhcp/host-file etc says … so the ipv4 you see in console 194.168.x.y::8123 … or http://homeassistant.local:8123 , depending on how you’ve configured you local network

thanks for your help so far,

even using the new local ip address i cannot access HAS either ssh or web page and still have the same error scrolling on the HA pc

yeah, i think you have to fix the nic drivers somehow, thou as you see/get’s an ipv4 Number by your dhcp, it seems like it can talk to the DHCP, Unless you have some other bogus settings that gives you that ip-number you see when you type, ( ha net info ) , that’s basically your network status, so what ever it says , thats it AND “help” is a basic co… i cant help you guessing, you are probably in a better chair to do that :wink: ( with ur monitor and keyboard in front of you) … and as i haven’t seen any screenshot from your webbrowser in ur mobile phone ( i asume u have one ) http://194.168.x.x:8123 or http://homeassistant.local:8123

EDIT: Reload, restart PC / HA OS fix you internal network, reload NIC uninstall nic, reinstall … the erros u get in PC , is related to the Drivers for that nic

thanks - have tried restarting multiple times - still the same error - attempting to ssh gets the following error image

and webpage is as follows:

its the same error on the local instance:
r8169 000:02:00.0 ens1: rtl_txcfg_empty_cond == 0 (loop 666, delay: 100).

i have a spare identical PC - i will try re installing HA on that and hope its all sorted before Sunday :confused:

thank you so much for your patience