Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)

@BeardedConti Is there something that you want me to add to post #2? Have you managed to find the magics that just fix things (was the red or blue pill)?

Sorry to say, but no.
Most of the things I couldn’t replicate. And all posts and recommendations that you mentioned worked.

1 Like

I’ve managed to get this working on Synology as suggested in the instruction above, Thank you. Do you know where I would put a www folder to add TileBoard files? I cant find the default config folder as suggested by most sites in hassio?

You should put it in …/hass.io/homeassistant folder.

If you used default values, it should be something like:

I have since moved to raspberry pi 4 booting from ssd and I couldn’t be happier. It is much more stable and super fast. I assume the slowdowns I was experiencing on synology was due to the hdd array. My other docker programs running on the synology are much happier now


Thanks, this worked, had to put it in:

1 Like

A post was split to a new topic: USB Booting Rasperry Pi

Is there a direct download link for the SPK? Synocommunity is down for days now… Cheers.

Did you check one of the first posts? There was link to dropbox.
EDIT: Can’t find it - looks like it was removed.

SynoCommunity is upgrading HW and should be up by the end of the weekend if everything goes as planned. There was a post somewhere on Reddit about this.

I found one from the author on March 30th. Just not sure if this is the latest and I already had an installation yesterday.

@fredrike thank you for all your hard work !

I have a DS918 which has two Ethernet ports.

Any pointers on how to get HA to use the second network interface rather than the default primary interface used by the rest of the DSM ?

That’s a interesting idea, would you then look to have your docker running on a separate volume and/or treat it as part of an iot network?


The primary interface is my Trusted VLAN.

Ive never used the second port but now have better networking hardware, so can easily put the second port on the IoT VLAN.

Hi Frederik,
Many thanks for all your hard work on this package. Really appreciated. It works pretty well.
What would be the best way to do un upgrade of hass.io? Can I just do the upgrade from within the hass.io interface? Or do you propose to use another procedure?

Many thanks!

I’ve been running this package for a year or so and always do the Home Assistant upgrade from within the GUI, nothing special is needed.

@fredrike This package has been running great for me. I installed a SSD on my nas and moved mariadb to that for better performance. Really works great. I also wanted to move my home Assistant folder to there. Worked fine, but now the docker containers will no longer start because it can’t find the old folders anymore. Tried editing it via the docker package but doesn’t work. Is there a safe way to safe this somehow? Only have to change volume 1 to 3 and it’s done. I wouldn’t mind using the cli for this. Or can I safely remove and install the package again?

Yes, just press update and that’s it :slight_smile: Of course - you never know if there could be a breaking change, so first, always, check Release notes for breaking changes.

Not fredrike, but will try to answer this :smiley:
You can do it in one of the following ways:

  1. use snapshot in Supervisor to create snapshot of your current system. Remove current installation, make new installation in different location and then just load snapshot from Supervisor menu
  2. remove current installation (all your files will remain), make new install at different location. Stop package and just copy files (including all folders and hidden files and folders) from old location to new location.

Whatever way you do it - result will be the same - first option is more user friendly, but can take a bit more time. Second option is a bit faster but you have to do it by hand.

1 Like

You can change the path of the hassio folder by editing: /var/packages/hassio/target/etc/hassio.json make sure to stop the package and all hassio containers first.

Cheers guys. I found that file and changed the location. I also edited the config files of the containers. It then gave me some errors about the pulse audio file that couldn’t be found (although I can see it). I removed that from the container and it booted. I updated to 0.101.2 from the supervisor and everything still seems to work fine, so I guess I’m all ready! Great work on the package.

1 Like