Home assistant Unifi controller

Hi all, running my Unifi network in the cloud at present but want to bring it back on site hosted. Anyone running a Unifi controller on the same host as their HA? if so any advice on doing so along with any pitfalls would be greatly appreciated.


Add-on works well.

1 Like

+1 for the add-on.

Have been using the Unifi Controller on H.A. for a long time, it works like a charm thanks to @frenck . He makes sure the controller is been updated when new versions arrive so all good.

great, thanks @silvrr , @Neil_Brownlee and @DotNet2Web for the feedback. Is it fine to be running this on the same host as HA itself, i also run MQTT and saw some comments on some co existence issues? is this something you have encountered at all?

also, when i go to the add on store i only see “Unifi Network Application” add on, has it been renamed at all? thanks

I run the controller and HA in separate containers on the same Synology NAS. Works very well for me, and I like the separation. If HA goes crazy, I don’t want to find my network also goes down…

I also run MQTT and much more on HA in combination with the Unifi Controller. No problems have occured in the last year.

To be complete I run HomeAssistant on a ODROID N2 board.

Recently, last week, I upgraded my unifi eco system and moved the controller away from HA into the hardware of Unifi itself.

Not because I experienced any problems running the controller within homeassitant but more because I want to keep those things seperated.

I run MQTT and a lot of other add-ons on my RPI4 4GB without issue.

great, thanks @Neil_Brownlee for confirming…installing it now. Then need to figure out how i export from my managed cloud instance to the on prem controller. Think its just an export/import but will need to get the org managing my existing setup to export i guess. thanks again everyone, always a helpful forum.

thanks @DotNet2Web, what Unifi hardware are you using to run that controller?

I’m using a Dreammachine SE to run the controller software.

For moving you existing controller to your Homeassistant version just follow this tutorial and your good:

great, thanks all. I have now ported all my devices from the cloud to an local HA hosted unifi controller. Thanks so much for all of your help. Just one last thing, i noticed there was an update whilst in the controller, i hit update and it downloaded a large .deb file. What do i do with that?



In case of an update for the controller software, not for the Unifi hardware, you have to wait till there is an update for the add-on within homeassistant.

Normally @frenck will update the controller add-on within a few days. Just wait till there is an update for the Unifi Controller Add-on and you will be fine!

Thanks @DotNet2Web. All working fine, I added the Unifi Network integration but i was thinking i was going to see lots of entities for the devices, things like throughput, number of clients, temperature etc but dont see any of this information. I have seen some people creating dashboards to this effect so not sure how they are scraping this information. I have probably missed a critical step somewhere? thanks

You need to add some Unifi integrations now :slight_smile:

@Neil_Brownlee , i added the Unifi Network Integration but it does not show me much. Its found the switch, USG, AP’s etc but just gives me very basic info such as software version etc, no operating metrics as such?
Are there other integrations i need?

There is one in HACS. Also have you clicked configure on the integration and gone through the config after install?

Also there is this in HACS

EdgeOS (Ubiquiti)

Hi, I installed the Unifi Addon on the Home Assistant OS of my Raspberry PI4 and it appears to have installed and configured correctly.
The problem comes when I try to integrate devices to my network.
I am trying to integrate a Switch Lite 8 PoE and a U6 In Wall AP, but when I press the Integrate button, it stays in Orange and does not finish integrating.
What can I review?
Thank you.