Home Assistant unusable/slow/not loading locally but fine with Nabu Casa

After updating to the latest 2024.5 update, my local home assistant has become unusable (slow and things just not loading) but is fine via Nabu Casa (snappy and quick, everything working just fine).

CPU load, temps and RAM are all ok barely breaking a sweat, but I’ve noticed some higher CPU usage since the update, but not enough to kill the system.

Even starting Home assistant in safe mode locally doesn’t make a difference.

Again, accessing Home Assistant via Nabu Casa URL in a web browser works perfectly.

Any ideas?

Any errors or warnings in the logs? How much more CPU is it using?

1% CPU load. There are errors and warnings in logs, but nothing stands out to me. Most of them are errors thrown up during reboot.

Take a look at your custom integrations and log files. 2024.5 added new debugging to identify custom integrations that are doing things incorrectly in HA. I’m willing to bet that you have a custom integration that is doing that very thing.

1 Like

I’ll sus it out. But why would accessing via Nabu Casa be totally fine but not when accessing the local URL?

As @code-in-progress said, can be related to addons. Try disabling all, enable one and one until you hopefully find the culprit.

1 Like

Disabled all add-ons and rebooted the system, still no good. Still super slow to load everything, but Nabu Casa is working well.

Sounds like local lan configuration errors. Maybe two devices on same ip? Have you tried rebooting your router?

Update: rebooting the router worked for all of a few minutes. Again, just as described earlier, the local home assistant URL is struggling, but Nabu Casa is fine, with no significant system resources being used. i.e. CPU and RAM are idling at 1% and 20% use.

Do you use Unify integration ?

Nope, the only integrations I use are:

  • Alexa Media Player
  • Bluetooth
  • Browser Mod
  • Bureau of Meteorology
  • ESPhome
  • Google Calendar
  • Google Cast
  • HACS
  • Home Assistant Supervisor
  • ical
  • LG Soundbars
  • LG webOS Smart TV
  • LocalTuya
  • Mobile App
  • MQTT
  • Radio Browser
  • Sensibo
  • Speedtest.net
  • Sun
  • System Monitor
  • Tuya
  • UI Lovelace Minimalist

HACS Add-ons:

  • Advanced SSH & Web Terminal
  • Home Assistant Google Drive Backup
  • MariaDB
  • Mosquitto broker
  • phpMyAdmin
  • Studio Code Server
  • Zigbee2MQTT

My MariaDB database size is 267.9 MB.

There must be something wrong locally with the router because when I access my Home Assistant instance via Nabu Casa it performs flawlessly.

Open CMD and ping homeassistant.local -4

You’ll get an IP and results if it’s replying to the ping.


If I access Home Assistant via IP address instead of http://homeassistant.local:8123/ it works flawlessly.

Any ideas what could be going wrong?

1 Like

Does the local IP you are entering match the CMD IP test? If you have the HA device set to DHCP on your router, the IP may have changed.

Yes the Ping IP to homeassistant.local matches the IP address I was using to access Home Assistant

Is your local network set in the UI or your configuration.yaml file?

Set to Automatic in UI Network settings page. I don’t ever recall setting up an IP in configuration.yaml

I only have MariaDB, includes to automations, scripts and scenes, and sensors coded in configuration.yaml

Is port forwarding enabled in your router settings? Something is blocking the local IP from the browser.

Did you try another device with the local IP to eliminate the MacBook?

I have no port forwarding set up in the router. The port forwarding rule list is empty. All of this wasn’t a problem prior to updating to 2024.5

I can access via homeassistant.local:8123, it is just so damn slow. Takes minutes for a single page to load if it loads at all.

Accessing via local IP is snappy like homeassistant.local:8123 used to be prior to update