Home Assistant Won't Boot


I am loading a new install of Home Assistant OS via SD card onto my ODROID N2 and keep getting the following error

Anyone know what might be causing it to hang at this point?

I see no error, so maybe you should just have some patience and wait a bit. :slight_smile:

Hm, the HDMI console is supposed to show the full OS boot and the Home Assistant banner at the end :thinking:

What version of HAOS did you install?

You might just need to wait a bit longer, the first boot initializes swap space which can take a while.

Maybe it’s not bad to share how you prepared that SD card. :thinking:

I have the same issue with the latest update on my Odroid and HA on eMMC card.
Click install, loose connection but does not reboot.

Had it with other HA updates aswell. Mostly solved by cutting the power of the Odroid and leaving it or several minutes. After plugging the Odroid in again the booting should succeed.

People here comment you should give it some time but how much time is that? If nothing happens after 30 minutes I suspect something is wrong?

Hi Thibaut, you are talking about updating while the OP is about a new install: different situation.

Ow sorry, did not read the first poist thoroughly then.

Thanks for all the comments, tried again this morning as I didn’t time how long it was stuck for the first time. It got stuck again for over an hour.

The SD install with via Balena Etcher using a direct download of the 12.2 file for ODROID N2. Flash was stated as successful.

Please use the latest 12.4 image, it prints the systemd boot log on the HDMI output, so it should be clearer to see where it gets stuck.

Thanks for the suggestion, this is where it appears to be getting stuck

It may be a faulty or fake SDcard.

Second attempt same SD card different issue

Not sure if it’s related but after updating to Supervisor from 06.0 to 06.2 I can’t get HA up again with journal spawning errors:

homeassistant hassio_supervisor[590]: s6-supervise watchdog: warning: unable to spawn ./run (waiting 60 seconds): Exec format error
homeassistant hassio_supervisor[590]: s6-supervise supervisor: warning: unable to spawn ./run (waiting 60 seconds): Exec format error

Tried with a second SD card and same message

There have been quite some issues in the past when using balena etcher to prepare HA installations.

That’s the recommended method on the Home Assistant site, is there another option which is more reliable?

I have tried different SD cards, different image versions, different flashing programmes and keep getting the same issue, any further ideas, I’m really stuck now :disappointed:

It is not a different issue.
It is the result of a unsuccessful boot, which cause HA to start in safe mode.

What brand and bought from where?
Amazon and AliExpress have many fake cards where the actual size does not match the reported one, which means at one point you can not write more to the card or you will overwrite existing data.

Used SanDisk Max Endurance, direct from SanDisks Amazon store