Home Assistant Community

Home Assistant won't install on a fresh Hassbian flash

hassbian
Tags: #<Tag:0x00007fcf499bb250>
#1

This is a clean install of Hassbian on a Raspberry Pi 3. No matter what I try I continue getting an error when trying to install Home Assistant.
I think this may be an issue with pip, but if anyone knows how to fix this I would really appreciate it if you could give me an answer. I have already tried disabling IPv6 and I’m not behind a proxy.

This is the error:

Exception:
Traceback (most recent call last):
  File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 594, in urlopen
    chunked=chunked)
  File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 391, in _make_request
    six.raise_from(e, None)
  File "<string>", line 2, in raise_from
  File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 387, in _make_request
    httplib_response = conn.getresponse()
  File "/usr/lib/python3.5/http/client.py", line 1198, in getresponse
    response.begin()
  File "/usr/lib/python3.5/http/client.py", line 297, in begin
    version, status, reason = self._read_status()
  File "/usr/lib/python3.5/http/client.py", line 266, in _read_status
    raise RemoteDisconnected("Remote end closed connection without"
http.client.RemoteDisconnected: Remote end closed connection without response

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/commands/install.py", line 353, in run
    wb.build(autobuilding=True)
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/wheel.py", line 749, in build
    self.requirement_set.prepare_files(self.finder)
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/req/req_set.py", line 380, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/req/req_set.py", line 620, in _prepare_file
    session=self.session, hashes=hashes)
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/download.py", line 821, in unpack_url
    hashes=hashes
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/download.py", line 659, in unpack_http_url
    hashes)
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/download.py", line 853, in _download_http_url
    stream=True,
  File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 501, in get
    return self.request('GET', url, **kwargs)
  File "/srv/homeassistant/lib/python3.5/site-packages/pip/download.py", line 386, in request
    return super(PipSession, self).request(method, url, *args, **kwargs)
  File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 488, in request
    resp = self.send(prep, **send_kwargs)
  File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 609, in send
    r = adapter.send(request, **kwargs)
  File "/srv/homeassistant/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/adapter.py", line 47, in send
    resp = super(CacheControlAdapter, self).send(request, **kw)
  File "/srv/homeassistant/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/adapters.py", line 423, in send
    timeout=timeout
  File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 643, in urlopen
    _stacktrace=sys.exc_info()[2])
  File "/srv/homeassistant/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/retry.py", line 315, in increment
    total -= 1
TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
#2

Is the fresh install sized to use all card space? I think the default Hassbian image partition leaves unused card space. Either that or there appears to be a network connection issue.

#3

I think it is sized to use all card space and is more likely a connection issue of Hassbian. How should I fix this?

#4

Could it be wireless issues? I always use wired Ethernet.

#5

look here Hassbian-config script issues

#6

@priva28, Is there any specific reason for choosing to use Hassbian?

I have found it easier to use a normal Raspbian install on the Pi, and install Home Assistant using Docker. Hassbian is basically a generic Linux install, with a built in script that installs HA for you.

If you use Raspbian with Docker for HA, and a great program called Portainer to manage your Docker install, It makes management of HA very easy. You can still install any other Linux based items you wish as well, if that was your reason for choosing Hassbian.

I would recommend you look at using Docker instead.

#7

Hassbian is a venv installation. Some people do not want the Python environment replaced every upgrade.

#8

yes, it is. And so is installing Rasbian and manually installing HA afterwards since the instructions for that also install it in a venv.

HA installed in Docker is kind of like installing it in a super venv so it is even more isolated from the OS.

I don’t know of any HA install except for Hassio in HassOS that requires a complete OS upgrade to update HA itself. So I’m not getting why you made that statement.

#9

The Docker container in which Home Assistant runs in is an Alpine Linux OS minus the kernel.
The OS libraries & python modules in the container are replaced with every release.

#10

true again but i don’t see any reason at all for that to be any concern to the user. You literally almost never interact with the OS in the container so why would the user care if the entire container OS gets updated on every update? As long as the OS in the container runs HA correctly most users will care not at all what the OS is let alone what version of a particular OS it is.

I still fail to see the relevance.

#11

There have been some custom components that required Python modules not in the container.
I think the new manifest system can handle that now with 0.92.

#12

I remember that you may have had troubles with that but that is not the experience with 99.9% of all users.

Even those who MIGHT have had some strange issue in that thread it only affected a couple of people.

The vast VAST majority of people will never experience ANY trouble at all in that regard from using HA in a Docker container. I don’t think it’s appropriate scaring new users away from using docker because of the experience of a couple of users of one custom component.

#13

I am not scaring them away. The OP is using Hassbian but I am currently on Hassio. I was just pointing out some pros & cons.
And, by the was there IS a Hassbian image that includes the OS, but I believe it is Raspbian based, just for the Raspberry Pi.

#14

Hassbian IS raspbian with venv pre-installed.

#15

Thank you to @ludeeus (again)… that fixed my issue…

For others:

sudo -u homeassistant -H /bin/bash
source /srv/homeassistant/bin/activate
wget -O /tmp/get-pypi.py https://bootstrap.pypa.io/get-pip.py
python /tmp/get-pypi.py
deactivate
exit
sudo -u homeassistant -H -s
cd /srv/homeassistant
python3 -m venv .
source bin/activate
python3 -m pip install wheel
pip3 install homeassistant