Home Assistant Yellow - builtin ZigBee

Hey! I received my Yellow today, super happy :slight_smile:
Old RPi4 Setup is already migrated, everything works perfectly, except for my wish to of course also switch to the builtin ZigBee Radio. I restored from my old setup which used a DresdenElektronik ConBee II, attaching the USB-Stick works perfect. I would have assumed I can just migrate via the builtin ZHA option “Migrate Radio” - sadly no radio appears.
Is there a Firmware to flash for the Radio module to become active or anything else I’m missing?

That’s a co-incidence - here’s a post on my migration from a Sonoff 3.0 Zigbee USB stick to the on-board Yellow SkyConnect SilLabs device:

Hey James,
thanks for the writeup! I tried it with ttyAMA1 and the builtin migration feature, I was even able to keep the names and locations (by never removing it). Control only seems possible after a few minutes of waiting - patience I didn’t have in quite a few tries before this final succesful one :smiley:

1 Like

Solution for those stumbling upon this:

  • Take a backup with ZHA via “Download Backup”, reachable under Devices, ZHA, Configure
  • Use the “Migrate Radio” feature to migrate to /dev/ttyAMA1 (at least for me), wiping your old radio on the way. Install the previously taken manual backup
  • Wait a few minutes for your devices to become accessible again
  • Unplug the old radio

I migrated from a Raspberry PI 3b to Home Assistant Yellow today. I used the procedure Tim has kindly documented here to migrate my Zigbee devices from the Conbee II to the Silicon Labs EZSP choosing /dev/ttyAMA1 from the list. The migration appeared to be successful but, alas, I am seeing some strange behavior.

Most of my Zigbee devices are Sonoff MINI Smart Switches that are installed behind light switches on the wall. The light switches work as normal to turn the lights on and off and the light on/off state shows up correctly in HA. But I can no longer turn the lights on/off using the switches in my HA dashboard. I also have some Sonoff S31 Lite outlet plugs. Same behaviors. All of this worked fine with the Raspberry PI 3B and Conbee II. I see the following in the logs:

Logger: homeassistant.components.zha.core.channels.base
Source: components/zha/core/channels/base.py:486
Integration: Zigbee Home Automation (documentation, issues)
First occurred: 4:38:35 PM (12 occurrences)
Last logged: 4:38:41 PM

  • [0xB6B7:1:0x0006]: async_initialize: all attempts have failed: [DeliveryError(‘Failed to deliver message: <EmberStatus.DELIVERY_FAILED: 102>’), DeliveryError(‘Failed to deliver message: <EmberStatus.DELIVERY_FAILED: 102>’), DeliveryError(‘Failed to deliver message: <EmberStatus.DELIVERY_FAILED: 102>’), DeliveryError(‘Failed to deliver message: <EmberStatus.DELIVERY_FAILED: 102>’)]

I’m hoping someone has some suggestions as to how I need to go about diagnosing the problem.

There are also some issues I see in the diagnostics report - like the Title of the Controller in the Integration is still “ConBee II …”. I have no idea where to fix that. The radio_type is “ezsp” which is probably the important thing. But I have no clear idea what I’m looking for in this report. Any help would be appreciated.


Update: False alarm. It’s all working now. I don’t really understand why but I noticed that two of the Sonoff S31 outlets were offline. Not knowing what to do I unplugged and then plugged them back in and voila! Not only did they come online but the issues with the other devices disappeared. Perhaps they were crucial nodes in the network?

Does Home Assistant Yellow have an external antenna option for Zigbee? I am not keen on the clear plastic enclosure, my preference is an RFI screened enclosure but this would require an external antenna.

Not as delivered, but the blank pads for J9 strongly suggest an IPEX / U.Fl connector would solder on (bottom left):

The circuit diagram confirms RF_SIGNAL does connect to J9, but no idea if there’s a software antenna select.

1 Like

THANK you!

Has J9 been confirmed yet as an antenna connection and if so, how we could use it?


Sadly, you have all the information I have - basically the hardware docs for Yellow.

Solder on a PCB mount IPEX / U.Fl connector (very common, even Amazon has many options), clip on an antenna pigtail, and see if range improves?

If not, the next step would go digging in the datasheet and radio driver code, but antenna select could be in a closed-source SiLabs firmware blob with an unpublished API. Don’t know what has been published so far, given the radio is under development to add Thread to the existing Zigbee protocol stack.

Hi, used your solution. THNX.
Did you change the name of your zigbee radio afterwards??
I dont like its stil called conbee.

No, I have not. I don’t like it either, but I am working hard to suppress my obsessive tendencies. My advice is to reframe it as a stoic challenge😉


I have an issue with the built in device…

I added then removed a device… when I tried to re add… than I face with that…

“Device seen - marking the device available and resetting counter”

I don’t know how to fix this…

Tried to remove Zigbee radio… and add again, but it wasn’t helping…