Home assistant Yellow installation issues

Sorry for not specifying, it’s the PoE kit (although I’m using a power adapter instead of PoE). Installed a brand new C4 module, 8gb Ram 32gb eMMC (model CM4108032)

I am thinking of adding an SSD at some point in the future, but nothing is connected right now.

I have installed an Aeotec Z-Pi7 Zwave controller.

This is what I had found, I’m going to try again.


Edit: no luck using the “recommended method”. I tried several times, and every time both the green and red lights are on, not the red only.

I’ll see if I can try the other methods.


Option 2 isn’t working either. I set the jumpers, plug it into my PC (only the red light is on now), but when I run rpiboot, it does nothing just says “waiting for BCM2835/6/7/2711…”

I’m going to pull the C4 module, remove the Zwave controller and try again. :rage:

Well, there’s a new issue. How the hell do you remove the heat sink to change the C4 module? I can’t seem to pull the pins holding it in place and there’s no hole beneath the case to poke them out.

Edit, nevermind, I figured out how to get the lower clear plastic panel off.

I reinstalled the CM4 module. I was wondering if maybe it hadn’t been seated properly, but it was.

I have tried both options for reinstalling the os, when I hold on the blue and red buttons, it never starts with only the red light on.

Running rpiboot never goes anywhere (the 2 jumpers are set as specified in the instructions). The HA Yellow is connected directly to the computer with a USB cable, not through a hub.

I now have a very expensive paperweight that I had to wait a year and a half for. :face_with_symbols_over_mouth::rage:

I was able to get my new HA Yellow PoE up and running just now. I am using the same CM410832 module as you. However, because I did not want to use the onboard eMMC, I had to follow this guide in order to change the default boot order. I wanted my 1TB WD SN750 NVME drive to be both my boot and storage drive. I used another Raspberry PI as the USB boot host for the Yellow, as Windows is not supported when building the new code required to change the boot order.

It should be noted that two jumpers on the Yellow board need to be moved (JP1 to ‘USB’ & JP2 must be bridged) in order for the Yellow to boot off of the USB-C port. Also, one must supply external 12v power to the Yellow in order for it to be seen by the computer one is running ‘rpiboot’ from. For me, my goal in doing this was to update the firmware on the CM4 to make it boot from NVME first.

In order to get the HAOS 9.4 for the Yellow installed on the NVME drive, I simply downloaded haos_yellow-9.4.img.xz from Releases · home-assistant/operating-system · GitHub. I then used the Raspberry Pi Imager (on my Win11 PC) to flash the image I just downloaded to the NVME drive that I had temporarily installed in a USB to NVME enclosure. Once the drive was imaged, I removed it from the USB enclosure and installed it in the HA Yellow PoE board.

Finally, with JP1 and JP2 back in their original positions, I simply plugged in a PoE Ethernet cable. After about 5-10 minutes, I was able to connect to the Yellow board via my web browser.

I know my process is a little non-standard… However, it seemed like the easiest method to me. I have had some prior experience with using CM4 modules in other boards, so this was a little familiar to me.

I hope this helps! Good luck in getting your Yellow PoE up and running!


Thanks for the update.

I tried on 2 different computers, a windows computer and a Mac, and both had the same result running the rpiboot - it never progressed from waiting for the computer. I tried with both the HA Yellow and another CM4 I have mounted to a Piunora board I recently got but hadn’t had a chance to set up yet, so I have no real experience with either. Neither of them worked on either computer.

I’ll see if I can try running it on one of my RPi Zeros when I get a chance.

I may order an SSD to try this out. Does that completely bypass the eMMC? That might be a good solution, as it would also allow me to replace the CM4 board at any time in the future if there are any issues.

I was looking forward to migrating everything over this weekend, looks like it’s going to be a few more weeks at least now. :frowning:

Thanks again.

Yes, it does bypass the eMMC as long as the boot order in the CM4 is configured to boot NVME first. I am not sure what would happen if the boot order still looked first to the eMMC, even it it were empty.

Are you 100% sure your CM4 has eMMC on it? The part number you mentioned above does indicate that it has 32GB of eMMC… Just a thought that would explain the behavior you’re seeing… :thinking:

1 Like

Make sure you buy a NVME M.2 SSD. Some users in the other Yellow threads have had issues with some SSD’s - especially those who have tried a M.2 SATA SSD. :wink:

1 Like

Yes, without taking it apart again, I can see both the eMMC and WiFi modules from the side, as depicted here:

I was also looking at a WD, different model. It is a NVME M.2.

1 Like

@MarkWalsh I just went through the same process and issues. I wasn’t really paying attention and the install via rpiboot process passed before my eyes. Then when I ran again it just sat looking. I reinstalled rpiboot, rebooted the machine, and reattached the HA. Then rpiboot ran properly and installed ok. I was able to then use the eMMC as the location to install the OS and run everything ok (I think). Now I have to work through my internal network to see the HA and configure. I am not sure my input helped a lot, but I guess it seems like I had a similar issue.

1 Like

I haven’t had any luck yet. I’ve tried using the reset button, I’ve tried switching the headers to mount via usb, but the rpiboot never recognizes it.

I bought an SSD and have that mounted, but still no luck.

I’ll try again when I have time to devote to it. I’ve also ordered an NVME adapter so I can try installing the system directly on the drive. I also may order a RPi compute development board to see if I can use that to install the system. I have another computer module 4 that I’d like to use for another purpose.

Otherwise, maybe I can see if there’s someone in the Philadelphia area that is more familiar with this that could help me get the system installed.

Last resort, I order another without PoE and wait another 2 months.

I finally had time to get back to this. No luck with anything.

I used a USB Nvme adaptor, successfully installed the Home Assistant OS onto the drive (I didn’t download the file as suggested, just used the RPi imager to install the HA OD (not the Yellow installer) onto the drive. I’m not getting anything. My router briefly showed an extra device in the count (35), but very quickly dropped down to 34 devices and never came back.

I want to verify what is the correct setting for the jumpers to boot off of the ssd. I tried with the jumpers in both positions, in one I only got the red light on solid, the other I got both the red and green lights on solid. The green light never blinked once.

Getting extremely frustrated with this.

EDIT: I think I figured out why I couldn’t get it to mount to my PC as a USB device. I’ve been using the wrong USB ports. I need to use the USB-C port (I had a usb-c cable but can’t find it right now) I missed that part.

I’ll order a new cable and try yet again next weekend if I have time.

I finally got the thing to reset during startup. I’m trying another install of the eMMC OS using the Yellow installer on USB stick.

Edit: SUCCESS! I finally got to the “Preparing Home Assistant screen!


That is good news. I wish I could have been more help, but your sticktooitiveness is on point.

Dear friend. I am having the same issue only red and green lights are on on my POE version. How did you solve the problem?

Sorry for the delay, i haven’t been on the forum for a while.

I went through the reinstall process.


I don’t remember what happened that finally got it working, or why it wasn’t working the first few times, I just kept trying. I was never able to get it connected to the rpiboot, I don’t know if I had the wrong cable (it said it was a data cable when I bought it), I used option 1 and eventually was able to reinstall.

I believe I also swapped out the Ethernet cable I was using (I wasn’t using PoE) just in case, but I don’t think that was what solved the issue.

I hope you’ve gotten it working.

Just got the full kit with the CM4 included, Status LED is blinking twice (patern) imagine that is the heartbeat for more then an hour, so i tried the Re-install recommanded way, didnt do much more, and now tried the other way still nothing.
any ideas…

If you got the full kit, you shouldn’t have needed to do anything, it was preinstalled.

1 Like

Hey Mark thanks for the link,

I had also same problem and been trying for several days to install home Assisstant Yellow as well.

I got always flickering yellow led even after 20 minutes and kept flickering. After unplugged everything out of my home assisstant yellow. I plugging the power wire back in and holding blue and red button like that for 5 seconds.As described on the website: Home Assistant Yellow Guide

And applied the process back from beginning:

. I put the usb flash back into the drive with Raspberry Pi software
. Internet cable and power cable back into home assisstant Yellow
. After installation, finally only the red led remained on; installation completed

Hope by now everything is working for you!