Home Assistant Yellow - turn off status lights

Is there a way of turning off the status lights? I only need them on at the start, not forever


I just had the same question,
and the yellow documentation refers to the rpi documentation.
So I was actually planning on trying this.

I spoke to soon,
on my rpi4 is was just possible to edit config.txt
but is doesn’t seems to be the case on the yellow, I think because of the additional SSD

After a lot of struggling I was finally able to modify config.txt
but no luck, I did a test first on my RPI4 with HAOS and there all leds are off,
but the same settings on the yellow don’t have any result.
The only advantage now is that I know how to modify the config.txt file now.

So I’m still looking for a solution how to disable all leds


Did you finally find a way ?
Looking for the same but I didn’t find any positive answer so far.

1 Like

SSH Login with port 22222 (see tool for that : 🆕[add-on] HassOS SSH port 22222 Configurator) and edit the config.txt file in mnt/boot/ did work out for my #yellow. At least I tried to change the red to heartbeat - that worked.

1 Like

I couldn’t disable the red LED, but figured out how to disable the yellow and green ones. I put the following at the end of the /mnt/boot/config.txt file and rebooted.

# Home Assistant Yellow

# Turn off the Yellow user LED

# Turn off Power LED

# Turn off Red Activity LED
# Can't really disable this since it isn't left in the device tree.
# dtparam=act_led_activelow=off

# Turn off Ethernet ACT LED

# Turn off Ethernet LNK LED

You can see where these values are set from this patch to the device tree for the Yellow.


Okay, I figured it out. I had the Red and Green LED’s mixed up. Turns out the power LED needs to be set to pwr_led_activelow=on. I switched the pwr_led_trigger to panic to have an indicator physical indicator if there’s a kernel panic of some sort. Here’s the updated configuration. Use none for the pwr_led_trigger instead of panic to completely disable the LED.

# Home Assistant Yellow

# Turn off the Yellow User LED

# Turn off the Red Power LED

# Turn off the Green Activity LED

# Turn off the Ethernet ACT LED

# Turn off the Ethernet LNK LED

I’ve tested quickly and IT WORKS !! I was able to make it look totaly “dark” :-d (To be honest I enabled back the LEDs, to better think other time what I will disable, but … it works !! :slight_smile: )
Nice, Thanks, @jwillikers !

1 Like

I’m going to try this but it would be nice if this was possible via the HA settings in the web interface.

1 Like

Ya, especially as I don’t necessarily want them off all the time.

FYI - it seems to be possible from UI interface at this moment

System - Hardware (Home Assistant Yellow) - Configure

(I am using Home Assistant 2023.6.2, Supervisor 2023.06.2, Operating System 10.3, Frontend 20230608.0 )

I saw that it can be turned of manually. How about through an Automation rule? ie. at 6pm to 6am I want to turn of these LEDs as they are right next to my TV. But wants it on during the day for easy status indication.
I tried to find it in intergrations, but are not sure if Yellow even features?