HomeAssistant and Reolink Doorbell POE

Evening guys,

Well I have received my new POE doorbell and if works perfectly save for two things which I hope will have been sorted with HomeAssistant. Due to going for the POE for stability in my network setup I have had to forgo the option of receiving “Rich” Notifications. I hoped to solve this with HomeAssistant and the automation that it allows for me to fill that gap. This lead me to search for the specific Integration that would allow this and I came across a fork of the main one available in the HACS addon by JimStar

Whilst this had to functionality sorted with the ONVIF notifications, the current firmware publicly available for POE did not have the notification for “Visitor” added to the notification XML. Thankfully myself and another user (shout out to skynet01 on Github) messaged support about this and they thankfully have sent us an up to date firmware for both Wi-Fi and POE which resolves this functionality. This means that notifications can be set up off the button press of the doorbell now.

Until this is released to the general public (or if someone from Reolink support can add it here or officially) skynet01 has it hosted on Google Drive which will be linked below.

POE version: 1459_22102808: https://drive.google.com/file/d/1WH6tef5x4RfH9WcHQrxWWOadN049UjFH/view?usp=sharing
Wifi version: 1459_22102806: https://drive.google.com/file/d/1WKDSj5dQX8ApbAMwzCwVI7g05dGGiusj/view?usp=sharing

(if this isn’t allowed please let me know)

After upgrading the firmware it has been advised by support to go to “Settings>Network settings>Advanced>Port settings” to check and enable the ports first.


After that install the HACS integration by JimStar and you will be able to add the respective automations for snapshots etc to allow your own version of “Rich” notifications. I won’t go into how to here as there are multiple ways to do this and each personal to your own circumstance but this gives you complete local control of your Doorbell.

Again big thanks to JimStar for the integration fork and to skynet01 for hosting the firmware until Reolink gets it pushed publicly.

This link to the resolved issue and further details as to why this was needed is as follows: https://github.com/JimStar/reolink_cctv/issues/49

8 Likes

+1 for JimStar’s integration it solved all my Reolink_dev integration issues of missing notifications and random errors popping up, it also actually uses ONVIF subscriptions to get push motion notifications from the camera.

I can also confirm the doorbell press notifications work with Reolink POE Doorbell once you install the firmware above.

After testing it for 2 weeks I was finally able to get rid of mediocre Frigate and move my setup to this new integration.

If anyone is interested I can post my NodeRed flows for rich notifications to Telegram and iOS app.

2 Likes

@MattEng0 thanks a lot for this. now I can order the reolink doorbell, as soon as it will be available. :slight_smile:

We might want to notify @TheHookUp, that recently did a great review of a lot of doorbells, and while the reolink came on top, he clearly said there was an issue with the Visitor sensor not working. here’s a clip I made of that warning, from the full video review:

1 Like

That would be great :slight_smile:
My reolink PoE doorbell is ordered and on it’s way, so your flows are very welcome.
I’m also using Telegram and the iOS app.

Is the reolink doorbell able to send a notification to a google nest hub when the doorbell is pushed?

I don’t think that’s supported out of the box for Reolink. But you should be able to do it by using the doorbell press trigger (or through Node) that JimStart’s integration provides.

I actually use Scrypted to get streams into Homekit, Alexa and Google as it’s very reliable and best of all instantly loads without having to wait.

Ow really? I am also using scrypted for some other cameras :-). Indeed it’s pretty good. I saw there was a reolink plugin, however I thought I read somewhere that the reolink doorbell was not compatible. Are you using your Reolink PoE doorbell with scrypted? You get the doorbell button state into scrypted as well as the doorbell person detection? It works good in HKSV?

Is 2-way audio working?

I am using Reolink Doorbell POE with Scrypted, works great. You should be able to ge Reolink Doorbell ding with ONVIF as you are correct Reolink Scrypted plugin doesn’t support the ding from the camera. I use MQTT Scrypted plugin to get doorbell ding notification from HA (Use “Button” template and set it as type Switch in MQTT plugin) then I grouped that MQTT sensor with Reolink Camera in Scrypted.
Make a group in Scrypted and add these to your group:

  1. Doorbell Ding sensor (BinarySensor)
  2. Doorbell (Camera)
  3. Doorbell (VideoCamera)
    Assign it only to HomeKit and disable other integrations (as the entities above already do them by themselves)

Remove the old none doorbell HomeKit connection and add this new one. Should be good to go after this.

Thanks for clarification! I do a little bit the same with my eufy cameras in scrypted. Also using the mqtt plugin and send mqtt messages from HA to scrypted. Indeed maybe it would be easier to get the doorbell push through onvif directly in scrypted.
Are you doing the same with the camera person detection? Or are you only using the doorbell push button?

And is 2-way audio working in scrypted?

Onvif plugin has a doorbell option for a device but it’s asking for doorbell event field? I assume it’s like topic of sorts that it listens for in the ONVIF notification. It could be as easy as dropping this in? tns1:RuleEngine/MyRuleDetector/Visitor which I haven’t tried since I already had gotten MQTT setup working. For motion detection I am using Scrypted reolink plugin which uses Onvif to get those events.

The 2 way audio is not working as Reolink doesn’t support Onvif Profile-T (As far as I know that’s what needed to get it working, so maybe if we bother Reolink enough they will add it)

I did ask the author to add doorbell feature directly into reolink plugin here as you can see he seems pretty busy … maybe if enough people post there he will add it.

Are you able in scrypted to use:

  • The onvif plugin to get the doorbell push button
  • The reolink plugin to get the motion detections
    At the same time? I guess you should use 1 of the 2 and you can’t use both at the same time?

I’ve made a request for onvif profile T at the reolink community forum :slight_smile:

And I will definately reply to your scrypted thread. It would be great to have the doorbell push button integrated in the reolink plugin itself.

  1. Havent tried to get the doorbell push button through ONVIF Scrypted plugin as I have it working through MQTT (I get this event from Reolink HA plugin, which in turn gets it from ONVIF)… but since I am not a dev I am not sure how to do it through Scrypted ONVIF plugin directly.
  2. Yes I use Scrypted Reolionk plugin to get the motion events (you can also use the ONVIF plugin to get the motion events, I tried both they work the same). You can use both (doorbell trigger and motion) at the same time, if you do it this way, it will be classified as a doorbell which is much better since then HomeKit will notify you differently when doorbell is pressed.

You’re totally right :slight_smile: forgot that a standard onvif plugin is also capable to send motion detection. That makes is easier.

And I guess I have some good news, got a reply from Reolink:

It seems the doorbell supports now onvif profile T, it means everything should be able to do through the standard onvif plugin in Scrypted:

  • doorbell press
  • motion detection events
  • 2-way audio

My PoE doorbell is on it’s way, so I hope to receive it soon :partying_face:

1 Like

I guess the scrypted onvif doorbell event name is without the tns1: in front.

So only “RuleEngine/MyRuleDetector/Visitor”

1 Like

@skynet01 did it work? Do you receive the doorbell press using the standard onvif plugin?

Just FYI, my PoE doorbell was shipped with this firmsware, so apparently it has been released.

2 Likes

I just received mine the other day. Everything works with the ONVIF plugin on Scrypted, except for 2-way audio. Have you been able to get it to work?

Looking to get the PoE version. Please where did you get yours? Its been out of stock on the reolink website for weeks

1 Like

I can confirm that I see the “Visitor” sensor as a doorbell button press in HA, using the JimStar integration. But there is a big issue on my side… I get the device with 12 entities… none of which is the camera itself. I can see the doorbell and all it’s sensor glory… no picture or video entity.

I am indeed on the latest release of the firmware as well.

Anyone? (Edits to include screen shots of my HA config, and camera config within the Reolink PC app.)

OK… edited yet again… this must be what I’d read in someone else’s post then… I just didn’t understand it. I’d heard someone mention that they just walked away for an hour or two and then “it” appeared. I didn’t understand they were talking about the video/camera entity. But it happened for me after about 15 minutes… just be patient, I guess!

Ok… and now another issue, and I wonder if others are having it or not. In the former Reolink integration, I had always and forever just used the picture entity card to display camera pictures, and then just tapping through that “cover” picture that refreshes every ten seconds, in order to see actual video.

Now, switching to the JayStar integration so I can use the doorbell button, everything looks and feels the same, but when I tap through the picture for any camera I have, video never starts.

Everything else on the doorbell works, and I know video itself is fine, because I can access through the Reolink app. But HA is no longer showing as it used to. One think from the former integration, was that I could have sworn there was a buffer/no buffer check box in the config of the picture entity card. I don’t see anything like that in this now. Maybe that’s new in Lovelace though, having nothing to do with the new Reolink integration.

Anyone else having same/similar issue, or have any ideas on where I may have not done something quite right?

In the integration configuration, there are a few settings that made a difference for me. I set the stream type to RTSP and 264 standard. Also, try different streams. You can also install go2rtc addon followed by the RTSPtoWebRTC integration, this will make all your video playback very smooth.