HomeAssistant update fails

Fails to update from version 0.100.3 to homeassistant:0.101.0 Don’t now what can be wrong!!
Hassio running in docker on Raspberry pi3b+
19-10-31 18:21:20 WARNING (MainThread) [hassio.homeassistant] Don’t wait anymore of Home Assistant startup!
19-10-31 18:21:20 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!

I solved updating issues last night by removing everything in my config.yaml, then updating, then putting everything back in to my config. Good luck.

Thanks! Will try your solution.

I’ll add my plus one to this - update starts, eventually hassio restarts with 0.100.3 still running. I don’t have time to play with it now, but will try the yaml suggestion later

Hi i have exactly the same issue, after reboot when running the update from 0.100.3 to 0.101.1 it boots with 0.100.3.

If i check through the ssh console it is 0.101.1 for a moment. But when home assistant finally boots it is the old release 0.100.3

When in the process of updating:

➜ ~ hassio homeassistant info
arch: armv7
boot: true
custom: false
image: homeassistant/raspberrypi3-homeassistant
last_version: 0.101.1
machine: raspberrypi3
port: 8123
ssl: true
version: 0.101.1
wait_boot: 600
watchdog: true

and after reboot it removes the 0.101.1 image:
19-11-01 08:47:12 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
19-11-01 08:47:12 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.100.3
19-11-01 08:47:13 INFO (SyncWorker_15) [hassio.docker.interface] Cleanup images: [‘homeassistant/raspberrypi3-homeassistant:0.101.1’]

Did not yet try the above suggested solution.

I’ve fix the problem by shifting api_pasword from http component to auth_providers component.


Hi Alex,

Tnx! That worked for me.

   - type: homeassistant
   - type: legacy_api_password
     api_password: !secret http_password

Since about 0.98.0, I’ve had between 2 and 4 attempts (waiting an hour for ‘each’ update to complete) to get my system to actually update.
I run hassio 2.12 (on a pi 3b) 32gb card (only 8% used) and am currently on 0.100.3
I now backup (off card) before any attempt. :cry:

also for me same error

what did you leave?

1 Like

Don’t know what is essential but left the below…

  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: 49.299
  longitude: -123.1408
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 0
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: America/Vancouver
  # Customization file
  customize: !include customize.yaml

# Configure a default setup of Home Assistant (frontend, api, etc)

1 Like


Same for me here :slight_smile:

hi all,

I also had update issue, and
I just comment the “api_password:” than update 0.99.2 to 0.102.0b0 successfully.


Can you explain this a little more? I don’t have “auth_providers” in my configuration.yaml

That worked for me!

To have more info on #auth_providers see

Trusted networks has moved from http: to auth_providers:

This worked for me!

- type: trusted_networks