Homebridge and Home Assistant ssl problem

I have tried to sett upp Home Assistant with letsencrypt and Homebridge. I cant get it to work…
I tried to follow:


This is how my Homebridge config.json looks like:

    "bridge": {
        "name": "Homebridge",
        "username": "CC:22:3D:E3:CE:30",
        "port": 51826,
        "pin": "031-45-154",
        "manufacturer": "@nfarina",
        "model": "Homebridge",
        "serialNumber": "Not Specified",
        "firmwareRevision": "0.4.27",
        "hardwareRevision": "<optional>"
    "platforms": [
    "platform": "HomeAssistant",
    "name": "HomeAssistant",
    "host": "",
    "password": "MyPassword",
    "supported_types": ["automation", "binary_sensor", "climate", "cover", "device_tracker", "fan", "group", "input_boolean", "light", "lock", "media_player", "remote", "scene", "sensor", "switch"],
    "default_visibility": "visible",
    "logging": true,
    "verify_ssl": false


systemctl status homebridge:

Oct 16 09:15:16 raspberrypi homebridge[486]: [10/16/2017, 9:15:16 AM] [HomeAssistant] Fetching HomeAssistant devices.
Oct 16 09:15:16 raspberrypi homebridge[486]: [10/16/2017, 9:15:16 AM] [HomeAssistant] Failed getting devices: Error: socket hang up. Retrying... 

I have tried different ports, tried with my dns domain…
If anyone got some ideas i would be really grateful!


Was just a rookie mistake…

Would you share your rookie mistake to another rookie? :relaxed: I’ve got the same problem.

From one rookie to another…if you were in the same situation as me and had set up SSL…

Go to your homebridge config.json
Make sure “host” is https://
Change “verify_ssl” to true



When i enabled homebridge to autostart the config.json file moved to: /var/homebridge/config.json… So i was edditing the wrong Json file…

veryfi_ssl should be set to false…

From the documentation of Homebridge-homeassistant

Using with self signed SSL certificates
If you have set up SSL using a self signed certificate, you will need to to set verify_ssl to false in your config.json file to allow bypassing the Node.js certificate checks.