Using Homebridge with SSL

I am currently using the homebridge-homeassistant module with homebridge to access and manipulate my HA devices with Siri. This weekend I decided to implement SSL and all went well with HA. That is until I tried to use Siri to turn on a light. I noticed that in the config.json file I needed to change http to https. After making the change Homebridge still cannot connect to HA. Has anyone got this working?

I’m very interested in this and didn’t know it was an option. I’ll try this out and post back later this evening (U.S. Mountain Daylight Time).

I’ve been fighting to get it to work, and have been having a few issues, but I do have a thought.

Out of curiosity, are you able to get it to work if you don’t use the “https”?

It might be that the homebridge-homeassistant is lacking the ability to negotiate the ssl connection.

Sorry its been a ruff week and am just now getting back to this. Yes it works fine when https is out of the picture. The problem is that HB does not like the self signed certificate. Thats the error I get from HB when firing it up. HA does not have an issue with it at all. Have posted to the HB-HA repo but have not had anyone answer the question to date. For now sticking with http just so I can use Siri with my devices. Wish I had a “Siri in a box” June 13th???

Interestingly enough thats how I have it set up. Only points to an internal address like as I am running DNS inside my network in order to resolve it. I will attempt to hardcode my exteranl ip to see if that makes a difference and post results here.

Ok, so external ip gives an error ECONNREFUSED and bails. Tried https://localhost:8123 and that gives the same self signed cert error as before. I am not sure how to get this working, but I would really like the security of https with HA.

Are you sure your config.json is correct? Here’s mine, everything works without issue:

“bridge”: {
“name”: “Homebridge”,
“username”: “CC:33:4D:E4:CE:45”,
“port”: 12345,
“pin”: “123-45-678”

"platforms": [{

        "platform": "HomeAssistant",
        "name": "HomeAssistant",
        "host": "",
        "password": "secretsquirrel",
        "supported_types": ["light", "switch", "media_player", "scene"]
}, {
        "platform": "HarmonyHub",
        "name": "Living Room Harmony Hub"



Yep, config.json works fine when HA and platform are set to http. When enabling HA and setting http to https in config.json is when I get the error from HB. HA works fine with https enabled. I am beginning to wonder if it has something to do with the way I generated my certs from open-ssl on the Mac. Thats the only diff I can find. I can’t seem to get the 90 day certs generated from lets encrypt, so I went with open-ssl.

I have the same issue as Keith. Is there any update for this?

Best Rik

I had this issue.

Mine was caused by running in a docker container which wasn’t given access to the SSL certs directory.
Along with the SSL certs having missing information themselves.

I fixed my HA issue (in Docker) by adding

-v /path/to/certs:/path/to/certs:ro

to the run command via SSH my Docker container for both HA and HomeBridge also now MUST be ran by root via SSH to avoid any problems.

You can read about my Cert missing information in this thread…

Hope this helps.

Trying to setup and did not know what is the username (seem like a mac id), port and pin in the config.json?