Homekit-integration: No answer from all devices

tl;dr: In Apple Home all of my devices are shown with “No answer” and I can’t switch them.

I have Home Assistant exclusive on a raspi 4 with ssd. For external use I configured my traefik on another host to route traffic to it from a separate domain. For this I configured

  use_x_forwarded_for: true
  external_url: "https://my.domain.tld"
  internal_url: ""

22 is my traefik-host and 165 is Home Assistant.

All this works fine until I tried to integrate HomeKit. I used configuration tips from this page. I tried just adding
and I tried adding

  - name: HASS Bridge
    ip_address: ""
    advertise_ip: ""
    port: 21065

Every time I can integrate the bridge in Apple home and all devices are shown. But none of the device can be used, everything has “No answer”. In my local network there is a Homepod mini and an Apple TV 4k, both show up in Apple Home as bridges.

I searched the web and all I found was something about IGMP. I have no vlans, no special network config, just a Fritzbox and everything on one local LAN, ipv6 switched off. I switched off Multicast TV in my Fritzbox, but no effect.

Any help is appreciated, thanx in advance!
Cheers, Michael