HomeKit "No Response"

Tags: #<Tag:0x00007fc40b7d81e8>

Hello!

I tried to open a Github issue, but I didn’t get any answer… So I try to ask here! :slight_smile:

The problem

Every time I reboot Home Assistant, HomeKit works for about 1 minute (maybe a little bit more), and then all my lights (I only have configured lights in HomeKits) become unavailable with a “No response” state.

Environment

  • Home Assistant release with the issue: 0.105.2
  • Last working Home Assistant release (if known): -
  • Operating environment : Hass.io
  • Integration causing this issue: HomeKit

Problem-relevant configuration.yaml

auto_start: false
port: 51827
ip_address: 192.168.X.X
filter:
    include_domains:
        - light
    exclude_entities:
        - light.salon_1
        - light.salon_2
        - light.salon_3
        - light.projecteur
        - light.gateway_entree
        - light.gateway_bureau

Traceback/Error logs

Nothing to show. I haven’t any error log.

Additional information

I opened my router firewall ports for UDP (5353) and TCP (51827) for my HassIO device (https://www.jethrocarr.com/2018/06/03/firewall-rules-for-homekit-with-homeassistant/).

I have the exact same thing :disappointed:
My log shows:

2020-02-28 21:23:39 DEBUG (Thread-37) [pyhap.accessory_driver] Sending event to client: ('172.16.0.40', 53430)
2020-02-28 21:23:39 DEBUG (Thread-37) [pyhap.hap_server] No socket for ('172.16.0.40', 53430)
2020-02-28 21:23:39 DEBUG (Thread-37) [pyhap.accessory_driver] Could not send event to ('172.16.0.40', 53430), probably stale socket.

@AdrianPal did you set your log for HAP to debug like this? Wondering if you have the same log entries.

logger:
  default: warning
  logs:
    homeassistant.components.homekit: debug
    pyhap: debug 

My bad, I forgot to answer this thread, since I opened a Github issue in the same time…

I succeeded in fixing this issue… by restarting my router (by accident :sweat_smile:).

Now, HomeKit works perfectly! I even added some entities to HomeKit after that, and it is still working… Love it!

I don’t know if you already have rebooted your router? Maybe you could give a try?

@AdrianPal I kept looking at my HA config and thinking that was the cause of the HomeKit No Response issues as I recently migrated to a new machine. But your comment about the router turned my attention towards my router and it turned out, that for some reason, my DrayTek 2926 router was messing around with the multicast messages.

So, I disabled the following options in my router’s config and it started working again! :partying_face:
IGMP Proxy
IGMP Snooping
IGMP Fast Leave

Thank you for pointing me in the right direction :raised_hands:

2 Likes

I started having problems in the past month or so where HomeKit showed everything as ‘no response’. After reading this I started looking into my UniFi home network setup and ended up turning off “Enable multicast enhancement (IGMPv3)” for each wireless network. That fixed the issue immediately and everything seems to be fine.

I’m not sure why it suddenly stopped working when I didn’t change any of my UniFi settings, but I think I remember updating the UniFi Controller software at some point and maybe that’s when it started happening. Anyway, thanks for giving me the idea to look into my router/network setup rather than my HA setup!

2 Likes

Unfortunately this isn’t solving it on my end.

I am having the same problem, but I did not have it a while ago. Maybe an update changed something?

My router is running an avahi daemon with enabled reflector for mDNS.
I also allow in the firewall UDP Port 5353 for mDNS and TCP port 51827 for HomeKit. The network switches are not doing any IGMP snooping etc., Wireless Multicast Forwarding was disabled on the wireless access points and is now enabled - that makes NO difference with regard to the symptoms.
There is no Apple bridge like ATV or iPad, and none was needed so far.

My assessment is as follows: This is not a problem with the reachability of the IoT devices because:

  • the IoT devices are found and working with HA, even while HomeKit shows “No Response”
  • the elements that I expose to HomeKit are only “proxy” elements, i.e. input_booleans and lights that model something else on the HA side. These elements are always reachable because they only exist in HA.

So somehow this must be a problem between HA and the Apple HomeKit clients (iOS, macOS).

It would be great if also others could post their solutions.

Thank you, turning off “Enable multicast enhancement (IGMPv3)” fixed the problem for me!

Wish I found this post earlier! I also have a DrayTek router and have now disabled the same setting as you and I looks to have solved the issue I was having. Thank you!

I have the same issue. And the flag on my uniform controller was already disabled. Any other hint?

Never got this working properly. I then moved to node-red homebridge for some things and homebridge in a docker container for all the lights, Switches and thermostats

Same here and keeps on and off

Genius!!! thank you!

This issue has been going on with my setup for a while now and after changing the IGMPv3 setting on the UniFi controller HomeKit is more responsive than it has ever been! Thanks!

Want to double confirm that, after a LOT of head-scratching, that a restart of my router did the trick. Initially, I was skeptical, but it completely resolved the issue.

1 Like

I’m having a strange trouble.
Sometimes without reason when connected remotetly via Apple TV, I click to turn on a light, and it it does not turn on and a exclamation mark appears.
But all the status are appear ok. The I go to homekit integration and a make a reload and it start working again…
Is this happening to someone?
Thanks

I had the same issue. For me was an Apple TV 3 I plugged in my network.
Turned it off and everything went back to normal.

When I turn off “igmt spooning” the Internet speed drops to 64kb.
It fixes the problem with HomeKit “no response” but the internet is down

Hi @JoaoM , I’m having the same issue! Have you found a solution on your end?