Homeseer WD200+ Zwave Plus Wall Dimmer

My guess is that it doesn’t have a great connection into the Z-Wave network. Make sure your receiver isn’t impeded by a nearby wireless router and is close enough to the switch or other nodes in the network. FYI Z-Wave will hop through up to the four closest nodes.

@avp387 i had that issue due to position of the z-wave dongle. I had the machine in a rack system, had to use a short USB cable and place the z-wave dongle outside the rack.

Okay, I’m brand new to z-wave and have putzed around a bit with hassio to control some lights and temp/humidity sensors. I recently moved, so restarted with a fresh hassio setup and an Aeotec 5. I installed my first Homeseer WD200+, and it shows up as a dimmer. I can turn it on/off or set dimming levels (although I don’t get UI status reflection of state afterward).

Anyway, so I tried downloading openzwave as per above, but I guess I’m doing something wrong. If I point my config_path to the openzwave config directory and reboot my hassio, my Aeotec configuration gets completely deleted with a “Driver for controller /dev/ttyACM0 removed” message in my logs…

Help? Thanks.

It looks like everything’s there, actually, without the downloaded openzwave, accessible by code. I guess I was just expecting to see widgets in the UI for everything.

openzwave can sometime add support, sometimes just names things correctly. open another thread with your configuration your having issues with and I’m sure someone will help out.

OK, for me adding the config_path option just confused my zwave config and it forgot about everything. Including the Aeon Gen5 USB stick. So that suggestion is missing a ton of details on moving and maintaining any existing configuration you already have.

After removing the the config_path and reverting all the changes I made trying to follow that thread of “advice” I started over.

For me, what did the trick was after adding the WD200+ dimmer (using “ADD SECURE NODE”) was to click on “HEAL NETWORK” (as suggested by then I clicked “SAVE CONFIG” (that wrote the WD200+ config details to my xwcfg_HEXID.xml file). After that all the WD200+ options showed up in the Node Config Options for that device.

This is on HA 0.91.3

Good luck!

How are you guys handling status mode with these?

If I set one or two led lights to on, the switch must be set into status mode to see the leds, but turning the leds off does not set the switch back to normal mode automatically, like it does on a homeseer system. There also doesn’t appear to be any way in HA to read a config parameters for me to verify both leds are turned off before setting it into normal mode.

How can I coordinate the mode with active notification LEDs? (normal mode when all leds are off, status mode when any led is on)


I’m trying to set up the multi-tap triggers on a HomeSeer FC-200+ fan controller. I’d like to automatically set the fan to high on double tap up.

I can see that the scene is activated in the ZWave logs, but it’s not triggering. Any ideas?

Here’s my automation:

- id: 'turn_on_master_bedroom_fan_double_tap_up'
  alias: Turn on master bedroom fan to high with double tap up
  initial_state: 'true'
  - platform: event
    event_type: zwave.scene_activated
      entity_id: fan.master_bedroom
      scene_id: 1
      scene_data: 7860
    - service: fan.turn_on
        entity_id: fan.master_bedroom
    - service: fan.set_speed
        entity_id: fan.master_bedroom
        speed: high

Wrong entity id for the trigger. It should be a zwave entity.

That was it. Thank you!

I wanted to share what I did for my Homeseer WD200+ to more easily manage and control it

First I set up a bunch of input selects:

Then I set up a bunch of automations to watch all of those input selects and convert them to ZWave config calls to actually update the switch.:

Then any of my automatons just controls the input_selects and it makes it way easier to manage.

Another way is to feed the events into NodeRed if you use that, which can then make the calls. this is how I do it… whatever your more comfortable with.

I’d like to know this as well. I can change when the dimmer is on, but I can’t seem to go into status mode automatically.

Do you have an example of this? I’m terrible with NodeRed but am wanting to learn it more, and would like to automate the LED’s on my switch.

Help! I’m so confused by this thread. Been slowly transitioning from Hubitat over to HA on Hassio…I have three Homeseer WD200+ dimmers in my kitchen that I used to give status light updates for my home. I can update the status lights manually in the HA Z-Wave Network Management menu by adjusting the node config options, when I do this each node updates and displays correctly…When I try and do it through an automation using zwave.set_config_parameter, it does nothing and the log displays:

2020-02-17 15:28:54.798 Detail, Node005, Polling: COMMAND_CLASS_SWITCH_MULTILEVEL index = 0 instance = 1 (poll queue has 0 messages)
2020-02-17 15:28:54.798 Detail, Node005, Queuing (Poll) SwitchMultilevelCmd_Get (Node=5): 0x01, 0x09, 0x00, 0x13, 0x05, 0x02, 0x26, 0x02, 0x25, 0xcc, 0x2f
2020-02-17 15:28:54.798 Detail,
2020-02-17 15:28:54.798 Info, Node005, Sending (Poll) message (Callback ID=0xcc, Expected Reply=0x04) - SwitchMultilevelCmd_Get (Node=5): 0x01, 0x09, 0x00, 0x13, 0x05, 0x02, 0x26, 0x02, 0x25, 0xcc, 0x2f
2020-02-17 15:28:54.804 Detail, Node005,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-02-17 15:28:54.804 Detail, Node005,   ZW_SEND_DATA delivered to Z-Wave stack
2020-02-17 15:28:54.857 Detail, Node005,   Received: 0x01, 0x05, 0x00, 0x13, 0xcc, 0x00, 0x25
2020-02-17 15:28:54.857 Detail, Node005,   ZW_SEND_DATA Request with callback ID 0xcc received (expected 0xcc)
2020-02-17 15:28:54.857 Info, Node005, Request RTT 58 Average Request RTT 58
2020-02-17 15:28:54.857 Detail,   Expected callbackId was received
2020-02-17 15:28:54.933 Detail, Node005,   Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x05, 0x05, 0x26, 0x03, 0x63, 0x63, 0x00, 0xd5
2020-02-17 15:28:54.934 Detail,
2020-02-17 15:28:54.934 Info, Node005, Response RTT 135 Average Response RTT 134
2020-02-17 15:28:54.934 Info, Node005, Received SwitchMultiLevel report: level=99
2020-02-17 15:28:54.934 Detail, Node005, Refreshed Value: old value=99, new value=99, type=byte
2020-02-17 15:28:54.934 Detail, Node005, Changes to this value are not verified
2020-02-17 15:28:54.934 Detail, Node005,   Expected reply and command class was received
2020-02-17 15:28:54.934 Detail, Node005,   Message transaction complete

Do I need to update something in the Zwave config before automations work? Doesn’t make sense that the devices responds in the Zwave config menu but not the automation. Any thoughts?

Those logs have nothing to do with the configuration parameter. They are showing that you have configured polling and the polling is getting the status of the light. There should be no need to poll these switches, I’d turn that off.

You’ll have to check the log again for the config parameter it should be pretty obvious when setting it. You might also want to post the service data you’re using in the automation, likely there is an issue uthere. The values should be the same as the control panel values.

Thanks for the quick reply…I just created a quick test switch to ‘test’ it out. Seems pretty straightforward, but perhaps I missed something?

- id: '1581971564028'
  alias: test
  description: ''
  - entity_id: input_boolean.test_switch
    platform: state
    to: 'on'
  condition: []
  - data:
      node_id: 5
      parameter: 22
      value: 1
    service: zwave.set_config_parameter

…and yes I have confirmed the dimmer is node 5

I was serious when I said the values need to be the same as in the control panel. :wink:

  - data:
      node_id: 5
      parameter: 22
      value: "Red"
    service: zwave.set_config_parameter

Parameter 22 is defined as a list. You must specify the list value, which is “Red” and it will be converted to 1 for you.

1 Like

@freshcoast You’re a genius! lol…seriously thanks. I can’t believe it was that easy. So…on another note. I took your same logic and applied it to parameter 13 (normal/status mode). I’ve tried using the values: 1 or 0, that didn’t work. I tried “Normal” and “Status” and that didn’t work. Any ideas on how I can trigger this parameter?

Thanks again! I’m learning a lot!

“Normal mode” and “Status mode”.

All the ones that are type Item, use the string label.

1 Like