Honeywell T6 Z-Wave thermostat

Hello thank you for the prompt reply.
Yes I am using the old c-wave integration Z-Wave beta.

I just finished setting it all up and having it running. I was looking at the conversion from Z-Wave beta to Z-Wave js… I just don’t have the amount of time it takes to convert all that over at the moment.

Sorry, but I don’t have experience with the Zwave beta (which should be OpenZWave 1.6 if I’m not mistaken). I had issues with the now deprecated version of OpenZwave 1.4, to which I needed to add certain lines to make it work.

I don’t know about 1.6 but 1.4 creates a xml file in the root directory of the Home Assistant config folder. If you could post the device xml file, that might help in diagnosing. Just post the section for the thermostat, that all we would need for now.

thanks again for your assistance.

in /config directory the only zwave config xml file present has the information as follows:
no mention of the thermostat.

<?xml version="1.0" encoding="utf-8" ?>
<Driver xmlns="" version="3" home_id=********** node_id="1" api_capabilities="0" controller_capabilities="40" poll_interval="60000" poll_interval_between="true">
	<Node id="1" name="" location="" basic="2" generic="2" specific="1" type="Static PC Controller" listening="true" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">
		<Manufacturer id="0" name="Z-Wave (Sigma Designs)">
			<Product type="1" id="1" name="UZB Z-Wave USB Adapter" />
			<CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" after_mark="true">
				<Instance index="1" />
				<Value type="byte" genre="basic" instance="1" index="0" label="Basic" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />

I second this. This thermostat works flawlessly with zwavejs2mqtt. My whole zwave network is much more responsive than with either of the older integrations.


So coming in from samsung ST to HA all my Z-Wave devices ran very responsive some even less than a second.
And you are saying that Z-Wave Js is even snapper…Now your just bragging…and it’s causing me to want to jump ship to Z-Wave Js.:grin:

Your card has the option to enable auto mode! I can’t get that to show up for the life of me, despite enabling auto change over mode via Z-Wave configuration. Any idea how you got that option to be available?

OZW1.4 generated two xml files, and the one you posted is not the one I was looking for. The other file had all of discovered devices with all of the available configurable options. If that’s the only xml file present, then I’m not sure how else I could help.

It’s your installation, but there are a lot of people using ZwaveJS now. When you have a day or two, I would suggest making the move.

@petro has made a great resource for switching over from the OZW beta to JS.

Sorry I do not know how or what caused it to show up.
During Inclusion i did have it In Auto Change over that might be it…But im a noob with HA.

Thanks for your continued support.

Took two nights after work to get it switched over…same Outcome.

I had a little too much to drink on third night and decided SCREW it! …so i blew it ALL away including HAS and started from Scratch and only with Zwave JS… sad to say No luck.

where is the Zwave JS config XML file located?

I’ve had that issue before, normally after starting up either ZwaveJS or Home Assistant. Setpoints appear correctly in Fahrenheit, but temperature is incorrect in Celsius. Seemed to sort itself out after a while and I haven’t seen that issue in a while.

I am not using the official ZwaveJS addon, so I’m not fully versed in it. Everything should to be taken care of in the Integration UI, no config files are generated. I assume are running HA 2021.4.6?

Thank you,

Yes running the latest.
I Will just ignore it for a while see how it goes.

Sarbon 15
found this setting under the configuration Page Of the thermostat.
could be what you’re looking for

Hello @walrus_parka
finaly got it working better stated it started working.
It dawned on my that the Temp showed properly on the Cool side but not the Heat side .
ends up that it fixed it self when i set a heat temp.
Much thanks again

1 Like

I know this is an old thread, but I just integrated a Z-Wave Honeywell T6 and wanted to report on it. I’m using the HA OpenZWave (beta) still – the one using MQTT that everyone has been hating on :slight_smile:. Everything worked well generally.

When you first associate the T6 it is not set to use Auto mode, but just Heat/Cool/Off. The first thing I did was enable Auto via a config change. That’s when I also saw the incorrect number ranges for heat/cool endpoints. To fix that, I just did a re-init of the ZWave settings for the T6 node (it just takes a couple seconds). It seems then HA gets the right config and the numbers then looked normal.

It has been working flawlessly for a few days now.

1 Like

Thank you! I just ordered one and so will be playing around with it next week. I am using the standard Z-wave JS add-on and so am looking forward to exploring the integration. (I will run it without connecting it to my HVAC system initially to get familiar with it.)

Sorry to bump the thread. I just moved into a new construction with this device, but seeing some weirdness with it when connecting it to ZWave2MQT.

It joins the network just fine, but gives me a target temperature of some ridiculous number, and won’t let change it. I also can’t change the mode function.


I’ve looked through the settings available in the ZWave config, but see nothing that might help. Is it just a bad unit?

I haven’t seen this problem since I switched from the old OpenZWave based integration to the new excellent zwavejs2mqtt integration.

I assume you are using this GitHub - OpenZWave/Zwave2Mqtt: Fully configurable Zwave to MQTT gateway and Control Panel using NodeJS and Vue which is based on OpenZWave.

I meant ZwaveJS2MQTT, sorry.

What did you mean by “the first thing I did was enable Auto via a config change”?

My T6 Pro thermostat has Auto (or Heat/Cool) mode, but when I select Heat/Cool in HA it does nothing on the thermostat. However, if I change to Auto mode manually on the thermostat, HA will update to show Heat/Cool.

It’s been a couple years, so I don’t remember details, and I now use ZWave JS, not OpenZWave.

Looking at the configuration in ZWave JS UI, I changed [53-112-0-12] Auto Changeover to 1 [Enable].

The T6 still works flawlessly.