How can I remove unknown nodes on my ZWave controller

Tags: #<Tag:0x00007f739a616f10> #<Tag:0x00007f739a616df8>

I have several dead or unknown nodes on my zWave controller. A lot of them are from the same august lock I tried several times to connect with and never could until I finally was able to connect to it. So now I have about 5 unknown nodes and then a 6th node with the august lock.

I’m using the beta OpenZWave Daemon but it doesn’t let you delete a node or dead node so wondering how I can force delete a node I know I don’t have.

Check this post:

Ok I’ll try it!! Thank you!

In the same shoes… I have ~10 of phantom nodes kept on stick, that gets recreated into zwcfg_xxxx.xml file after each system reboot. Similarly to @HA_fanatic these are remnants of unseccusful integrations of Fibaro Smart implant or CoolCam door sensors.
I tried to use OZWCP (I’m using old integration) but with no success. I even tried to use AeoLabs own Zensys Tools to remove these, but no success. Currently I’m at the point of waiting for final version of new integration and rebuilding the whole network from scratch, starting with hard reset of zstick (avoiding this for now, since access to some of devices is very limited, so this would be probably whole day work for me).

One more though (perhaps something stupid, I do not know enough about how zwave works); since these phantom entities are created based on devices that were later successfully integrated into HA (so exist in network); is it possible that zstick tries to communicate with these phantoms and succeeds (perhaps using some device unique ID) and therefore it thinks that node is not dead, but just not fully configured. That’s why removal of device fails as it is possible only for failed/dead node. I’ll try to move away from my network with zstick fa enough, so it can’t connect to any node and try to repeat operation…

You can/have to mark devices as failed manually before removing them. If you for example add a device, reset the device and add it again it can cause weird issues as indeed, there is some form of communication possible. That’s why it’s best to mark the node as failed and remove it. You have to do that exact same thing in the Zensys tool. Instructions for using the Zensys tool (don’t mind the OpenHAB website :slight_smile: )

Do make sure you understand that the Smart Implant creates multiple devices in HA, as discussed in the following thread:

https://community.home-assistant.io/t/z-wave-device-split-into-multiple-devices/

@RickKramer In my case smart implant issue was not that several devices were created, but that node created did not contained all required entities - only subset, so was unusable. So it required several retries before it was properly visible with all necessary to function entities. Each iteration such node was removed and readded until successful some phantom nodes were created that survived node removal process. Now are still visible; not in Developer Tools -> States, but in zwcfg_xxxx.xml. If removed manually (after stopping zwave network and home assistant), get recreated once system starts again. These nodes are also visible on stick when using Zensys Tools.
I followed already exactly the same tutorial you refer to, but the problem is that in very first step NOP command does not fail! So as result node status does not change to failed and it cannot be removed. That’s why I suspect that finally properly added devices responds to commands send to failed nodes (same physical device, but different node number). These phantom nodes are also visible in home-assistant.log as failing to initiate:

2020-09-16 11:47:59 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave node 3 not ready after 30 seconds, continuing anyway

Maybe you are facing the issue described in:

According to that you may want to perform the operations with some of the devices in range.

Damn that did!!! Thank you!!!