How do I switch to Zwave JS?

I’m waiting for the migration wizard. I’m also on the cooked in version and it’s fine for now.

1 Like

Agree, CO_4x4, I have to say that it feels extremely premature to be deprecating the only stable, completely operational version of zwave (1.4) before a fully operational replacement is in place. Looking at the zwave-js page there are quite a few pretty critical components still missing, such as polling and setting parameters via services (the latter which I currently use), that currently don’t work. Perhaps most people have already migrated to one of the other zwave forks. Every one of my devices is zwave, so this component is pretty critical for me. Very frustrating.


Hi all, I’m sure this is a stupid question, but I’ve researched and can’t find the answer…

I’ve installed Deconz on a separate Pi that runs in the middle of my house, means if I restart HA no issue with reconnecting, it’s so much better.

At the moment my Zwave controller is in my HASSIO pi, but it would be so much better with the new ZWAVEJS to move this across to my separate pi running deconz. It looks like this is possible, but I’ve tried to install (installed npm and then server etc) but everytime I run ts-node src/bin/server.ts /dev/tty0 it gives me an error, first it was typescript missing, but now it’s just saying the server.ts script isn’t installed.

Is there an idiots guide of how to install this on a separate pi as I just can’t get this working.

I’m getting a ‘failed to connect’ when attempting to install the zwavejs integration. What am I missing?

Gave the new Z-Wave JS Integration a spin around the block. Came from OZW and this new integration is extremely responsive and fast! Easily half the response time of OZW, and that one wasn’t slow either.

I am trying to figure out if there’s an event that I can build an automation around to trigger the start of homekit when the zwave network is ready. For OZW I used an mqtt event, but not sure how to do this with Z-Wave JS. Any guidance?

Again, great work on the Z-Wave JS integration!

Since quite a few releases (6 months or more) that isn’t needed anymore. Previously one needed that to prevent HomeKit from starting before all entities loaded. Nowadays, Home Assistant restores all entities on start instantly. Hence, that problem is non-existing.


This is great! I had no idea!

Awesome work! Very excited for the new ZWave JS integration. I’m a little confused how to get the Zwave JS server up and running though. I’m running HA in a Docker container so I’m going the container route. In the documentation ( Z-Wave JS - Home Assistant ( it says the if i’m not going the add-on route, I can install the Z-Wave JS 2 MQTT project as a Docker image which contains the Zwave JS server. So am I understanding it right I need to install that whole project just for the server part? I don’t have use for the rest I guess so I’m a little confused.

Anyone else having problem with zwave js where door sensors aren’t reporting? I’ve checked and they’re all just listed as “Node ##” and asleep. So the entities don’t generate.

Is there any best practises for migrate old zwave to the new zwave js without reconfiguring everything?

I would love to know as well, the zwave changes surprised me today… and it seems none of my zwave devices are working. Even if I make the switch to zwave js, it doesn’t look like my garage door sensor would work.

Its quite simple!
Just stop the old zwave, dont delete anything just yet. install the zwave js addon, after you will be prompted to go into configuration and then integrations, and install the z-wave JS ( for me it was automatic, just need to activate). and then, go fro a coup of coofee or beer, and wait for like 5 minutes and voila!

i actualy then installed the community one because it give alot more fuctions and deleted the official one :slight_smile: i love the graph there! ( on addon ons)

Wish there was a migration for the device/entity names. Going to take some time to identity and name my 83 devices. Still better than repairing them all :smiley:

Have a look at this post in the migration thread.


Did anyone get a remote with buttons working? In the add-on log I see:
23:46:23.689 CNTRLR « [Node 005] received CentralScene notification { "nodeId": 5, "ccId": "Central Scene", "ccCommand": "0x03", "payload": "0xa20001" }

From: I gather that I should receive a value notification. However when listening for zwave_js_event I do not receive anything on a buttonpress.

Anyone a clue?

You will need to reconfigure anything and wait for the devices to send their discovery information to the zwave server again. Also the ‘profiles’ are different. In my case for a smoke detector it went from one sensor with different values that represented different states, to multiple binary sensors. So it is quite a bit of fiddling, however I do like the profile in zwavejs better, as it is much clearer (to me).

1 Like

Hi all,

I’ve a problem when i look up my network it is ‘null’. How can i fix this.

"network_key": null,
"usb_path": "/dev/ttyACM0"

and how are we supposed to do that without any ui to these devices:

fwiw, these are all Sensitive doorstrips, and opening/closing the door wont help…

1 Like

I am also a little bit confused…

My HA runs in Docker (Synology NAS) so I decided to download the zwavejs2mqtt container from here.
Then I connect to my Diskstation (NAS) via SSH an ‘fire’ this command:

sudo docker run -p XXXX:8091 -p YYYY:3000 --name zwavejs-zwavejs2mqtt --restart always --device=/dev/ttyACM0 -v /volume3/docker/zwavejs2mqtt:/usr/src/app/store zwavejs/zwavejs2mqtt:latest

XXXX and YYYY were adjusted to free ports.

Now I was able to connect to the zwavejs2mqtt UI via the IP of my diskstation and port XXXX.
There were lots of errors in the log about being not able to connect to MQTT. So I reactivated my Mosquitto container and entered the correct IP in the zwavejs2mqtt UI (Settings->Mqtt->Host url).

My devices which I had configured via the old integration were incomplete, so I decided to remove them all (because I have only 3 zwave devices and I was not patient enough to wait for a refresh after waking them up). Then I readded them.

Next step was adding the new integration to HA which took about 15 seconds :slight_smile:

All devices were found and everything good so far (I am happy about the switch to Zwave JS).

What I don’t understand:
Do I really need MQTT or should I disable this setting in the zwavejs2mqtt UI?

1 Like