How to add an Insteon device?

My hub stopped working (perhaps because Insteon went belly up?). I installed the Home Assistant on Hyper-V on Windows 11. And used the Insteon Integration from the web interface to the service. It pulled a bunch of my devices in automatically. But it missed a few. I’m assuming I never actually added it to the Insteon hub using the Insteon app. For instance, I have 2 2247D switches in controller-receiver for a switch at the bottom of stairs and the top of stairs. But neither show up in Home Assistant.

I tried to “configure” each of them, but neither device in Home Assistant lights the light. Is Home Assistant just telling the hub what to do and it is limited to the devices that are in the hub? I can’t add these devices to the hub now because the Insteon app won’t work and the light on the hub (type 2) is red.

Can I get Home Assistant to add it to the hub by pressing the buttons on the switch that would be used to register it to the hub?

I just started looking into this today, so I’m very much a newbie with Home Assistant.

Also, I tried to connect the Android Home Assistant app to the service, but it doesn’t connect. I tried to specify the 172.x.x.x address just like I connected using the browser. homeassistant.local:8123 didn’t work either.

I don’t know much about Insteon but if you were able to install the integration successfully and control your existing devices that were already linked to the hub that is a great start.

According to the documentation on the Insteion integration (below) you should be able to link new devices by calling the service insteon.add_all_link

You would call the service by going to developer tools, then clicking “services”

Thanks. I was just about to go look for Insteon/Home Assistant integration documentation.

Now I need to know what exactly is it doing? Is the Home Assistant actually controlling the devices directly, or does it DEPEND on the hub still being there and working.

I also need to know if HA can REMOVE schedules in the hub already. It looks like it is still running in the hub, but I didn’t see yet that HA might have imported those schedules. I’m afraid if I make some new schedule, it will be running in parallel to what the hub is doing. Or is it making a schedule in the hub.

Off to try to read more…

The integration uses “local push” to communicate on your local area network to the insteon device. According to documentation it works the 2413U USB and 2412S RS242 flavors of PLM and the 2448A7 USB stick. It has also been tested to work with the 2242 and 2245 Hubs

That means the integration relies on having a supported insteon hub or USB stick kept on and connected to your network. The insteon stick/hub is still required and controls the insteon device, but your Home Assistant instance is able to communicate with the insteon hub locally, even with no Insteon cloud connection (as the cloud connection no longer exists).

What I can’t answer are schedules and other “higher functions” that the insteon app did. The Home Assistant insteon integration can only do what the documentation says it is capable of, and I don’t see anything about changing the schedules. It does mention editing scenes though so I’m not sure if they are related. Hopefully someone using the integration can chime in.

What I would recomend is abandoning any insteon schedules and using the automations within Home Assistant itself to control all devices. Ideally, remove all insteon schedules and replace them with Home Assistant automations instead. Home Assistant would then control all devices using the insteon hub just to send the on/off commands.

Oh boy, I get to start over. I just tried reloading the virtual machine that I set up yesterday in Hyper-V and something about disks corrupted in the chain.

So I will get to see if I can remake it twice in a row AND re-establish which devices are which. And recreating all the rooms, etc.

So far I see that HA can turn lights on and off, but what about turning a dimmer light on to a particular dim amount? Like 50%? Is that possible? I hope so.

Yes, it is definitely possible. In the light.turn_on service, you can also specify a variable for brightness_pct to control a dimmer’s brightness.

When you build the automation in the UI, you should also be able to specify brightness. This is dependent on the light/switch comming in as a dimmer though through the Insteon integration.

Great, thanks. Still working on trying to remember how I got the Hyper-V setup. I guess if I do it enough, I’ll become an expert. I haven’t done a virtual machine for a LONG time. Probably 10 years or so. I used to be a programmer. First program written in 1966. Had about 43 years as a professional programmer. But I did the software and didn’t like having to figure out hardware. Now I get to do that again…

When my virtual machine starts, I see a flash of a big red banner and I think there is a lock on it. Is that normal? What is it trying to indicate? And how can one stop the starting or record it so that I could see exactly what it was showing? (these are probably Hyper-V questions)

I don’t use a VM myself, and run homeassistant container in docker.

I would start a new thread for the VM issue as you would likely get better help from someone more familiar with it.

I got it all set up again and it is working. I just deleted the whole VM and started again. I read that HA could run on a synology box so I will try that. I have a notion it will work even better there.

I thought the red flash at the beginning was probably an HA/linux thing so you might know. What OS/hardware are you running docker on?

Glad you got it working.

If you plan on adding zigbee and/or zwave usb sticks, I would avoid synology. Many have reported problems- The issue being the synology os is somewhat locked down and doesn’t pass the usb sticks through to Home Assistant well. See this thread for potential complications.

I’m running Ubuntu on a used Dell Optiplex. Plenty of memory/speed, and system was cheap.

Not planning on getting anything new (except maybe a couple more Insteon devices if I can still buy them). I’ve got 36 Insteon devices so I won’t be switching. But good to know about the USB problem. Hopefully Synology can resolve that eventually.

I installed the HA package on the Synology. Directions were a little confusing. I’m guessing those directions were from before the DSM 7.x update. I saw in a log that it apparently didn’t find the config. It LOOKS like the settings are proper for a shared folder “/docker” and then a couple of subfolders and that was all showing in the settings. Don’t know if it is a permissions issue. Will have to look into that more unless you have any clues (though you don’t have it running on a Synology).

I found in the log: “Unable to find configuration. Creating default one in /config”. Since the config folder was mounted in /config, I assume it then found the one I specified? Or maybe it made one there anyway? I do see a bunch of files there, so maybe that is all normal behavior.

And the last thing that was confusing was the instructions for the TimeZone. The instructions say this:
variable = TZ & value = Europe/London
but the Synology UI just has a field for “variable” and a field for “value”. What do you think?
variable column should have “TZ & value” and value is “Europe/London”? Or do you think variable is just “TZ” and value is “Europe/London”. I think I did it wrong initially and think the latter is the way to go. I’m going to try that, but let me know if you can tell from your Ubuntu work. Thanks.

I got HA integration installed on the Synology box. So far, it only found 11 of 36 devices on the hub. I don’t know if it is because the Hyper-V HA already got the 36 and I edited all but one of the switches to have good names and Area specification. I’ve let the Synology HA run for a while and doesn’t seem to be picking up any more. Do you think I should just start adding them in manually? Or give it an hour or more to maybe find more?

I tried removing the Insteon integration and restarting the docker container and reintegrating, but didn’t help also tried remove integration and restarting the synology box. No difference.

Any ideas?

Is there a way to tell the integration to go to the hub again and look for devices?

… time passes …

I WAS able to just add one of the missing devices manually so now I have 12 devices. Odd that it didn’t pick them all up. However, I might have confused it by running the Hyper-V HA and the same time I was running the Synology HA. FWIW, I like the Synology one better already. It discovered more more integrations than the Hyper-V version did (a couple of printers and a couple of Roku’s).

I guess I will go ahead and add the rest of the missing devices manually . Bummer.

If it is new install there is no config and it creates one at initial startup. This is normal behavior, unless you are trying to map to an old install, in which case there is a problem with the data or the path wasn’t specified properly;

Yes that should be the correct way to do it

Network discovery relies on SSDP (a part of UPNP) to work Simple Service Discovery Protocol (SSDP) - Home Assistant

In addition to the USB pass through problems I mentioned above, VM’s often don’t pass through all network connections, have a firewall of some sort that blocks UPNP connections, or requires “extra” network configuration to open these connections from host to VM (depending on the VM used). For discovery to work, ALL network connections must be open from the Home Assistant instance in the VM to the network the host machine is running on, including UPNP connections. If there is a block anywhere on the path it will not discover the integration. For Hyper-V, there could be a setting somewhere to enable these connections, but I’m not familiar with it.

The Home Assistant Container install eliminates this block because Docker can use “host networking” mode (at least on a Linux OS install) which removes any isolation between the Home Assistant container and host machine. However, Home Assistant Container does not include the Home Assistant “addons”, and is a bit more advanced.

For anyone starting out, I recommend these Everything Smarthome Videos, specifically on “install type” and hardware recommendations:

I’ve been successfully adding my SwitchLinc devices through configuration. But I have an “On/Off Module” that is a category 0x02 and subcategory 0x37. I add it, but it doesn’t show up in the list of devices on the Synology HA. Do you know if there is a reason for that?

Thanks for the links. I think I already watched both of those, but I’ll double check.

… time passes …

I continued to add stuff manually and most of it was going ok. Just 2 on/off type switches didn’t show up. So I finally restarted the docker task and reconnected to HA and NOW those 2 show up. Odd. But good :slight_smile:

I had to add an on/off switch with the same cat and subcat using default override. It then didn’t appear in the device list, but after restarting HA it showed up.

Thanks, I figured that out at the end of my last post.

Everything was working great and then we were watching YouTube TV on the Xbox and it stopped working. It took a while of rebooting router, etc. until that all came back. HOWEVER, 2 things were still screwed up.

  1. A camera that was working with ICSEE on the phone and CMS on the PC stopped working and no longer is known to the router. (maybe the antenna blew off in a storm yesterday and I’ll check that in the morning).

  2. The Insteon IP address was changed in the router. It used to be like and now it is on

How do I change the HA in Synology to use the new IP or change something else so that it is back to 53?

Nothing is ever easy… I just finished manually putting all the 36 devices manually and everything was working. But since the crash, not so much.

… time passes …

I sure hope I don’t have to remove the integration for insteon and add it all again… :frowning:

… time passes …

I woke up from sleep remembering that the Configure had something about changing the hub. I selected that and was able to change the IP for the Insteon Hub. My HA is working again.

Now I have to find out if the router is allowing static addresses so that it doesn’t get changed again.

You will need to reserve an IP address for your Insteon hub, since as you found, the integration will stop working if it changes.

Instructions on how you reserve an IP is specific to your router, but will be done through the router’s configuration page or mobile app. I’ve never owned a router that did not allow you to reserve an IP, it’s just different for each of them.

Yes, I’ve set up static addresses before, though it was long ago enough I don’t remember how, but I can figure that out. I’m a bit worried that the modem/router seemed to have reset itself when I unplugged the power and plugged it back in. I’ve been having a lot of trouble with wifi occasionally dropping connections and so I just power off and on and then it is okay.

But this time, it prompted for changing the password. Hopefully some bad actors haven’t gotten into it.

Getting back to HA… I just manually configured another switchlinc, but it didn’t manage to add it to the insteon. It doesn’t respond to on/off in HA. And when I look at its details, it says Firmware: 00 and engine version: unknown.

Maybe I’ll try restarting HA. If you have any other ideas on this one, let me know.

Another switch in that same switch box has the exact same model switch with the same rev. no. And that one works fine.

… time passes …

No, restarting doesn’t help. When I try to switch it on in HA, the switch position just goes back to off after about 5 seconds. I presume it isn’t able to talk to the switch.

… time passes …

Not sure what changed, but all of the switchlinc and outletlinc devices appear to be registered and working now. I just have to play with the garage door opener that I made and see if that works.

I have an I/O Linc that I set up to do 2 things. Operate the remote of the opener when the “switch” is turned off. And using the sensor to know when it is fully open. (I hooked up a magnetic alarm switch to the top of the door and wired it to the I/O Linc. It worked with Insteon app.

So the “switch” opens and closes the garage door just fine. But the sensor doesn’t seem to be getting triggered back to HA. Any ideas what to do?