How to: Aeotec DSB45 Water Sensor

I have been helping a friend setup HA, I wrote up these instructions, I hope it helps others. I have included the email routines I use as well. Here is the result:

image

Aeotec DSB45 Water Sensor
-------------------------

Join the node to zwave network
Rename the zwave device to: basement sump pump sensor
Restart HA

Zwave > node config options > 121: Report Type to Send  change to 4113

Press the zwave button on the sensor, and click "set config parameter". Might take a few tries for it to stick, if you see the value change to anything other than 4113 it did not stick. 

######## FILE: entity_registry.yaml
#I renamed my entity, you dont have to, but its in the rest of my config:

binary_sensor.basement_water_sensor:
  name: Basement Water Sensor Alarm
  platform: zwave


######## FILE: customize.yaml
  
binary_sensor.basement_water_sensor:
  device_class: moisture


######## FILE:  configuration.yaml		
notify:
  - name: scott_sms
    platform: smtp
    server: smtp.gmail.com
    port: 587
    timeout: 15
    sender: [email protected]
    encryption: starttls
    username: [email protected]
    password: PASSWORD
    recipient:
      - [email protected]
    sender_name: Home Assistant

  - name: scott_email
    platform: smtp
    server: smtp.gmail.com
    port: 587
    timeout: 15
    sender: [email protected]
    encryption: starttls
    username: [email protected]
    password: PASSWORD
    recipient:
      - [email protected]
    sender_name: Home Assistant

	
sensor:
  - platform: template
    sensors:
      basement_water_sensor_battery:
        friendly_name: 'Basement Water Sensor Battery'
        value_template: '{{ states.zwave.basement_sump_pump_sensor.attributes.battery_level }}'
        unit_of_measurement: '%'
        entity_id: zwave.basement_sump_pump_sensor


######## FILE: automations.yaml

- id: water_alarm_triggered
  alias: 'Water Alarm - Triggered'
  trigger:
  - platform: state
    entity_id: binary_sensor.basement_water_sensor
    to: 'on'
  action:
  - service: notify.scott_email
    data:
        title: "Water Alarm Triggered"
        message: "Check the sump pump in the basement"
  - service: notify.scott_sms
    data:
        title: "Water Alarm Triggered"
        message: "Check the sump pump in the basement"
		
######## FILE: groups.yaml

default_view:
  entities:
    - group.basement_water_sensor_group	

basement_water_sensor_group:
  name: Water Sensor
  entities:
    - binary_sensor.basement_water_sensor
    - sensor.basement_water_sensor_battery
6 Likes

Man, thanks for the hint about using the zwave button to wake the thing up to make changes to the node configuration instead of the “wake up” button. It’s been kicking my butt ever since I bought the stupid thing over a month ago.

Who would’ve thought that you couldn’t use the manufacturers own instructions to put the thing in programming mode.

Works like a charm now! :laughing:

No problem, stay dry out there!

Just got one of these today and this worked great and saved me a lot of time trying to troubleshoot why it wasn’t working. It works now, thanks!

What are those options 4113? I see 4 is sensor binary, 1 is battery, but what is 13? (If thats correct on how to read it)

Out of the box the values were 256 which I’m not sure what that is either (disabled since it wasn’t working?)

The options are in hex but you put in the code in decimal. 4113 = 1011 in hex.

I’m not at my setup right now so I’m doing this from memory but I’m pretty sure that’s correct.

Ah, makes sense. So 1011 is the recommended setting per the Node config options in Home Assistant

OZW Ideal Setting: 0x1011 (Battery, Sensor Binary Report, Alarm)

image

I love the high level of nerd-out here :smile:

Originally, this device worked fine within Smartthings, however,after excluding it from ST and including it to HA, I have never been able to get this thing working in HA… In the latter, the binary_sensor.aeotec_dsb45_water_sensor_sensor always showed as “On”. Took forever to get the 4113 config param for report 121 to stick but once it did the sensor showed “Off”. Didn’t matter if I submerged it in water or dried it off. Oddly, while trying every possible combination to get this device to respond to changes, it would switch from off to on (& vice versa) when I pressed the wakeup button followed by the z-wave button. .

This device is included in the Aeon z-wave USB stick which is a secondary hub/device to my Smartthings hub. As soon as I included this water sensor to the USB stick it showed up within ST but, like HA, did not respond to any changes. Several hours later it started to work perfectly within ST. Unfortunately, I can not get it to work in HA. :frowning:

Just like to say, THANKS!! This was a great help in setting up my Water sensor. As a noobie I was struggling until I found this!

Thank you so much - all up and running :sunny:

Despite this post I went ahead on my own with a similar device configured for SmartThings. I had better success however. Thought I’d share what I did:

  1. Put SmartThings into exclude mode.
  2. Press Z-wave button on device
  3. Select “Add Secure Device” in Home Assistant.
  4. Hit Z-wave button.
  5. After a minute or so when it was registered, hit Z-wave button again and then use the instructions above to push the 0x1101 config on 121.
  6. Device registered and working.

Hopefully you’ve got yours sorted though.