How to Bind?

How does binding work with ZHA?? I had a remote bound to a bulb last night, but now I can’t figure out how I got it to work! I’m not coming across any documentation on this process anywhere. Any help would be appreciated! Thank you!

I was also yet unable to use the binding, I have used automations for my bulbs and zha events from my remotes. I think this is not yet final to some reading, but not 100% sure.

I‘m also looking for zha config on another topic but unable to find, let me know if you find more information on the binding.

Currently doing the same. automations.yaml has become quite unwieldy!

I tried it just now, but I‘m not sure about what groups do and what to set for binding, after pressing bind nothing really changes.

I like zha, as it is native in HA, but the documentation is very spare, I would help with that but unsure where to find the relevant information on github. If anyone knows would welcome some guidance…

Good News, even if it looks like it is not bind, it works now. Got my wireless remote 5 button now bind to a color bulb and to a zha group, which I thought I deleted, Strange

Not sure where we should see the binding of remotes to devices and groups

Really? How did you do it? I’ve had no feedback from ZHA AND no results.

you go into the remote you want to bind and select the device and bind it. I have not understood how to bind a group yet. Also it seems unbinding I have not done right.

I had to remove the remote otherwise I cannot unbind. What is also bad with usage of binding, is that the status in HA is not reflected properly anymore. So will stick to automations for now.

Will play around and let you know, once I have more info.

Any luck yet, @ha_frw?

no real progress, using bind you do not see the update back in HA, so I went back to automation. Not happy with bindings as they work yet.

Another user has tried to explain the process here. I hope it helps your scenario (didn’t work for the remote I had). How to setup Lutron connected remote using ZHA?

Please post back your results.

Would be interested in seeing this work as well, automations are really clunky to set up, brightness up / down is not animated, some button presses are just skipped and I don’t really get how I can adjust color temperature (I guess I need to create scenes for that?).

I will try to create a group and bind to that as suggested here:

Edit: none of it worked, and now even my automations don’t work anymore. I’ll probably switch to Zigbee2MQTT to see if that works out better.

I am also trying to find out how this binding works…
I have two tradfri devices:

  • Tradfri ON/OFF Switch - Model E1743
  • Tradfri Control Outlet - Model E1603

When i go to the “on/of switch” device, manage clusters and then to the section Device Binding i am able to select the control outlet…
image
Press “Bind”, then nothing happens.
I know the “on/of switch” is a battery powered device, but what to do next? (i’ve pressed all the buttons several times (to wake it up so to speak), but still nothing.

I really would like to have this binding works, then the ‘connection’ between the switch and the outlet do not have to rely on HA.

Anyone knows?

1 Like

I was able to "bind’ them together via the “normal IKEA method” (pressing the small button at the inside for 10s near the outlet i want to bind to) … and that works.
But the device status of the outlet is not reflected back to HA.

With Zigbee2MQTT i didn’t have this problem. (Had other problems with stability, thats why i try this switch over to ZHA.

Anyone been able to figure this out yet? I have a Hue dimmer and some Hue lights, but indeed the Bind button doesn’t seem to do anything…

Greetings to all.
This is how I have achieved it:
The first step is to create a group and add the entity that we want to control:

https://imgshare.io/image/NefxK9
https://imgshare.io/image/NefmWF
https://imgshare.io/image/NefY2O

Then we will configure the switch that will control the device:

https://imgshare.io/image/NefjFY
https://imgshare.io/image/Nef9an
https://imgshare.io/image/NefhIQ

If it is a outlet unmark “LevelControl”. If it is a light mark all options.

Wait at least 1 min.

Test if it Works

If it Works congratulations!! But it not report state

Then:

https://imgshare.io/image/NefqHP

Now it reports state. And if Home Assistant downs, no matter, link continue working.

Sorry for my bad english.

I would have liked to include the images or links, but being a novice user, the system has not left me

I hope it worked for you.

2 Likes

Thanks for that explanation! The pictures helped a lot. Too bad this didn’t work for me. I tried with an ikea tradfri E27 bulb and the tradfri on/off switch. Created a group, tried to bind them all together but didn’t see any “confirmation” in the HA ui. Waited a few minutes and tried to use the. Button when HA was offline, but that didn’t work :frowning:

Any idea what I should to to fix this? Tnx!

Hey Guys

After countless tries and doing basically the same thing over and over again, all my light bulbs bind to a singe ike tradfri 5 button remote. Here is what I have and did:

Home Assistant Version: core-2021.1.5
The above version is the first version I got this to work. I basically tried the same thing a couple of times with older version but had no success.

The Remote:

{
  "node_descriptor": "NodeDescriptor(byte1=2, byte2=64, mac_capability_flags=128, manufacturer_code=4476, maximum_buffer_size=82, maximum_incoming_transfer_size=82, server_mask=11264, maximum_outgoing_transfer_size=82, descriptor_capability_field=0)",
  "endpoints": {
    "1": {
      "profile_id": 260,
      "device_type": "0x0820",
      "in_clusters": [
        "0x0000",
        "0x0001",
        "0x0003",
        "0x0020",
        "0x1000",
        "0xfc7c"
      ],
      "out_clusters": [
        "0x0003",
        "0x0004",
        "0x0005",
        "0x0006",
        "0x0008",
        "0x0019",
        "0x1000"
      ]
    }
  },
  "manufacturer": "IKEA of Sweden",
  "model": "TRADFRI remote control",
  "class": "zhaquirks.ikea.fivebtnremotezha.IkeaTradfriRemote"
}

I have 12 light of witch 4 are lightify smart+, 3 are legacy lightify and 4 are ikea tradfri bulbs. So I think this is largely light bulb agnostic. All 12 bulbs are within the same zha light group. Not a HA group, but a Zigbee device group.

I had to unpair and repair the tradfri remote. The bulbs were paired about 6 month ago and are used all the time. However untill the resent version the below never worked for me, but this time it did.

Click on Manage Cluster in the Device Info Panel

Select the group of the light you want to control. Called alle_lichter in my case, select the OnOFF cluster and click Bind Group

1 Like

FYI, I’ve submitted some info about Zigbee binding to the ZHA docs, please help update later if merged:

I’m in the same boat too. In my case it is an IKEA remote (E1524) 5 buttons tied to a single lamp (E27 Opal 980l IKEA). Conbee II + ZHA. Repeated the procedures mentioned in the thread countless times without any progress.

The UI for the remote binding don’t provide any feedback (only the groups part is reporting) but I set the debug in the zha components I can check that the bind commands of the group are sended followed by a “SUCESS”. But the lights never came on, I tried with diferents bulbs, diferent remote, repairing them, so far no luck.

Does any of you have success with a tradfri remote + bulb group binding?

Thanks for all the information/images mentioned in the thread!

Yes, I do. I have linked Trådfri remotes directly to Trådfri lights. They work even though HA and Conbee is turned off. I love this setup compared to Deconz, which was horribly unstable.
You need firstly to make a group of the light(s). You need to do this even though there is only one light you want to control.
Then you go into the remote settings for the remote you want to bind to the light.
Click “Manage Clusters” and go to the bottom section: “Group Binding”. Ignore what is above this section.
Select the previously created group in the drop-down, and select all checkboxes, and click “Bind Group”.
Lastly, go into the settings of the light(s), and click “Reconfigure device”. All done.

4 Likes