How to setup Lutron connected remote using ZHA?

Tags: #<Tag:0x00007f73ac3799a8>

I have 2 Lutron Connected remotes (not Pico) and both are paired to the same 3 light bulbs (was set up using Wink years ago). I have sold Wink, and the remotes still control the bulbs, as they are still paired together. I have seen that support for these remotes has been added to the ZHA component. Has anyone set these remotes up so that they are paired directly to bulbs and to home-assistant? Any help is appreciated especially if you have these working in home assistant. Thanks!

I don’t have the Connected remotes, but generally if you’d first want to pair the remote with HA, then use the direct binding options in HA to bind the remote to the bulb* as well.

*HA ZHA does not currently support native zigbee groups (at least in the zha configuration panel) so as of now you can not bind a remote to a group, and can only bind to a single bulb.

Thank you for the reply and the information.
It seems I should wait until groups are supported, since I am trying to connect 3 bulbs to 2 remotes.

Thanks for clarify this, so ZigBee groups is the feature required to bind multiple bulbs? Any idea if there is a place to track it’s development or should we just be reading release notes?

It actually may be possible now via the zha configuration panel or the services that let you set zha cluster attributes/call commands etc, but it is not documented and I’m not sure how you’d do it. The unsupported part is more of a front end for it I think.

For tracking progress I just look at the pull requests on github to see what’s being worked on. I know the zha devs are active and working on a lot of things so it should only get better.

1 Like

It’s been a few months and group support seems to have been added to zha.
Does anyone, ie @dmulcahey, know if it’s possible now to bind a lutron connected remote to a group of lights in home assistant using the zha component?
I have added three bulbs to home assistant, and one lutron connected bulb remote. I also created a zigbee group for the three light bulbs. However, the “Clusters”, “Device Binding” and sometimes present “Group Binding” features are not at all intuitive.

I was able to get my remote to Group Bind to my bulb group. I repeatedly pressed the top button on the remote as I repeatedly pressed the “Bind Group” button in home assistant zha integration panel.

I am trying to bind another LightLink based remote to a ZHA group using a similar approach, but had no luck at all. Could you please help understand where you found the Bind Group button in the ZHA panel?

@ajayjohn here is how I’ve been able to Bind several connected bulb remotes.

  • create the group in ZHA
  • add the lights to the group
  • turn off the lights in the group.
  • open the zha config/cluster page for the Lutron connected bulb pico
  • under Group Binding select the group you wish to bind the remote with
  • check all the clusters available
  • click BIND GROUP once
  • press the Light On button on the remote at 2-3 sec. intervals. After about 2 or 3 presses the lights should bind, and turn on.

If that doesn’t work, it may be worth removing the remote from zha, factory reset the remote and re-add the remote to zha.

2 Likes

Thank you for the detailed response!
Unfortunately, that did not work for the remote I have :frowning:
My remote seems to keep controlling a predefined group that automatically gets added when you pair the remote. Even worse, if I pair multiple remotes, they’ll all control the same group only!

I have asked this as a question here but never received any response https://github.com/dmulcahey/zha-device-handlers/issues/235#issuecomment-588613886

I never used the predefined group. I honestly didn’t know the remote was responsible for creating it.

It maybe worth removing the devices from all groups, remove the remotes from zha, resetting the remotes, and starting from scratch.

Reset the Remotes

  1. Hold the On and Off buttons simultaneously for about 12 seconds.
  2. After 12 seconds, the LED on the remote should turn on solid.
    KEEP HOLDING the buttons to continue.
  3. After 3 seconds, the LED will flash quickly. KEEP HOLDING the buttons until
    the LED stops flashing. Remote is now reset to its factory default

http://www.lutron.com/TechnicalDocumentLibrary/040421_Zigbee_Programming_Guide.pdf

Coming from Wink as well. Had a group of 4 zigbee lights in Living room and used Lutron CBR (not pico) to control one light of the group for individual control. Set up via touchlink - bulb is a GE. similar setup in family room but different CBR to control both GE lights. no issues and with touchlink if wink down could still control lights via CBR. Moved them to HA - setup same lights but now if I use touchlink both remotes control both sets of lights - even if I stop HA. the only way to get individual control is to factory reset the remotes and rediscover them without removing them from database. If you do that they don’t get recognized properly as a lutron CBR but are "“unk_manufacturer”, “unk_model” , “class”: “zigpy.device.Device” and the touchlink pairing works individually. Weird behaviour when there is a quirk for the Lutron (zhaquirks.lutron.lzl4bwhl01remote.LutronLZL4BWHL01Remote2)

I migrated from Wink about a month ago and had a bunch of Lutron remotes in Wink, some single bulb control, some group control, and some as shortcuts (controlling Zwave and Wink Relay lights through Wink). Wink paired them with the bulb and the Wink hub did not need to be active for it to work, no Touchlink needed.

It works the same after I migrated those to Home Assistant. Reset the remote (hold top and bottom button until the remote light blinks then goes on solid then off) and then add it to ZHA. Make sure it shows up as Lutron LZL4BWHL01 Remote, if it doesn’t, reset it and add again. Add your bulbs to ZHA. In ZHA create a group of the bulb or bulbs you want (don’t include the remote). Then in ZHA click on the remote, select the group you want to control in “Bindable Groups”, select all clusters (click check box next to ^Name), and bind group. The remote then controls the bulbs in the group independantly from HA/ZHA if HA is down or restarting, no Touchlink needed.

You can use an unbound remote buttons as triggers in automations instead, so you can have the remote operate two switch on/off actions, or four toggle actions, or really do any 4 independant actions (scripts, scenes, whatever) in HA with the buttons.

touchlink seems to set up groups when you use it - i get two groups automatically generated . one looks like this “No name group 0x0030” which has one of the lights as a member and my zwave stick as the other. the other light is not listed but I cant add it and the log says duplicate entity when i try so something is badly wrong with the group. will reset everything to factory for the 10+ time and try the binding route.
Did you have to click on the top button on remote when binding to wake up remote?

You don’t need touchlink at all and that might be the source of your problem. Binding the group to the remote from HA/ZHA binds them together directly while still having Home Assistant/ZHA as the primary controller for the devices. My guess is that using Touchlink to do this probably messes with the primary controller between them.

When binding my remotes (I have 10 remotes) I didn’t press the top button repeatedly when binding the group, but I bound the remote to the group shortly after pairing the remote, so it may likely have still been awake. That said, I did have to try the pairing a few times on a couple of them so it might not have been awake those times, so pressing the button “may” help but in my case I didn’t press the buttons when doing this.

my understanding of this remote is that in order for HA to see it’s events you have to have the zigbee coordinator in the group it is paired. I believe the quirk auto creates and binds the 0x0030 group for it when the device is added (you can get a better understanding if you read the issue and or pr for it on the zha-device-handler repo). In my experience just adding bulbs I want it to control to that group seems to work (caveat I only have one in HA right now)

You are right. I kept wondering why a “No name group 0x0030” kept being created with one of the lights that I was touchlinking in it. I tried adding the other light (after touchlinking it) that I wanted to control to that group and got “duplicate entity” even though that light wasn’t shown as a group member. Thought that the group had to be corrupt so just set up a group as recommended by Xelloss99 and issued bind command to that group. Worked after I ignored the touchlink. If I have to setup again or another remote I will try the auto generated group as you are correct that I only see the result of issuing the command in the log - not the actual command itself.