How to configure HTTP/HTTPS proxy on

Hi all,

I’m trying to figure out an issue on the updater (TLS handshake timeout during docker pull), and in order to do this I thought to configure an HTTPS proxy.

I didn’t find any configuration or specific theard, so I tried the following steps without success:

  • configure a prerouting nat rule on hassos to forward https protocol to proxy -> it seems ignored due to a generic docker rule in first position of nat chain
  • configure proxy on docker daeomon -> it failed due to root fs in read-only status, and also /etc/systemd/system/docker.service.d . I tried to remount the fs in rw mode, no error messages but the fs is still in ro mode

Any suggestion/hints ?


Hi! I was wandering if you managed to solve your problem?

I stumbled upon this thread because I have a similar problem, but no solution… I am on a network behind a proxy and I can’t find a way to set it up in hassio. I am using a raspberry with the recommended image (hassos). The home assistant is working fine, but it has no access to the internet (for updating or even for the weather updates). I would appreciate any help or ideas.



unfortunately I didn’t find any solution :frowning:

I didn’t try to find any workaround to address this issue because my hassio instance is not behind a proxy (I tried to configure a proxy only to find a workaround to a problem of compatibility between my tplink router and hassos 2.12, the router dropped https connection to some sites, mostly of them on AWS).

I know that for a home user the use of a proxy is not a typical scenario… but should be simple to add this configuration.

I hope you can find a solution.


See and upvote this: Support HTTP Proxy