How to connect to Nibe heat pump without the cloud


Do you have any experience with calculating COP in non-S series VVM? I have two ways to get supply current. BE1-BE3 sensors which sends current on each phase and than EP14 which sends some current, maybe supply current for all phases.

BE1-BE3 sensors looks fine, but BE1 and BE2 sometimes peak to 10 A or even more. This seems suspicions, because sometime it goes close to fuse limit. Also idle current is around 0,5 A on each phase. If I calculate the supply power (3 x 0,5 x 230) I get 345 W idle supply power, so more than 3 MWh in idle per year. I think this is too much. EDIT: I found that BE1-BE3 sensors are measuring consumption of whole house, not just heat pump.

EP14 sensor gives smiliar values as BE1-BE3, but without peaks. Other problem on this sensor is, that current never goes under exactly 1,0 A.

These weird values are also in VVM320, so it’s not a problem of value reading from unit.

Thank you in advance for your ideas.

Hallo everybody,

There is a lot of expertice in this forum.
Is there somebody who can help me?

The situation is as follows:

I connected an Nibe Modbus 40 accessory to my SMO40. The Modbus 40 I have enabled and fysical connected and is accepted with no errors.

Than I try to add the NibeGW integration in HA. I get always the fault:

“Error on read request from pump. Verify your Remote read port or Remote IP address .”

I tryd several IP addresses:

Where HA is running on,

The router address

I can’t find the IP address of the Nibe Modbus 40.

I tryd also some port numbers for read, listen and write:

99999, 99999, 10000

99999, 10000, 10001.

I reversed the A B wires of the Nibe Modbus 40 connection.

Everything without success.

I hope that someone can help me.

Regards, Tim.

Hello Tim,

I don’t know NibeGW in deep, but in my opinion it’s alternative for MODBUS40. If you have MODBUS40 you just need to connect it to heat PUMP and to HA via convertor which converts RS485 to USB, WiFi or RJ-45.

Do you see MODBUS configuration in heat pump menu? MODBUS40 doesn’t have own IP address since it isn’t a network device.

Hi Anacron,
Thanks for your reaction.
I thought that Modbus40 and NibeGW are the same thing.
I have Modbus40 connected to the SMO40 and a RS485 to ethernet convertor.
Modbus40 is enabled in the SMO40 menu.
I add nibe integration in HA. Then have to give the Modbus URL. If I fill in the HA URL I get Unexpected failure. And what is the apparatus ID?
I hope you can help me further.

Regards, Tim.

SInce you already add the MODBUS to SMO without error, there should be everything OK. I would focus on convertor. What model of convertor are you using? Can you test it without MODBUS if it connects to router?

Hi Anacron,
Thanks again for your reaction.
The convertor is a Waveshare RS232/485 to Ethernet convertor.
I can make contact with it and looks ok.
At the moment I have only one ethernet port available for connecting the SMO40 and the convertor. I have first to buy a second range extender (TL WA850RE).
When I have installed it, I let you know.

Hi Anacron,

In the first place I wish you a Happy New Year!

I added a second TL extender.

In the Add integration session I fill in the IP address of the convertor:


I also tried other IP addresses.

I allways get:

Error on read request from pump. Verify your Remote read port or Remote address.

Can / will you help me solving this problem?

Thanks, Tim.

Hello Tim, Happy New Year to you also. I suppose you should use IP address of convertor which you find in your router or administration of convertor (if there is any). Do you have correct port?

I’m using USB convertor so I cannot provide better advice.

Hello everyone! This is a wonderful integration altogether. At first, I didn’t quite understand which steps needed to be taken, but I hadn’t worked with ESPHome before. Surprisingly, it was quite straightforward, and the integration has been running since yesterday on my VVM500 with F2120 and 2x ERS20-250. Thank you very much for that!

After doing some exploring, I found a feature missing: the ability to control the ventilation in stages, just as it works through the hardware AUX inputs. A bit of research online led me to this link:

UPDATE: Through Register 47260 (0 = Normal, 1 = Stage 1, 2 = Stage 2, 3 = Stage 3, 4 = Stage 4), the fan speed can be activated considering the configured activation time of each fan stage.

It’s mentioned there that Register 47260 provides this function, but it’s not implemented in the integration.

So, my question is: How can I “retrofit” this register for writing?

Thanks for this guide! Currently I’m only able to use Docker based Home Assistant, and it does not support Add-ons. I was able to install ESPHome using ESP Web Tools, but couldn’t figure out how to upload lilygo-t-can485.yaml file to the board.

Is it possible to install/upload this yaml without HA OS, i.e. using container based HA installation or some other method (maybe ESPHome on Docker)?

EDIT: ESPHome on Docker did the trick!

Most (if not all) sensors and configurations work as expected using this integration, but at least for F750, fan speed is missing. There are four “Fan speed current” entities, but all show just zero values.

Looking at this, the correct parameter (register?) would be “10001”. @elupus, is that possible to manually insert to HA configuration or would it need a fix to integration?

1 Like

Hey @elupus,

This is really a great job! Congratulations for this!
I loved to setup my first ESP with lilygo and to connect it to my nibe F730. Had some initial trouble, but found a setting that is working over month like a charm. I just uninstalled the NibeUplink integration;)

I have the same issue as @Vaakos my climate system S1 is not showing.
I just attached a possible patch in this Issue Ticket:

If I find some time I will also look at the fan speed for the F series.
I also feel this looks strange:

Not sure how it should be shown, but from the noise I guess my fan is running more likely between 20% and 50% :smiley:

Hero! You actually managed to patch this!

I might have a solution for your fan problem. There an entity (fan_mode_47260) that shows a drop down list with all the fan modes (NORMAL, FAN MODE 1 though 4). Maybe this solves your problem with controlling and checking the fan states.

@Vaakos thanks, hope it will be merged soon.
For the fan i think you are right it looks like Fan Speed current is representing the FanMode 0-5 not the actual fan speed %.
But the Value is configured to be a Percentage… Lets see if my PR is merged I will look more on this.

I also have a lillygo-device connected to a F1255PC.
All seems to work fine, but the HA-log is filling up with the following message:

(MainThread) [nibe.nibe.connection.nibegw] Ignoring coil 47045 value 14002602 - failed to decode

This message is logged every 145 sec (approximately, it seems to be randomized by couple of seconds)
Does anybody have an id to find out what the issue is? (I don’t see any errors in he logs from the device - checked within esphome around the times of the error loggings)