How to delete entities in Insteon integration

I have a open/close Insteon sensor that fails regularly and I’ve replaced it. It’s no longer used for anything so I wanted to just delete it from Home Assistant but i can’t find a way to do that. The “delete” button is grayed out. I tried using service insteon.delete_all_link. Called the service and then pressed the button on the open/close sensor (several times) per the instructions, but it’s not deleted. What am I missing?

The sensor is paired with the PLM or hub and automatically discovered by the pyinsteon library. You need to delete the all-link in the PLM or hub. One way to do that is to follow the manual unlinking procedure using the set bullion on the sensor and the PLM.

Depending on how you originally linked it, you may have links in both directions. So you should repeat the procedure twice, starting with the sensor then again starting with the PLM.

Thanks for the reply. I noticed in the video that the controller (switch in the video) was placed into unlink mode first and then the responder. The instructions for the Insteon integration show calling the service Insteon.unlink_all on the responder (plm) first and then putting the controller (open/close sensor) into unlink mode. I’m wondering if this is backwards? I know when pairing the controller must be in linking mode before the responder. Wouldn’t this also be true for unlinking? Maybe I just need to place the sensor into unlinking mode before calling the service in HA?

Every Insteon device is both a Controller and responder. That’s why I said you need to repeat the process twice especially with the PLM. So I’d say the pyinsteon instructions are not wrong but possibly incomplete. I don’t have experience using the pyinsteon library for link maintenance. I do all link maintenance manually. So I can’t confirm if the service call works as documented.

Ok. Just to be sure I understand the manual mode correctly:
1- Put the open/close sensor into unlinking mode by holding the set button for 3 seconds twice in a row.

2- Put the plm into unlinking mode by holding the set button for 3 seconds once.

3- Repeat 1 & 2 a second time.

Is this right?

I’ve never used manual linking/unlinking at all so totally new to this.

Manual unlinking didn’t work. Tried the process you described and also found in the open/close sensor manual at least 6 or 8 times. It appears to work. HA stops receiving signals from the sensor but the entity is still listed. After restarting the server it starts receiving signals again from the sensor.

There was one minor discrepancy in the process. The manual states that when the unlinking process is complete the led on the sensor will turn to steady on. For me the led went to off instead. I don’t know if this means anything or is just an error in the documentation.

I’ve got a similar problem where an old on/off module just died and is no longer responsive. I’ve removed (forced a delete) of the device in the Insteon App for the PLM, but the HA system still shows the device.

Here’s what I’ve done so far:

  1. Deleted the device from the Insteon app so it’s no longer there.
  2. Deleted the entity related to the on/off module
  3. When listing the Insteon integration related devices, it’s still there and all I can do is “disable” it, not delete/remove it.

I’d like to get rid of it completely, should I just edit the insteon.yaml file and restart HA?

Interesting, this is the only entry in the insteon_devices.json file. Should I just delete this section? I don’t imagine that it’ll make the device disappear in HA, so I’m going to wait for a reply to this thread.

    "address": "2cfecf",
    "cat": 0,
    "subcat": 0,
    "firmware": 0,
    "engine_version": 2,
    "aldb_status": 1,
    "aldb": {},
    "operating_flags": {},
    "properties": {}

I also am struggling mightily trying to delete a device. I know someone said “my answer” is on the Insteon Control Panel, but that is not getting me where I want to go. Has anyone figured this out?

I am also struggling with “ghost” Insteon devices in HA. HA appears to be “reading” all deleted devices that had at one time been defined in the Insteon HB. I have deleted the Insteon Integration from HA, assuming that will remove all devices and entities from HA, then performed a Factory Reset on the Hub with the same assumption - that the Hub database of devices would be cleaned out. However, when I reinstall the Integration in HA, all of the old devices are STILL THERE! Are my assumptions wrong? Any ideas? I have asked Insteon support about the Factory Reset, but it may be a while before they respond (it is just recently they have restored cloud service and support).

UPDATE: I poked around some more and found that Deleting the Insteon Integration does NOT remove the insteon_devices.json file, which contains the definitions of (evidently) ALL devices ever known to Insteon. To be safe, I renamed it, and re-added the Insteon Integration and viola! - just the Hub itself is known to HA. I then re-added the devices to the Hub and they appear in HA. Problem solved!


I’ve have a lot of Insteon devices (wiping out the plm and starting from scratch is not an option I would consider)

I have 2 devices I want to remove

  • fanlink (dead, no longer have access)
  • iolink (garage door opener - still has power if needed)

I have been trying to get the ha service Insteon: Delete all link to work, but to no avail:(

Following the description and directions noted:

Tells the Insteon Modem (IM) to remove an All-Link record from the All-Link Database of the IM and a device. Once the IM is set to delete the link, press the link button on the corresponding device to complete the process.

Is there not a service that will delete the device , not just the links

I would like to completely remove these 2 devices from the HA integration.

There has to be a way… any help is appreciated.

I am also looking for an answer to this. I am moving from a UDI Polisy and am currently using the Universal devices ISY Integration, but in hopes of making things simpler I tried the HA Insteon integration.

I used a spare USB wireless 2448A7 to test and linked a keypadlinc. My conclusion is that I will stick with Polisy and integration. If I was able to delete a device/entity then I would probably consider since my Insteon network is not overly complex, but lacking this ability to delete a device is a deal breaker.

Maybe an Insteon Hub would also work better instead of a PLM, because it can manage the Insteon Devices and linking in its interface, but then again no different than what I currently have with Polisy and integration.

The Home Assistant Insteon PLM integration is an embarrassment. If you’re like me and already have a Universal Devices ISY, Polisy or Eisy then stick with it. The best world for using HA with Insteon is with the Universal Devices controller.
I experimented with the HA PLM integration for a few devices that I don’t use very often. I just wanted to delete one from HA and put in back on Polisy and I found out how impossible it is to delete. It really sucks.

I’m not like you.

I followed @lenzrg 's process and it worked.

Delete the Insteon integration for my Hub v2.
Rename or delete the insteon_devices.json file.
Reboot HA (just to be safe)
In-install the Insteon integration.

Result: Only the Hubv2 is found!