How to disable wifi and bluetooth on new installation?

I’m new to I just installed it and everything is working but i want to disable the wifi and bluetooth radio. I searched the forum and the results were not helpful because I do not have a config.txt file in /mnt/boot or /mnt/config. Can anyone help me?

If you’re using the SSH add-on you won’t see the actual host OS. You need to look at “debugging HassOS”

I’m not using any add-ons, I’m just using it locally. I took the sd card out and mounted it on another laptop to browse the filesystem.

So what directories do you see in the “other laptop”?

I have 4 partitions:

268 mb volume:




Usually a raspberry pi SD card will have a fat partition with the kernel, and config.txt etc on it.

Ok, thanks for your help everyone. This is out of the box, but I must have done something wrong. I will flash and install again.

Your SD card is likely fine and you are looking for the FAT partition. You might need to work a little more to find and mount it using OS X, if that’s what you’re using.

I’m using linux, but I’m just looking at the SD card filesystem in the gui file explorer. I will keep trying.

1 Like

Never mind, I found it. For some reason I thought it would automount, then I opened up disks and looked at the SD card, found all the partitions, and mounted the boot partition. Config.txt is right there. Thank you.

Is there an updated way to disable the radios or is the following information correct?

1 Like

There may be a way to disable it more completely, but I’ve only used the network manager nmcli radio wifi off. You can use nmcli if you install the SSH & Web Terminal addon and turn protection mode off.