Quick Question, how to I turn of the Wifi Radio on my RPI3 using HassIO?

Quick Question, how to I turn of the Wifi Radio on my RPI3 using HassIO under HassOS

I’m using an ethernet cable now, I’ve read the docs here:

but I cannot see a way of turning the Wifi off. thanks

I’m also very interested in doing this. Anyone know how to get Hass.IO to not boot up the wifi module?

Edit the “config.txt” file to disable WiFi (and Bluetooth.)

You can access config.txt either by mounting the SD Card in a separate computer and editing it directly (there is FAT32 partion called boot).

Or if you have the HassOS SSH console enabled, you can connect with that and edit the file and reboot the Pi.

/mnt/boot/config.txt

kernel=u-boot.bin
disable_splash=1
dtparam=audio=on

# Minimum memory assigned to GPU
gpu_mem=32

# Disable WiFi
dtoverlay=pi3-disable-wifi

# Disable Bluetooth
dtoverlay=pi3-disable-bt

For more detailed information see:

If you make a mistake and HassOS won’t boot, you must remove the SD card and edit it in another computer.

6 Likes

Thank you so much :slight_smile:

I’ve already enabled SSH access over port 22222, and updated my config.txt file, and it seems to have worked, nice to be able to disable bluetooth also.

Also I didn’t have a line to set the GPU/CPU memory split gpu_mem=32 in my config so I added it.

Before adding it the GPU was using 76MB:

$ docker container exec homeassistant /opt/vc/bin/vcgencmd get_mem gpu
gpu=76M

After adding the line the GPU is now using 32Mb so it’s nice to free up a little extra RAM for Hassio.

1 Like

How may one verify that bluetooth and wifi are indeed disabled?

Does anything show up in /sys/class/bluetooth?

How may I check? I am logged in as root, but commands like ls do not work.

I’m SSH’ed in as root and this is what I get:

# whoami
root
# ls /sys/class/bluetooth
ls: /sys/class/bluetooth: No such file or directory

I got it now with SSH, thank you!

Ssh add-on is a separate container…

At first I plugged the homeassistant into a display and logged into root from there.

If on a Pi 3, grab a soldering iron, and get to work.


hopefully it wont refuse to boot if you remove it lol

i want to disable WIFI only, as i am using cable connection, and also using BT.
When i add:

dtoverlay=pi3-disable-wifi

to config.txt the wifi is disabled , but also BT is not working. Anyone knows why? Or what should i change?

Open the config.txt

/boot/config.txt`

  • Find the following line:

'# Additional overlays and parameters are documented /boot/overlays/README`

  • And add these two lines under it :
dtoverlay=disable-wifi
dtoverlay=disable-bt
2 Likes

Where do I find this file? I have the SSH addon installed but cannot see it there.

The ssh add-on just gives you access to a limited shell on the system. You don’t have root access.
It is probably easiest to shutdown HA and then put your SD card into a PC or Mac. You should find the file on either the root of the SD card, or it might be in boot folder.

1 Like