How to enable my disabled entity again (zIggoNet)

I installed the ZiggoNext integration using HACS, everything went well.
At one moment i decided to disable my ZiggoNext entity (configuration - entities).
At this moment i thougt that i simply could enable the entity again after disabling it… i was wrong, after disabling it it wasnt in the entities list anymore. I searched for an option to get it back, no succes.

What i’ve did using HACS:
uninstalling ZiggoNext integration.
restart HASS.
Install ZiggoNext integration.
restart HASS

But still i haven’t got my ZiggoNext entity back :frowning:

1 Like

Hi - I just had same issue and came across this while searching… For future posterity, solution was to stop HA, go to .storage directory, edit core.entity_registry, find entry, and set ‘disabled_by’ to null, then restart.

2 Likes

Go to Configuration -> Entities… then on your right side on top of the table you will find a little icon for filter, click it and enable to show disabled entites.

7 Likes

in my setting this does exactly nothing… Cant find any of my disabled Philips Hue integration motion sensors

1 Like

Thank you for this tip! i got my weather entity back now!

Another thank you for this tip. I had added an ESPHome ESP32 board months ago for development, then later repurposed it with a different name. I kept getting the disabled via Config error no matter what I tried.

What worked was to find and delete all references to the old entry in both .storage/core.entity_registry and .storage/core.device_registry, and to set disabled_by to null for the new device and entities.

There surely must be an official way to do this, is there not?

2 Likes

Yes. This.

3 years ago it seems there was an issue that caused this to not work sometimes. Its safe to assume its been fixed by now.

Is there a walk through on exactly how to do this? I am new to home assistant and I have disabled one of my roku TVs and now I can not enable it again. I get that the device and its entities are disabled by a config entry and I can’t seem to work out how to fix it.

Like you disabled the integration? Go to integrations and click “show” in the top right next to the count of diabled integrations. Find the integration you disabled, click the 3 dots and click “enable”:

Or you disabled the device? Go to devices and click “clear” in the top right next to the count of hidden devices. Find your roku in the list. Click it to open the page for the device, click the edit button in the top right and switch the toggle from disabled to enabled in the pop-up:

Or you disabled the media player entity for the tv? Go to entities and click “clear” in the top right next to the count of hidden entities. Find your roku in the list. Click it to open the more info pop-up and switch the toggle from disabled to enabled in the pop-up:

There’s no walkthrough on how to do the other way because no one should edit the registry files. There is no schema for what goes in there and it can change without warning in any release. Since the only thing expected to be editing those files is HA. You should use the UI.

1 Like

Hello Mike - I wanted to use UI, however this is what I am running into:


… and if I click the upper right corner “pen” icon to edit, it is greyed out and I cannot enable:
image

And I have a couple of the same bulbs… some are OK, some are disabled…

Could you help point me to the right direction? Is editing the registry the only way to go…?

Is the integration that created it disabled? There is a config entry per integration so it sounds like that’s what its saying. I haven’t seen that error before though so I’m not sure.

Yes the last line (Homebridge DD92 14DC) was the integration - am connecting to Homebridge via the HomeKit Controller integration.
… and that was disabled also… and greyed out also.

I have the same problem with multiple devices (sensors and switches, both ZigBee) using the Deconz integration. I had an old Deconz integration that I already deleted, tried to delete the devices within Deconz/Phoscon and readd them but I still have the same issue. Devices are deactivated by config entry and I cannot enable the via UI, because the toggle switch is grayed out

I solved this problem by removing the devices in Phoscon/Deconz, then going to developer settings and running Deconz: Device refresh and remove orphaned entries in the services tab (I hope that’s what the tab is in English, not 100% sure). After that I added the devices in Phoscon again. Finally, running Deconz: Device refresh another time.

Have you checked if the devices are really deleted?

I just had this where the UI would not allow me to re-enable a device, manually editing the .storage/core.entity_registry and .storage/core.device_registry files has fixed my issue.

The plugin that wouldn’t reenable was the Hildebrand Glow (DCC) (installed via HACS)

In my case had to change also in .storage/core.config_entries

This has nothing to do with getting those entities back… This will JUST show them on a list. It does not allow you to re-enable them.
The issue is not that they disappear. The issue is that it is not possible to click the switch to enable the device again…
I’m currentl having the same problem with ESPHome device that i disabled, because it was showing twice. Disabling one disabled both instances. one of them later disappeared. (makes sense, same hardware same config same name. Shouldn’t have been two entries at all.)
And now i have re flashed it twice, while deleting different stuff mentioning it. Still no luck.

Sad to see these issues are on-going.
I’ve joined the festivities. I thought it was such an innocent thing to do, to disable an entity, just to try out the functionality. Now I can’t get it back. Ugh.
In my case, it is an entity exported by node red, so I guess I can just change the name of the exported entity slightly in node red to get it back, but this kind of stumble rocks my confidence…

I ran into this exact situation as well with a TP-Link integration (where I did disable it via UI but when I went to enable it, it was greyed as displayed above). I ended up having to go into core.config_entries, core.config_registry AND core.device_registry, locating the device and setting the ‘disabled-by’ to null in all three (then restarting HA) to get it to reappear (will need Terminal or direct ssh access to find these files in .storage)

Sorry to necro this thread, but I just found the solution to this problem without having to resort to editing the core.entity_registry.

I had an issue with the iCloud integration and to try and troubleshoot, I had gone into the Integration’s devices and disabled each of them individually. I then went through a few reboots of HA, thought I had the issue sorted out, and then went to re-enable the devices only to be greeted by the “Enable” slider being greyed out and being told that the device was disabled by “Config Entry”.

I was about to edit the core.entity_registry when I noticed on the device profile information it was listing the iCloud integration itself as having disabled the entity.

So, in a last ditch effort, I went into the iCloud integration itself, hit the three dot menu on the right under “Integration Entries” and chose “Disable”. I got a warning that it would disable all Devices and Entities under the integration, I accepted.

The integration disabled, and then I immediately re-enabled it. This re-enabled all of the devices and entities underneath. Problem solved!

1 Like