How to get the IP Address or access to instalation

I installed the Home Assistant in my personal laptop at home in Windows 10 with the HA image in virtualbox and it seams that all the steps are correct and actually I get in virtualbox that Home Assistant is running. I have my laptop conneted through the ethernet cable direcctly to the router. (I´m attaching an image where we can see that HA is running but in the console I don´t see any IP address where to access).

I tried to access through:

  1. http://homeassistant.local:8123
  2. homeassistant:8123
  3. I also downloaded “wireless network watcher” and I tried all the IP address there and cannot access to homeassistant

From what I´m seeing in tutorials, accesing for the first time will run the instalation, but I was not able to get to that point yet.

Thank you very much for your support

1 Like

When you start the Virtualbox, it will tell you the IP address in the window which opens. If it doesn’t check your network settings are in bridge mode.

Yes, I have it in bride mode. This is how I have it setup. The only thing I can think of, if that when I did the setup, I selected the “other 32 bits” because I didn´t get the option of “other 64 bits”.

You have selected a wireless NIC. Drivers too those can be missing in the image.
Try a cabled network instead, if possible.

I have only 2 options in the settings and I tried with both options with a network cable connected to the router and with wifi and none of them worked.


Your Realtek is the most likely to be included in the image, so go with that until you get access.
What does the terminal output say when you have it set to Realtek and reboots?

And also try different emulation modes for the NIC, if possible.
There should be other options than PCnet-FAST III

Is it even starting up? You need a 64bit os to run HA. If you are only getting the “other 32bit” you probably have 32 bit windows.

I got it to run, apparently, or at least that´s what it is says the console, but it doesn´t give me an IP address.

I tried to access through:

  1. http://homeassistant.local:8123
  2. homeassistant:8123
  3. I also downloaded “wireless network watcher” and I tried all the IP address there and cannot access to homeassistant

But none of these works.


Thanks again

This is what I get when I introduce the address in the browser


I am not that sharp on HAOS, but try to enter ? in the console and see what happens

i dont understand a S… of what ur screen tells you, but i would like to see whether the url starts with http, or https, last wont work
and again you should be able to see in your router, which ip-number ur homeassistant have

PS: in the Home Assistant Console
type: ha dns info
hit enter

After that …
type: info
hit enter

take a screenshot

This is what I got following your instrucctions

ok, so ha dont find any dns-server

then type:
network info

hit enter

and there also seems be be other things wrong … we take that when u done and see next screenshot

This is the screenshoot forn network info.

I have the nerwork cable connected from the laptop directly to the router to a LAN conector (in the router). I also tried through WIFI connection but didn´t work either.

Thanks again

Have you got the network set to bridge mode?

Do you mean here? or do I need to do anything else on my network?


This is the set up I have in the settings in Network.

By the way I don´t know if this is important but even though I have the Ethernet cable connected to the routher, in the HA settings (network) under name: I only get this 2 options:

  1. Realtek PCIe GBE Family Controller
  2. Intel(R) Dual Band Wireless-AC 7265

But I don´t get any Ethernet option

Yep that’s the setting. The only difference with mine is the Adapter type is not blanked out and promiscuous mode is set to deny. Can’t really help more than that.

Another thought have you tried disabling the wifi in windows so windows only uses the LAN?

In the home assistant console type

ip addr

And then for example if you are on a 192.168.x.x subnet, try

ip addr|grep 192

Adapter type is probably only blanked out, because the VM is running at the moment the screenshot is taken.

Now is your normal workstation on the 172.30.x.x network too?
And if your workstation have a 172.30.x.x IP address can you then open your router and take a screeshot of the IP leases, then shut down the VM and change the MAC address in the settings, just some of the last 4 characters.
Restart and check your IP leases in the router again for a new MAC address.
If its there then try to ping the IP address belonging to the MAC address.