How to install into QNAP Virtualisation Station

The QNAP Virtualisation Station does not have Enable UEFI option, so I use the following steps to make it happens:


  • VirtualBox (PC/Mac)
  • Hassio image vmdk / vdi

In VirtualBox:

  1. Add Disk Image File (File > Virtual Media Manager > Add), select downloaded .vmdk or .vdi
  2. New Machine:
  • Name: hassio
  • Type: Other (Important)
  • Version: Other/Unkown 64-bit (Important)
  • Memory: 1024MB
  • Hard disk: select added hassio vmdk/vdi
  1. No need to start
  2. In created machine settings:
  • System:
    • Uncheck Floppy, Optical
    • Select Chipset: ICH9 (Important)
    • Extended Feature: check APIC, EFI, Hardware Clock (Important)
  1. Others not quite important
  2. Export Machine to .ovf (Machine > Export to OCI):
  • Select Format: Open Virtualisation Format 0.9 (Important)
  • Enter file, change from …ova to …ovf (Important)
  • Continue
  • .ovf, .vmdk and .mf files will be created separately
  1. done

In QNAP Virtualisation Station:

  1. Import VM
  • Import From: PC
  • Select created .ovf
  1. It will ask for disk image file, select created .vmdk
  2. Next
  3. Enter Info by your desired
  4. Advanced Settings:
  • CPU: i7
  • Netwrok: Intel Gigabit Ethernat
  • Hard Disk:
    • Cache Mode: Writeback
    • Controller: IDE
  1. Import
  2. Done

Now the Hassio vm should now created and bootable!

I tried .ova format before, QNAP will return checksum error, so .ovf 0.9 version can avoid it.


Thank you for your contribution. You should consider adding this to the home-assistant documentation.

Nice to see some developments

allreaddy wrote some on this toppic Github

If you have problems with OVA import use Virtbox 5.2.
Fore some reason it works on that version.

Goodluck and have fun

my vm say: booting from HDD… fixed… no boot… someone experience this?

I had the same issue, to fix this i used VDI instead of VMDK and exported the virtual machine to OVA format. I have QNAP TS-253A. It’s not a difficult process but if anyone want the converted image i could upload it somewhere.

Please upload the OVA file. Thank you.

I’m stuck at “Booting from Hard Disk…”. Mine’s a TS-253 Pro

1 Like

Here is the link, works on my TS-253A

Thanks for the time you spent on the tutorial. Followed strictly, but no go. Also tryed the @nick3 solution and still no go. Maybe there’s a fix, but the process is too much unreliable to put into production. Anyway, thanks again for your contributions!

  • For the records: Hardware = TBS-453A
  • Also for the records: Synology Virtual Machine Manager runs HassIO without any workaround and without any problems here. I’m currently trying both systems to see what fits better in my environment.

Very strange that it works on one qnap and not the other, My Hassio is running without any problems just like intended and is currently in a production environment in my home, I have updated the core and OS many times without any issues.

What is your problem exactly? Does the VM say booting from HDD and nothing happens or something else? Another thing i can do is upload a native QVM format VM.

After - currently it is a guess - running into some trouble with my VM setup on Ubuntu I found your tutorial. Thanks a lot for not only testing but also sharing.
I downloaded Virtual Box 6.1 and used the vmkd hass 3.11 to follow all your steps.
I am quite positive that I did not miss anything and I get stuck on the boot up.
Second try was using your ova which is starting up for me (TS-453B 4.4.1).
Updating to Version 3.11 is not really working for me though.
Are you on 3.11 ? Could you maybe export and share the qvm?

Based on @nick3’s image I created a qvm with the basic things prepared for Zigbee2mqtt setup, including needed automation mqtt etc. Feel free to try and share feedback.
Login is:

1 Like

THNX, (Almost) same procedure works with VMWorkstation as well. (Set to IDE, EUFI and export to OVF)

Hi Duesseldorferjung,

can you upload your qvm file again?
The link is Brocken.


Well, to avoid sharing something I am not aware of, I always set and expiration date on my nextcloud links. This one is good until 31.5.20 now.

Hi guys! I did everything exactly as suggested in the first post and I am also stuck on Booting from Hard Disk…

Any idea?

Thanks from great tutorial!

I managed to get Home Assistant running but I am not able to access UI in http://<QNAP_IP>:8123.

Any Ideas how to forward. I am able to acess Home Assistant CLI.

Hello, got the same problem than you, homeassistant is running but can’t reach it with QNAP_IP:8123
Did you solve it ?

Oops find it finally, the IP wasn’t the same than the nas_ip !


Good you got it working!

It was same with me. I noticed from my router that Qnap virtual switch has gotten it’s own IP and HA opened from there.

In virtualisation station select your vm, click on setting, boot options and select UEFI in firmware type