How to remove a self discovered UPnP/IGD integration


A couple weeks ago I got a card which indicated that my router was discovered for UPnP. Curious I hit the link and accepted the configuration.

Since then I have discovered that it isn’t useful for me as all the stats are 0 essentially, execpt some which appear to be max-int. Likely since I do not have traffic monitoring enabled on the router.

However, I cannot figure out how to remove this integration. I go into the Integration screen, I click on the row in the top box which shows the router, but if I click on the trash can in the top right corner, nothing happens.

Any suggestions?

Thank you.

Did exactly the same thing and came to the same conclusion. In my case, however, I was able to delete it. In other words, the “trash” took. Of course once I rebooted I was asked if I wanted to (re)add it. That problem was solved with:

    - igd

Thank you. I tried it with a desktop browsers and it worked. I was trying from my mobile.
Thanks for the advice for it not to come back