How to replace Conbee 2 Zigbee stick and retain current config?

Hi,

My HA configuration has grown to be more integrated into our home. This means that failures have become more significant.

To mitigate failures I have bought a second set of kit (RPi, Conbee 2) and copied a snapshot onto the SD card in the RPi. This means that, in the event of a failure I can unpug the Rpi, plug in the new one and we are back running in about 5 minutes, albeit with an older config.

The outstanding question is the Conbee 2 zigbee controller. Given that the USB device is addressed /dev/serial/by-id I assume that this will need to be changed in the standby configuration? This could be done offlline beforehand so isn’t a problem. However, if I replace the conbee 2 am I going to have to re-pair all the zigbee devices to the new one manually? This is not really acceptable.

Is there some way for the standby stick to pick up the configuration of the live stick such that no device pairing is required ?

Thanks in advance.

Does this help?

It looks like the answer is in that thread. I’ll try it out and confirm. Thanks for the pointer. It’s always reassuring when someone has gone down the path before.

Given the increasing importance of HA, methods for creating standby systems are definitely required.

Hi,
I went through the process but ended up with a controller with an ID of zeros. There’s a description of how to fix this issue in the Deconz documentation but it involves removing and reinstalling the addon. I’ll give this a try, but for the time being I need to return to my live system so that I avoid being kneecapped when the lights don’t work.

I’ll update when I’ve got this working.

Thanks

Any update? I’m interested too, just in case of conbeee ii failure…

Afraid not. Testing it out does not go down well with the other half in this weather. I’ll pick it up again in a few weeks. Everything else can be swapped in minutes, but at the moment I think all the zigbee devices will need to be re-paired with the new conbee.

Hi there,

I did not have to re-pair anything. I actually have now two NUCs with Conbees and I can remotely swap from different location to backup systems RPI3B+ with Raspbees. This was my procedure:

  1. I created a backup in Phoscon in existing system
  2. Shut down the host
  3. Pulled Raspbee out
  4. Installed Conbee
  5. Power on
  6. Changed the device address in deconz addon (device: /dev/ttyUSB0)
  7. Loaded the backup in Phoscon
  8. In hidden config loaded the last network configuration
  9. Rebooted the host

I think at some point I had to manually change in Phoscon the zigbee channel to 25 (from 20 which the new Conbee had) …

1 Like

Tosion,
Thanks for this. It was a while ago, but I think that was broadly what I tried. As I recall, everything looked fine from the rPi end but was disconnected from the actual zigbee devices.

I’ll need to repeat the exercise at a suitable time.

Hi tosion,

What do you mean by “In hidden config loaded the last network configuration”? It’s in phoscon webapp ? Home Assistant ?

In fact, I am reinstalling Home Assistant on an SSD (before it was installed on a sd card) and I am having problems with my Conbee2 key. If I run my rpi with the ssd, everything works but in deconz, I see the devices but no link and all are in error. So I’m missing a part of my configuration.

I would like to be able to restart everything on a fresh installation of home assistant but with the same conbee2 key.

I would like to test your method even if it is not exactly the same situation.

Mavvv

You can find the answer here:

Hmm…
Not 100% sure it is that same, but when I moved my zigbee2mqtt server from my W10 host to Linux, all I did was to copy the database.db to the \share\zigbee2mqtt folder.
I didn’t have to (re-)pair anything :thinking:
Furthermore, this file is asci, so you can just edit it with any text editor :stuck_out_tongue:

Well, I’ve had a chance to run through this. Apart from making a mistake at one point, it’s actually fairly straightforward.

The device address tripped me up as I was using /dev/serial/by-id and (obviously) the id of the device changed to the replacement conbee. I have changed this to a physical address to make changing the adapter more straightforward.

Without the mistake, I think the process is as follows:-

  • Create snapshot of Hassio and copy to PC
  • Create Backup of Conbee config on PC
  • Stop live system and power off
  • Swap Conbee with standby conbee and Power on rPi
  • Check device address is correct. in add-in configuration E.g. /dev/ttyACM0
  • Restart add-in
  • Restore Phoscon backup from PC
  • Devices now seen in deconz (vnc) but no network connections
  • Go into hidden advanced config and load correct network config
  • Deconz (vnc) now shows network connections.
  • All working correctly now
  • Reboot rPi to tidy up
2 Likes

I tried to move me DeCONZ to another Conbee 2 stick, only the network does not come up, around 30% devices are connected in the GUI. Only no measurements coming in, nor I can switch lights/plugins.
I tried backup/restore and also the hidden advanced config, but nothing made the network work. Anybody an idea what to try next?

@grundfuttock I can confirm these steps still work in November 2021.
The option hidden files in Deconz is the following:

  • Log in into the Deconz app via Phoscon
  • Select Gateway
  • ALT + Left click on the icon: Advanced
  • Load the latest file; for example in my case: I had files 1-18. So the latest was file 18, I loaded that file.

After reboot of Home Assistant, go into the Deconz Add-On and click on deCONZ. Wait for a few minutes and you will see rebuilding the whole network structure.
On the new Home Assistant instant you need to add the new Integration Deconz to import all the devices once again.