How to setup Netatmo integration using webhooks to speed up device status update response times

It seems that quite a few people struggled with setting up the webhooks for Netatmo integration. (You need to set them up if you want to drastically increase status update response times reported by your Netatmo devices). I was one of those people so I decided to gather all the information scattered among multiple posts and write up this compact guide to help anyone else struggling with this.

It’s important to note that the main credit for the information provided below goes to Cgtobi who seems to be the main person in charge of Netatmo integration overall and ondrej.belecky. Contributions of both people helped me the most to solve this issue especially in this post.

  1. This step is the most important:

DO NOT install Netatmo Integration from Home Assistant Integration page yet!!!

If you have it already installed, delete it first. Disabling it is not enough, you need to delete it. You will reinstall it as the last step of this guide. (After reinstalling, I didn’t have to redefine any of the Netatmo entities, they all came back. But just to be on the safe side, make note of all the customizations you happened to make to your Netatmo devices and entities.)

  1. If you use Nabu Casa you can skip this step.

If you don’t use Nabu Casa you need open port 443 so that your home assistant installation can be accessed externally. You can find multiple posts that deal with how to do it. And you need to have reverse proxy configured correctly as can be found for example here. (Nabu Casa does both of these steps for you.)

  1. Sign in to Netatmo Developer Page here: https://dev.netatmo.com/
    (Use the same credentianls you use to sign in to regular Netatmo account.)

  2. On that page, create new app. Name it whatever you like (although it must be a unique name). It will generate client ID and client secret for you as shown below. Make sure “App status” is “Activated” and there is a green tick next to “Webhooks” status as also shown below:


  1. In Home Assistant go to Settings > Devices and click three dots in top right corner and then click on Application Credentials as seen here: Application Credentials - Home Assistant. Add credentials manually by clicking the button in bottom right corner (Add Application Credentials):
  • Select “Netatmo” from Integration drop down menu.
  • Give your credentials a name. (It can be anything. Remember it. You will need it later when setting up the integration itself.)
  • Use client_id and client_secret that was generated for you when creating the app in the previous step.
  • Click Add
  1. Restart Home Assistant

  2. Now add Netatmo integration from integration page. It will give you option to set it up either from credentials you created in previous steps (the name you gave it) or Home Assistant Cloud. Use the option with the name of credentials you created!

Everything should be working nicely now and the status update response times should be almost instantaneous.

If it didn’t work, the most likely culprits are:

  • You installed the Netatmo integration before setting up the webhooks on Netatmo Developer Page and before adding the information to configuration.yaml.
  • You didn’t open the port 443 (If you have Nabu Casa you don’t need to.)
  • You don’t have reverse proxy configured correctly. (If you have Nabu Case you don’t need to.)

Hope this helps someone at least a bit. :slight_smile:

12 Likes

That worked perfect. Thanks.

Thanks for the help… it worked perfectly.

Hi all,
I’m new in HA, so probably (or sure) it’s my fault, but when I add netatmo integration and try to configure it, just “Netatmo public weather sensor” appears. How can I add my modulating thermostat and valves?. I was reading the community but without success.
Thanks in advance.

Under “Devices and Services” in your Home Assistant you should see something like this:
image

You should see your thermostat and valves after you click “devices” (In my case “7 devices”). You don’t need to click “Configure” for those devices to work.

Have you checked the logger for more information about the problems you are experiencing with the Netatmo integration? If not, you can modify your configuration.yaml file to increase the logging level for the Netatmo integration. To do this, add the following lines to your configuration.yaml file:

logger:
  default: warning
  logs:
    homeassistant.components.netatmo: info

Alternatively, you can use this configuration:

logger:
  default: warning
  logs:
    homeassistant.components.netatmo: debug

Once you’ve made the necessary changes, remember to restart Home Assistant. After the restart, you can verify whether the logger provides additional information about any issues with the Netatmo integration.

(For more information about the logger, you can check this link)

Thanks for your reply, I see the integration, but empty: image
I add logger:
2023-05-22 10:28:02.443 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Publisher account added
2023-05-22 10:28:02.689 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] No device data available
2023-05-22 10:28:02.690 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Publisher weather added
2023-05-22 10:28:02.809 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] No device data available
2023-05-22 10:28:02.809 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Publisher air_care added
2023-05-22 10:28:02.810 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Publisher weather removed
2023-05-22 10:28:02.810 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Publisher air_care removed

Thanks for your help

It seems Home Assistant can connect to your Netatmo account correctly. It then recognizes at least some of your devices but it doesn’t receive any data from them so it drops connection to them.

It is difficult to say what could be causing these problems. Here are a few things you can try to troubleshoot the issue:

  1. Do the devices work properly outside of Home Assistant like Netatmo app on your phone?
  2. Can you see your devices properly in your Netatmo account e.g. here or here (depending on which devices you use?
  3. Have you tried restarting your Netatmo devices?

If none of the above works, I would suggest reporting the issue here.

Hi, thanks for your reply,

  1. Yes, my devices are running perfectly on Netatmo app.

  2. From the links you sent me I see this:


    and this:
    At the first one it seems that my devices are at the rear part, but I’m not sure.

  3. Yes, I restarted some devices with the same results.

Thanks again for your help

Hello,

I try your methode but it doesn’t work. Netatmo can’t be configure in the configuration yaml… How can I use the webhook with nabu casa ?

hello followed the instructions but I get this when restarted HA :slight_smile: The netatmo integration does not support YAML configuration

what is wrong ?

I found a solution. In fact now you just have to set up the application id. Uninstall the integration, reboot ha. Install the intégration and select webhook.

1 Like

Great but I am misssing the Netatmo Smart Smoke Alarm sensors. Any chance we can integrate these as well ? Thank you !

1 Like

I have now modified the step number 5 in my original post to reflect the updated official instructions.

1 Like

very helpful, that worked perfectly for me . Good job thanks a lot

For the past few days, my Netatmo Video Doorbell hasn’t been streaming. Therefore, I deleted the integration and attempted to reinstall and reconfigure it. However, it’s now only linking to my account via the HA cloud, despite my attempts to connect to my developer account → “Successfully authenticated. Created configuration for Home Assistant Cloud.”

The next step I took was creating a new app on dev.netatmo.com, which is where things became strange. After entering the necessary information (title, email, DPO) and clicking ‘create,’ I ended up on a 404 error page (on dev.netatmo.com).

When I returned to my apps, it seemed that one had been created. However, all fields were empty, and even after attempting to fill them or enable/disable the active status, nothing was saved.

I suspect this may be an issue on Netatmo’s end. Is anyone else experiencing something similar?

1 Like

I have the same problem. Creating a new app on dev.netatmo.com is not possible. After deleting the integration, it is also not possible to establish a connection via the HA Cloud.

Same here. Hope this will be solved soon! Happy to have any tip to receive webhooks again…

Thanks

1 Like

Seems to be a problem on Netatmo’s side: