How would you tranfer from your Pi to your new Nuc?

Spoke too soon. Zwave was fine until a reboot, then it was mostly dead again.

The problem seems to happen when it updates the zwave config file. Copy the old one back and it work again till reboot,

time to take a break…

Are you allowing the z-wave nodes time (approx 5mins) to initialize after each reboot?

Yes and when it works it does take time. When it doesn’t, it eventually gives up trying.

I just put the Pi back online and zwave came up instantly.

The “configuration.yaml file not found” error can also be caused by a file that is included in your configuration.yaml file using some sort of !include directive not existing.

If you haven’t copied over every file and directory that is referenced in an !include then you will get that error.

That probably was it. The first time I tried this, I copied everything and the system would not come up at all. Then I started getting the /config/ not found error when I copied 1 file at at time to see what was killing Ha. That did not work and maybe that is why.

Then next time I had both the old and new HA open as the same time in the configuration editor. For configuration.yaml, I copied /pasted each line, checking each line in the check configuration as I went along. I did not copy everything because some of it is no longer needed (ie the home location config) . That is when that "can’t find /config/configuration…yaml message went away.

Automatons transferred with no issues via copy paste. The zwave config file was just copied over and then it seems to work until you reboot.

Right before I went to bed last night I tried it one last time and the system came up like it should. It stayed up overnight though I was told 1 light did not shutoff at sunrise.

Tried rebooting this morning and zwave came up, though much slower than on the pi.

Then I shut it down and restarted and it’s dead again. The only clue when it dies is i see messages about my nodes are looking for suc and the stick is reporting it is not suc (primary node I think).

As I was writing this message I rebooted and Zwave came up, though much slower than on the pi. This time I did NOT copy the old zwave config file over, so it eliminates that variable! Finally getting a little bread crumb- but I will take it :slight_smile:

The other thing that may or may not be true as I still not sure at this point:

It seems that when Zwave, does load properly, it’s when I reboot the system rather than shut it down and do a restart. I am going to work on that today to see if can prove that is true or not. May be some weird timing issue but guessing at this point.

Warm booting seems to be the trick. Turn on the machine from a cold start and Zwave will not start.

Wait a few minutes (not sure exactly at this point) and reboot and it works after a couple of minutes The pi sees zwave instantly while ubuntu takes a bit but it does work at least until I shut it down again. Then repeat process.

As far as the SUC error, I see someone else had the issue and this was their fix …thinking this over right now…:

Are you sure that the z stick device path isn’t getting changed on a restart?

I don’t have any idea what that error is but the USB path could get changed on reboot and if the device path is changing then I can see that causing issues until the next reboot and it getting changed back again.

I tried that earlier today and hardwired it like this:

  usb_path: /dev/serial/by-id/usb-0658_0200-if00

Same thing unfortunately
So far others that had the issue had to start over…hoping I won’t have to do that.

Yeah, that should definitely prevent that being the issue.

Good luck.

Using a snapshot I went back to where I was when I had just installed ha - and did a clean copy of the all config files…
Then I did a config check to see what stopped HA loading on my very first attempt (on Sat?) and all it was was the duckdns host name config it did not like. Remarked that out and rebooted.

It works but is same- warm boot works and takes a bit to initialize but does work. Cold boot no can do.

Thinking about borrowing a pc at work and install ubunta directly on it and see if it performs any better. I.E. Is something wrong with my zwave or just the way it is with ubunta.

Zwave on my pi has been flawless.

Got a clue this morning:

Short story too much to type: I had to remotely reboot my pi this morning and it was slow initializing my Zwave just like in my ubunta setup. It has NEVER done that unless I booted up the PI without the Zwave stick inserted.NEVER.

I am going to test more when I get home but if this holds true then that points to something zwave(openzwave) specific and nothing inherently wrong with ubuntu or my setup.

Which means I will just exclude everything and go with a fresh setup this weekend. The garage door will be a pain but the rest not too bad. Till then…

At long last, Zwave is working properly again and I did not have to redo anything!
It has worked perfectly on cold starts several times now and it has never done this until today.

What I did that apparently fixed it was to force the speed to usb 3.0 in the vm. I had done this before early on and it did not work. I found out the Aerostick is usb 2.0 so I tried it again as the vm defaults to usb 1.0.

I still have a few things to fix, but she’s back!

@kanga_who (or anyone else)

Following your instructions, it just occurred to me, will docker (and hence HA) automatically start every time the server is restarted?

If you use the Hassio script, yes.

If you use the parameter restart=always or unless-stopped in your docker run or compose, then yes.

Ok, I’ve bitten the bullet and gone with a native Ubuntu / docker / HA install and for the most part it has gone well after restoring a complete snapshot.

I don’t seem to be able to get the hassio SSH add-on to start though. Is this the right place to ask why not?

Make sure you are not using the same port # as your host (Ubuntu).

I left Ubunta SSH at the stock port# 22 and set SSH to port # 2200.

Bingo! That was easy :slight_smile: Thanks.

Now to try and work out how to set up the key again (it was a while ago I did it last time!)
EDIT. That was easy too!

Simple process isn’t it.

It is simple yes.
I had one major frustration though. I couldn’t get an install of Ubuntu server to work. It wouldn. In the end I tried the desktop version which did. Weird… (see below).

The other frustration of course is that I don’t fully understand Docker so I need to work on that.

On that, what is the technical difference between a hassio add-on and a ‘native’ Docker container.

Searching on-line didn’t help so I’m not hopeful, but if anyone knows why I got this error trying to install Server edition please tell me. The process was so straightforward, I’d start again if I could get over this problem.

Probing for devices to install to failed
Unfortunately probing for devices to install to failed. Please report a bug on Launchpadm and if possible include the contents of the /var/log/installer directory.

Essentially, nothing.

Which version did you try to use, and how did you try to install it?