HowTo - Ledvance SMART+ Plug Wifi in Home Assistant (Solution)

Do you have a Win10 machine you could try? That’s the only real difference I see.

No. Not one with enough power.
There is just one very old notebook from my son.
Could try to setup a virtual machine.

Or maybe any other idea how to get the needes IDs?


i am stuck at the last command on step 15.

PS D:\Frida> adb shell “/data/local/tmp/frida-server &”
/system/bin/sh: /data/local/tmp/frida-server: No such file or directory

can you help me ? i have root because after typing adb shell i get following message.

PS D:\Frida> adb shell
emulator64_x86_64_arm64:/ # su

thanks in advance.

Hi - where is your Frida-server loaded?

Hi sorry for the late reply.

i started the terminal from the same location where i extracted the Frida server. do you meant that or how can i find the frida server location ?

yes, I had to start in the location ABOVE the directory where the Frida- software is loaded. Please review my post above!

ok i will try it.

There is now a much easier integration available, as shown here:LEDVANCE integration - this is how to do it as per 03/22

1 Like

Okay, I’ve tried your solution, but how can I track current power?
Maybe we have to build a special DTH for SmartThings.

Hey there, can you get/see local key of ledvance devices with this method, maybe on api interface? Cheers

For anyone interessted: I managed to get the local keys now via a python script:


Hi @Flag

So when we have found the local keys. Home Assistant can connect directly to smart+ plug?

Regards Kenneth Dalbjerg

You can use the Local Tuya integration to use the devices in Home Assistant.

Had the same issue running Windows 11, using frida-server 16.0.2 solved the issue.

I must admit i don’t really understand the whole concept: is it enough with just the “Local Tuya integration” or do you also need the “frida-server” running somewhere? Thanks!

How does these configurations translate to the latest update of home assistant?

The -platform does not seem to be used any more, so how will this be rewriten to work?

And I see others have asked the same thing but they did not really get any answer so how did you import your ledvance.yaml file into the configuration.yaml file?

Yes, but how did you implemented the LEDVANCE Plugs ?

I had put into my config.yaml
switch: !include configz_ledvance.yaml

And in the configz_ledvance.yaml I had pasted your first smart plug and it did not work out.

Then I had copied your first plug into my config.yaml and when I checked the configuration I had gotten an error message:

Error loading /config/configuration.yaml: while parsing a block mapping
in "/config/configuration.yaml", line 2, column 1
expected <block end>, but found '-'
in "/config/configuration.yaml", line 33, column 1

and my first 2 lines are here

# Loads default set of integrations. Do not remove.
# Load frontend themes from the themes folder
  themes: !include_dir_merge_named themes

# Text to speech
  - platform: google_translate

and my line 33 starts with “- host…”

# ledvance
- host:
  device_id: 01158006b8fabcdefgh
  local_key: 9c5b5cd03abcdefgh

ID and key have been changed.

Any ideas how to fix it here in the config.yaml and maybe also in the additional configz_ledvance.yaml ?

Thanks a lot

Just wanted to mention what the “2024. reality” is for this. As a very novice user, I’ve managed to integrate 3 Ledvance SMART+ Wifi plugs and one Teckin smart plug very easily.
I’ve added all of them to the Ledvance SMART+ app, then used this python script to get the keys for each device.
Then I used this Local Tuya integration and everything was added perfectly.
I didn’t do anything complicated after, it all worked immediately.

Sounds really great, !! does the electric metering also work?
I bought 9 if them…and now I switched ti HA, …and realized they dont work …
So if this works it is fantastic :partying_face:

To be honest, never tried to set up the power consumption and those things :slight_smile:
Until 10 min ago:

  1. Checked the values that Ledvance app was giving (to have reference values to compare to, to make sure the data I get wouldn’t be gibberish)
  2. Found this: Function Definition-Tuya IoT Development Platform-Tuya Developer
  3. Saw in the above document that DPs 18,19 and 20 are denoting current, power and voltage now, so reconfigured the plug while explicitly mentioning DPs 18,19,20.

And everything was added immediately with correct values (been monitoring Tuya Smart App and Home Assistant for 5 min to double check if the values are similar). So I can confirm it works