Ledvance WiFi bulbs

Hey - thanks for responding. I’m all up and running! I am buying Zigbee stuff in the future.

1 Like

@FlyingHippo, thanks a lot for the screenshot detailing your entity setup, it saved me the trouble of trial-and-error to configure it myself.

I am myself dealing with a Classic A 100 E27 14W Multicolor bulb (#4058075485518)

And only the color temperature (aka white warmth) was different from what you posted.

Here is my config :

Maybe it’ll help you in return, if it works for your lamp as well.



Hey all, Ledvance made consumer life really hard preventing tuya/smartlife integration for customers even though they use tuya’s app core and services. It would be so easy to manage devices locally and with 3rd parties even with customisations, if they didnt remove tuya/smartlife integration from their app. Anyway, looks like there is only one workaround that is getting local key from ledvance for local/3rd party integrations. The problem is its really cumbersome method. I was wondering about getting local key from the files in app folder on a rooted emulator/device? Some of old smart life app versions save local key in plaintext on xml file. Anyone have any experience with that method for Ledvance devices? Cheers

No local file.
You can get localkey only sniffing.

Hey Francesco thanks a lot for your work and guide.

1 Like



This solution took a fair amount of fiddling for me, and in the end it works 20% of the way. When toggling the lightbulb off in Home Assistant, the light does turn off, but only after turning it on via the Alexa app.

The light cannot be turned on from HA, and even after turning it on in Alexa, the colour/brightness cannot be changed from HA.

The state also doesn’t seem to update in the Alexa app, when toggling the lights off in HA, until you tap on the light to ‘refresh’ it in the Alexa app. Then it ‘realises’ that the light has been turned off, and it appears in Alexa as off.

In the configuration.yaml you provided, don’t lines 7 and 8 need entity IDs and a service?

At least, for me, HA gave me yaml errors, until I added a service call and entity ID’s for turn_on / turn_off in the yaml:

  - platform: template
        friendly_name: "Ceiling Light 1"
        temperature_template: "{{states('input_number.temperature_input') | int}}"
        color_template: "({{states('input_number.h_input') | int}}, {{states('input_number.s_input') | int}})"
          service: light.turn_on
          entity_id: light.joes_office_light_1
          service: light.turn_off
          entity_id: light.joes_office_light_1
          service: input_number.set_value
            color_temp: "{{ color_temp }}"
            entity_id: input_number.temperature_input
          - service: input_number.set_value
              value: "{{ h }}"
              entity_id: input_number.h_input
          - service: input_number.set_value
              value: "{{ s }}"
              entity_id: input_number.s_input'

The ‘turn off’ from HA seems to be working fine, but the ‘turn on’ gives the following error in Node-RED:

function : (error)
"TypeError: Cannot read properties of undefined (reading '0')"

The error is with the ‘function’ node, but I have no clue what’s wrong with it or what I need to change.

I also see some errors in Home Assistant itself:

Failed to call service light/turn_on. not a valid value for dictionary value @ data[‘entity_id’]
Failed to call service light/turn_on. extra keys not allowed @ data[‘color_temp’]

Do you have any suggestions?

I’m determined to make this work - my house is FULL of these bulbs!

OK, the entity IDs of my helpers were incorrect (silly mistake).

I’ve corrected them all, and the lights can now be turned on via HA, and the brightness can be set.

However, colour and temp cannot be set from HA (I cannot change them from being set at pure white). The error shown in Node-RED is just “no JSON” on the top routine node, after the ‘switch’.

I think something is going wrong with my config when it comes to the set_color / set_temperature. I still see these errors in HA when trying to change the colour and temperature.

Failed to call service light/turn_on. not a valid value for dictionary value @ data[‘entity_id’]
Failed to call service light/turn_on. extra keys not allowed @ data[‘color_temp’]

thnaks a ton for this threat, was able to add 2 LEDVANCE Wifi SMART+ Outdoor Neon Flex LED stripes for my balcony with this threat and an old rooted android phone! :slight_smile:
config was similar to @BigTweety Classic bulb.

side note there are two different APK’s. One says incorrect password/username or ‘user not exist’.

LEDVANCE APM SMART+ Wi-Fi :ballot_box_with_check:

Hello, Hello, I followed the steps but I get stuck when I try the command (frida-trace -U --decorate -j ‘*!encodeString/isu’ -F) I get :

frida-trace: The term “frida-trace” is not recognized as a cmdlet name, function,
script file or executable program. Check the spelling of the name, or if a path
exists, check that the path is correct and try again.
To Line:1 character : 1

  • frida-trace -U --decorate -j *!encodeString/is -F
  •    + CategoryInfo: ObjectNotFound: (frida-trace:String) [], CommandNotFoundException
       + FullyQualifiedErrorId: CommandNotFoundException

I tried many versions of frida, sill the same, does anyone have any idea how to solve this issue?

I got it working, I just installed frida tools :slight_smile:

is the topic still being worked on?

I’m slowly getting desperate. I’ve been trying to read my Ledvance according to the instructions for some time now.

Unfortunately without success. Unfortunately I can’t find a link for version 1.0.0 anymore :frowning:

Please help

Screenshot 2023-01-25 205237

Hi, you might want to try an easier method via python script I have managed to write:

This method does not require any emulator or rooted android phone.

1 Like

Thank you soo much, thats great !!!

Hello, so now I have the next problem.

How do I get the current, watt and volt values.

into a normal sensor, which I can then integrate into the energy

You have to convert the attribute that corresponds to your current wattage to kWh

Integration - Riemann sum integral - Home Assistant (home-assistant.io)

Not sure wheter this is “Current” or “Current consumption” but something like this (replace with your correct sensor and attribute names)

  - platform: integration
    source: schukobad.currentconsumption
    name: energy_spent_schukobad
    unit_prefix: k
    round: 2
1 Like

got it to work now.

I created the sensor in “template.yaml”.

Then created the Riemann references in the “helpers”.

Maybe it will help someone else too, that’s why I posted it here.

that’s important too

unit_of_measurement: 'W'

is specified so that the whole thing has the right format if you then want to add it to the energy dashboard.
(but only works if you create it with Riemann beforehand)

what can i do with a LDV BT App and a LEDVANCE Bluetooth bulb ?