HowTo - Ledvance SMART+ Plug Wifi in Home Assistant (Solution)

Hi @fspatt ,
thank you for your advice but it has not worked for me.
One thing i noticed, i could update PowerShell to a newer Version.
OOB it used WindowsPowerShell in Version 5.1 and now i’m using PowerShell 7.2.
Other point is, i’m on Win11 x64.

Here what happens for me:

PS C:\Users\andre> cd d:
PS D:\> adb root
adbd is already running as root
PS D:\> adb push frida-server /data/local/tmp/
frida-server\: 1 file pushed, 0 skipped. 272.8 MB/s (46351796 bytes in 0.162s)
PS D:\> adb shell chmod 755 /data/local/tmp/frida-server
PS D:\> adb shell /data/local/tmp/frida-server &

Id     Name            PSJobTypeName   State         HasMoreData     Location             Command
--     ----            -------------   -----         -----------     --------             -------
1      Job1            BackgroundJob   Running       True            localhost            Microsoft.PowerShell.Man…

PS D:\> adb install com-ldvsmartwifi-smart-4.apk
Performing Streamed Install
PS D:\> frida-trace -U --decorate -j '*!*encodeString*/isu' -F
No frontmost application on Android Emulator 5554
PS D:\>

With the newer Version of PowerShell i don’t have an error after the shell command with the &.
Iritating is, that while pasting the shell command, the " are removed. Is this correct?

But i have stil lthe error: No frontmost application on Android Emulator 5554

On another different is, i have a newer Version of Android Studio:

Android Studio Bumblebee | 2021.1.1 Patch 1
Build #AI-211.7628.21.2111.8139111, built on February 1, 2022
Runtime version: 11.0.11+9-b60-7590822 amd64
VM: OpenJDK 64-Bit Server VM by Oracle Corporation
Windows 10 10.0
GC: G1 Young Generation, G1 Old Generation
Memory: 1280M
Cores: 24

Any other suggestions?


Hi - after you issued the “adb shell /data/local/tmp/frida-server &” command, I had to issue a ^C in order to get the command prompt back.

Yes, I used the trace command without quotes.

Which version of Frida server are you running? I was only able to get this to work with this version frida-server-15.0.17-android-x86.xz.

Hi Frank,
as you see in my log i got the command back after the display of this “table”.
Frida server is the same version. I also tried to update the frida tools itself.

Hi @Keules,
Im pretty new to HA. Just got ledvance integraded and would like to have the consumption too.
Could you explain how you imported the ledvance.yaml into your config?
When I integrate it in /packages I get the error: expected a dictionary for dictionary value @ data['packages']['ledvance']
When I integrate it separately I dont know which component I have to use.

Do you have a Win10 machine you could try? That’s the only real difference I see.

No. Not one with enough power.
There is just one very old notebook from my son.
Could try to setup a virtual machine.

Or maybe any other idea how to get the needes IDs?


i am stuck at the last command on step 15.

PS D:\Frida> adb shell “/data/local/tmp/frida-server &”
/system/bin/sh: /data/local/tmp/frida-server: No such file or directory

can you help me ? i have root because after typing adb shell i get following message.

PS D:\Frida> adb shell
emulator64_x86_64_arm64:/ # su

thanks in advance.

Hi - where is your Frida-server loaded?

Hi sorry for the late reply.

i started the terminal from the same location where i extracted the Frida server. do you meant that or how can i find the frida server location ?

yes, I had to start in the location ABOVE the directory where the Frida- software is loaded. Please review my post above!

ok i will try it.

There is now a much easier integration available, as shown here:LEDVANCE integration - this is how to do it as per 03/22

1 Like

Okay, I’ve tried your solution, but how can I track current power?
Maybe we have to build a special DTH for SmartThings.

Hey there, can you get/see local key of ledvance devices with this method, maybe on api interface? Cheers

For anyone interessted: I managed to get the local keys now via a python script:


Hi @Flag

So when we have found the local keys. Home Assistant can connect directly to smart+ plug?

Regards Kenneth Dalbjerg

You can use the Local Tuya integration to use the devices in Home Assistant.

Had the same issue running Windows 11, using frida-server 16.0.2 solved the issue.

I must admit i don’t really understand the whole concept: is it enough with just the “Local Tuya integration” or do you also need the “frida-server” running somewhere? Thanks!

How does these configurations translate to the latest update of home assistant?

The -platform does not seem to be used any more, so how will this be rewriten to work?

And I see others have asked the same thing but they did not really get any answer so how did you import your ledvance.yaml file into the configuration.yaml file?