Hue and Hive unreachable lights showing as on

I have a few hue lights that still use old light switches, hence they spend most of the time off and are just useful to dim when the switch is on.

However, Home Assistant appears to think that they’re always on, when they’re physically switched off.

I have my config as:

    - host: ""
      allow_unreachable: "true"

Actually, having another look, it appears Hue reports the bulb as on, but unreachable. Is HA accepting that it’s on even when it’s unreachable? I would argue it’s more likely to be turned off if it’s unreachable.

I have also just noticed that my Hive bulbs have the same behaviour. They are showing as on, even though they are physically switched off. The Hive app shows them as being off and unreachable.

What actually changes with the “allow_unreachable” toggle? It sounds like unreachable bulbs would be removed, however I’d rather just show them as “off”.

Edit: I managed to turn “off” the unreachable bulbs/rooms in the Hue app, and HA has followed that. I don’t seem to be able to do that for Hive though, and it’s not ideal to toggle this everytime they become unreachable. Is it possible to have a “unreachable_assumed_state” parameter, so we could assume they are either on or off?

I have the same problem here.

Before I used the Hue bridge with home assistant, I had tradfri.
Thus, the display of lamps that were physically turned off, shown as “offline” in Home Assistant was working.
But sadly it seems that the hue component doesn’t support that feature :frowning:

It’s odd that hue doesn’t support it when many other components do :confused:

Thought I’d chip in to say I have this same issue with my Hive bulbs

It seems the awesome developers of HA are working on a solution for this right now: :kissing_heart:

Thank you!

Is it just me? This problem seems to be back for my hive lights.

I’m having the same issue. Does anyone have a solution for this? (Running latest version of Hassio).

I’ve reported this as an issue in github

any news on this?