I can't find AH ip in DHCP list!

I run home assistant with vm, i gave home assistant a static ip and gave the vm network ipv4 the same ip, but when I check my router dhcp list i can’t find it !
when I checked network with fing app, i found that the host have two ip, one of them HA ip.
how I can separate HA ip from the host ?

Which one is listening on port 8123?

What vm software are you using, on what OS ?

I know which one is the HA ip and listening on 8123, but what i want is separate it from host so router treat it as a different device

i use VertualBox on windows 7 64bit

Then you have to set its network to bridged

it’s already set as bridge

Then that is normal. One is your Windows 7, one is your HA vm.

And this I believe is normal also. You’ve assigned a static IP in HAOS, then the HAOS would not ask DHCP server for any new IP, then logically the DHCP list in your router would not have any record of the IP of the HAOS.

A VM never gets an IP, because you have to install a kernel-based OS (in your case HAOS) which get an IPv4 either static or DHCP. If you can provide an IP to your VM you are actually installing a system container instead (e.g. LXC) this is why you have an IP on your VM (it is actually not a VM, we call them VE or OS container). If the later is the case you cannot install HAOS in a container as a container already has an OS. HAOS needs to be installed on a VPS (i.e. a VM), like doing a bare metal server install.

1 Like

Please explain, what has LXC to do with virtualbox ?

sorry I missed the virtualbox thing. You are trying to use the wrong operating environment for HAOS. Win7 and Virtualbox will not be a trouble free environment. If you can install HAOS on that machine bare metal or install Proxmox VE if you want to use the machine for other things.
Win7 and Virtualbox have had their peak days years ago. Now they are old and not very capable. Time to retire them.

1 Like

the problem is HA can’t control devices on local lan when i disconnect internet line the time that the ewelink app works fine

i have problem with local lan control, devices works only on cloud

Then you map out all your environment and settings and configuration and details, so that people here could possibly help.

1 Like

I agree win 7 should be got rid of!

HA works fine on virtualbox. But when he deletes win 7 he could replace it with haos, with or without proxmox.

The ewelink add-on is cloud-based, does not do local control.

Try the sonofflan integration instead

1 Like

the pc that i use as a server is old, when i tried to install windows 10 it became too slow, for that i back to windows 7, now HA works fine the only issue i’m facing is the local control

pc that i use as a server is old, when i tried to install windows 10 it became too slow, for that i back to windows 7, now HA works fine the only problem i’m facing is the local control, maybe it’s better to buy raspberry pi instead of upgrading pc hardware

i am already using AlexxIT sonofflan, it’s work fine until i disconnect internet cable
when i checked system health i got this:

Version|3.0.4 (8a202d5)|

Cloud devices online 3 / 3
Local devices online 0 / 3

all devices firmware update to last version 3.5.1 for switches and TH, 1.0.0 for SPM Main