I can't see my backup files recovered from crashed installation

I’ve just installed a new HA and had to restore from a 2 month old full backup as more recent partial backups would work during the installation process. I’ve now copied the recent partial backups to the backups directory but ‘settings’ ‘backups’ cant see them even after hitting ‘reload’. Their history is that I used Ubuntu in VirtualBox to find and copy them from my previous (damaged) virtual disk image to a windows network location and then used my Samba access to copy them from there to the backup directory. They still have the right .tar extension.
Any suggestions about how to fix this?

This is the preferred way to restore a backup: Common tasks - Operating System - Home Assistant

Indeed, I’m doing what is described in that documentation.
During re-installation it only allowed me to use the most recent full backup (2 months old). Now I’m up & running, I was hoping to restore from a partial backup taken just before the power outage that damaged my previous installion. The relevant .tar file is in the backup directory but the HA ui can’t see it, only the full backup used during re-installation. I tried another partial in case the most recent was damaged in the outage, but it is also not visible in the list of backups to restore from.
I tried “upload backup” and whilst i can navigate to where they all are, it says “unsupported file format” for any tar i choose, including the one i used to reinstall HA.

Could it be the backup restored a different backup location, which is not functioning at the moment (e.g. a samba share that HA no longer can access)?

The installation looks the same with the same IP address & file structure. I had hoped that by copying the tar file into the current backup directory all would be good. Using samba from Windows I can see the files there but HA can’t.

Try to make a new backup, and see if it appears at the same place.

Yes, visible from the UI (+ the 1 I restored from) and in file explorer (with the others I copied there),

Download 7zip
and see if you can open the .tar

If you can open it, we know it is not corrupt and search for another reason.

This issue refers to a similar problem and offers some workarounds. Did you use Firefox for the “upload backup” option? That seems to be the issue. It’s 2 years old but no resolution so may still be an issue.

Upload backup fails with “unsupported file format” under Firefox for Windows · Issue #3639 · home-assistant/supervisor (github.com)

Yes, I can open them all via 7-zip.

“Upload backup” in my post refers to the HA UI functionality (from menu topright).

Right, same thing the issue is referring to. Multiple people said it only works from Chromium based browsers. One said they used SSH to move the file and was able to restore it as well, circumventing the upload backup option altogether.

Maybe it is a permission problem.
If you have ‘Advanced SSH & Web Terminal’ installed, what does this return ?

I just worked out what your meant about the browser. Yes, I was using Firefox, so I opened HA from Chrome - it disn’t produce an error when uploading a backup, but didn’t do anything either.
So, looking at permissions (I don’t know how to copy/paste from SSH)
The 2 old partials are both -rwxr–r-- whereas the newly created one & the 1 I restored from are -rw-r–r–
What does this tell me?

And the names before it, root root ?

Yes. the full line reads:
-rwxr—r-- 1 root root size date name. The two partials have the name in green whereas the others as white

The green does not matter, i just copied an old backup over

it is visible

No errors in the log-file ?

Not that I can see.
As I’ve just read, that execute permission is the only distinguishing feature. Can I remove it?

It does not hurt to try

Is the backup.json present in the .tar