If I closed my terminal, how do I start Home Assistant back up on Ubuntu?

This is probably the most ridiculous question to ask but I’m a complete newbie when it comes to Linux, command prompts, and pretty much anything that isn’t point and click.

I closed to terminal because the UI was taking a while to restart, thinking I could easily force it to restart but now I don’t know the command to start it back up. Thanks for helping!

How did you install HA ?

1 Like

The alternate generic Linux install

sudo systemctl start hassio-supervisor.service

If you ran the hassio install script you don’t need your terminal open for it to run.

It sounds like you messed up your config and it’s not restarting. Just review the log file and fix the problem.

Did you try to restart ubuntu?

Thank you guys for your replies, I was at work so sorry for the delay.

@mcarty, I restarted Ubuntu and went to my to my local IP right away. It loaded but I’m on version 0.62.1 somehow! I just installed HA for the first time last week so I’m lost. I tried the “hassio ha update --version=0.XX.X” command but got “hassio: command not found” in return.

@francisp, I tried you command and I guess it went through as I was back at my normal ~$ bash. I don’t know enough to explain it, sorry.

I’m sure I’m just missing the piece that allows me to run the hassio commands but like I said, I’m very new. Any assumptions in the guide are lost on me. Thank you again for helping guys!


Something is very very wrong. Are you sure you didn’t have an old version installed in python?

No idea. This was a fresh install of Ubuntu as of this weekend. Any suggestions on how to just wipe everything (preferably without wiping Ubuntu)? I only just started some basic integrations and wouldn’t mind starting over.

Stop the 2 services, delete the docker containers, and restart the services.

I’m sorry you’ll have to be more specific. I can follow directions pretty well but I’m lost if they aren’t step by step.

I recommend you look at the script you ran. You’re going to need to spend some time reading and troubleshooting.

I think I was trying to add the HACS store then HA wouldn’t restart. I believe I’ve deleted everything from HACS but I’m still not getting anything.

You installed hassio using a script. I highly recommend you read what that script does and learn a little more about your system.

I’m sorry, you’re trying to help and I really appreciate that, but you’re going over my head. I am going to wipe Ubuntu and start over. I didn’t want to because I’m running a Plex server and people are depending on it but oh well. But I am going take your advice and read into what the install script does, but uh… Can you help me there too? I don’t even know where to begin. Thanks again. I’m brand spanking new but when I get the hang of things it’s not long before I become advanced at it.


This is unnecessary.

What do you need help reading? You ran a script. Go look at what it does. Read the script.

If wiping is unnecessary, what do I do to fix my issue? And which script do I look at? The install scripts? I can see them in the documentations but they’re gibberish to me.

I told you what you needed to do.

Stop the services and remove the docker containers. Then start the services again.

I said to read the install script you ran. I can’t believe people seriously will run any script they see online without trying to understand what it could be doing to your system.

Those are the services that run. Replace the word start with the word stop. Make sure you put sudo in front of it.

Then you need to remove the docker containers and start the services back up.

If you plan on managing a home assistant server, you really need to start learning this stuff.

I’m starting to smell what you’re stepping in. Trust me, I learn quick and will learn as I go. Linux and Home Assistant are literally less than a week old to me so it will take some time for me to learn the language. But…

I found this post that you replied in already with some more detail down below to stop and remove the docker containers. Then ran the install script again and IT WORKED! Any idea how I got to such an old version of HASS? Thank you again for your help. Really saved me from the headache of reinstalling everything again.

No idea.

Reinstalling everything is rarely the right way to fix the problem.

1 Like